cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1272
Views
0
Helpful
1
Replies
Highlighted
Beginner

Nexus 5K Routing Problem

Hi folks,

I'm really having trouble with configuring Nexus 5Ks for IP routing.  I have the L3 daughtercard (this is the first time I've used L3 features - up until now, I  have used only L2 on Nexus) installed and have several VLANs configured.  A host attached to a FEX with an IP address in the appropriate VLAN can ping the default gateway which is an SVI on the 5K, it can ping another SVI on the same 5K but can't ping any hosts that are in any other VLAN.  It is as if IP routing is disabled but this doesn't make any sense.  We have 2 5Ks configured as a vPC pair but only one is doing the routing here...

Below is relevent config - any suggestions what might be missing?

Thanks in advance,

Shane.

!Command: show running-config

!Time: Thu Nov  1 05:39:04 2012

version 5.1(3)N2(1)

no feature telnet

no feature http-server

feature tacacs+

cfs eth distribute

feature interface-vlan

feature hsrp

feature lacp

feature vpc

feature lldp

feature fex

fex 101

  pinning max-links 1

  description "FEX 101 Upper 2K"

vrf context management

  ip route 0.0.0.0/0 10.1.32.1

vrf context vpc-keepalive

vlan 1

vlan 244

vlan 245

vlan 246

vlan 247

vlan 248

vpc domain 1

  role priority 2000

  peer-keepalive destination 10.1.233.15

interface Vlan1

interface Vlan244

  no shutdown

  no ip redirects

  ip address 10.1.244.1/24

interface Vlan245

  no shutdown

  no ip redirects

  ip address 10.1.245.1/24

interface Vlan246

  no shutdown

  no ip redirects

  ip address 10.1.246.1/24

interface Vlan247

  no shutdown

  no ip redirects

  ip address 10.1.247.1/24

interface Vlan248

  no shutdown

  no ip redirects

  ip address 10.1.248.7/24

interface port-channel1

  switchport mode trunk

  switchport trunk allowed vlan 244-248

  spanning-tree port type network

  vpc peer-link

interface port-channel101

  switchport mode fex-fabric

  fex associate 101

interface Ethernet1/24

interface Ethernet1/25

  switchport mode trunk

  switchport trunk allowed vlan 244-248

  channel-group 1 mode active

interface Ethernet1/26

  switchport mode trunk

  switchport trunk allowed vlan 244-248

  channel-group 1 mode active

interface Ethernet1/27

  switchport mode trunk

  switchport trunk allowed vlan 244-248

  channel-group 1 mode active

interface Ethernet1/28

  switchport mode trunk

  switchport trunk allowed vlan 244-248

  channel-group 1 mode active

interface Ethernet1/29

  switchport mode fex-fabric

  fex associate 101

  channel-group 101

interface Ethernet1/30

  switchport mode fex-fabric

  fex associate 101

  channel-group 101

interface Ethernet1/31

  switchport mode fex-fabric

  fex associate 101

  channel-group 101

interface Ethernet1/32

  switchport mode fex-fabric

  fex associate 101

  channel-group 101

interface mgmt0

  ip address 10.1.32.15/24

interface Ethernet101/1/1

  switchport access vlan 247

.................

interface Ethernet101/1/13

  switchport access vlan 245

interface Ethernet101/1/14

  switchport access vlan 247

.....................

interface Ethernet101/1/48

line console

line vty

boot kickstart bootflash:/n5000-uk9-kickstart.5.1.3.N2.1.bin

boot system bootflash:/n5000-uk9.5.1.3.N2.1.bin

ip route 0.0.0.0/0 10.1.248.1

Everyone's tags (4)
1 REPLY 1
Beginner

Nexus 5K Routing Problem

Hi folks, the problem was simple once I've learned the answer... The LANBase license does not come installed on the L3 daughter card which up until now I would have assumed that it would.  The following link describes the problem and resolution;

http://www.ccierants.com/2012/10/occasional-confusing-issues-on-nexus.html

Thanks,

Shane.

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards