cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

285
Views
10
Helpful
11
Replies
Beginner

Nexus 6001 initial setup

Hello, We recently purchased a Nexus 6001 and as far as the basic configuration goes It is complete, the switch can ping and be pinged within the network, I can ssh into it and i can see it when running ip scanners however, any computer or server I have plugged into the SFP ports do not have internet connectivity , If i enter in show int stat and show run it all seems that it is working but I cant get out to the internet. I only need the switch to work layer 2. If there is anything you can do to help me out or guide me where I am going wrong id appreciate it greatly. Ahead of time thank you. I am including the show run and show int stat results:

 

!Command: show running-config
!Time: Wed Feb 8 15:53:19 2017

version 6.0(2)N2(1)
hostname NEXUSSWITCH

feature telnet
feature lldp
feature vtp

username admin password 5 $1$Eo7hdBAU$xDx8m/bxikDB/NCN65QQm0 role network-admin

banner motd #Nexus 6000 Switch
#

ssh key rsa 2048
ip domain-lookup
logging event link-status default
vtp mode transparent
vtp domain PCBU10G
snmp-server user admin network-admin auth md5 0x442dbc43085c1666299fe8ce21addc23
priv 0x442dbc43085c1666299fe8ce21addc23 localizedkey

vrf context management
ip route 0.0.0.0/0 10.10.1.1
vlan 1
port-profile default max-ports 512


interface port-channel1

interface Ethernet1/1

interface Ethernet1/2

interface Ethernet1/3
switchport trunk allowed vlan 1

interface Ethernet1/4

interface Ethernet1/5

interface Ethernet1/6

interface Ethernet1/7

interface Ethernet1/8

interface Ethernet1/9

interface Ethernet1/10

interface mgmt0
ip address 10.10.1.252/24
line console
line vty
boot kickstart bootflash:/n6000-uk9-kickstart.6.0.2.N2.1.bin
boot system bootflash:/n6000-uk9.6.0.2.N2.1.bin

 

--------------------------------------------------------------------------------
Port Name Status Vlan Duplex Speed Type
--------------------------------------------------------------------------------
Eth1/1 -- sfpAbsent 1 full 10G --
Eth1/2 -- sfpAbsent 1 full 10G --
Eth1/3 -- connected 1 full 10G 10Gbase-SR
Eth1/4 -- sfpAbsent 1 full 10G --
Eth1/5 -- sfpAbsent 1 full 10G --
Eth1/6 -- sfpAbsent 1 full 10G --
Eth1/7 -- sfpAbsent 1 full 10G --
Eth1/8 -- sfpAbsent 1 full 10G --
Eth1/9 -- sfpAbsent 1 full 10G --
Po1 -- noOperMem 1 auto auto --
mgmt0 -- connected routed full a-1000 --

 

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Advisor

Re: Nexus 6001 initial setup

If you getting the Data from another switch.

 

Then you should connect to any of the nexus ethernet port (not management - this meant to be management port)

 

PC --- ethe 1/3 ----Ether 1/2----other siwtch

 

inter eth 1/3

description PC connected

switchport mode access  (if you not mentioned any VLAN this means default is VLAN1)

 

inter eth 1/2

description uplink Data switch   <--here is your other data switch connection goes.

switchport mode trunk

 

 

hope this suppose to works as per your post description.

 

 

BB
*** Rate All Helpful Responses ***

View solution in original post

11 REPLIES 11
VIP Expert

Re: Nexus 6001 initial setup

Hi,

To what port you are connecting a PC/laptop for testing?

What vlan the PC/laptop is part of?

Is the 6k supposed to be the vlan/subnet gateway?

What is the IP for that vlan?

HTH

Beginner

Re: Nexus 6001 initial setup

Hello Reza, Port eth1/3, the vlan is 1 and the ip is 10.10.1.195 255.255.255.0

Is there something else that I am missing? Thank you again for your time

VIP Expert

Re: Nexus 6001 initial setup

Hi,

The PC/laptop is connected to port e1/3 and the IP is 10.10.1.195 255.255.255.0

Ok, So, where is the gateway for the PC/laptop?  Is the gateway supposed to be the 6k?

The gateway IP needs to be in the same subnet as the PC.

HTH

Beginner

Re: Nexus 6001 initial setup

Hello the gateway is the router that is IP 10.10.1.1 yes the subnet is a /24 all the way around

VIP Advisor

Re: Nexus 6001 initial setup

 

 

Now sure what port your internet facing router connected

 

in general, this should be like this :

 

PC --- ethe 1/3 ----Ether 1/2----Internet router(NATtting) ----ISP

 

 

interface Ethernet1/3
switchport trunk allowed vlan 1  <-- this need to switch mode access.(if you connecting PC)

 

what port your internet router connected ?

 

 

 

BB
*** Rate All Helpful Responses ***
Beginner

Re: Nexus 6001 initial setup

Hello and thank you for your help, the Nexus switch is getting it's data
from another switch plugged into the mgmt0 port and you're saying I should
change eth1/3 to switch mode access?
VIP Advisor

Re: Nexus 6001 initial setup

If you getting the Data from another switch.

 

Then you should connect to any of the nexus ethernet port (not management - this meant to be management port)

 

PC --- ethe 1/3 ----Ether 1/2----other siwtch

 

inter eth 1/3

description PC connected

switchport mode access  (if you not mentioned any VLAN this means default is VLAN1)

 

inter eth 1/2

description uplink Data switch   <--here is your other data switch connection goes.

switchport mode trunk

 

 

hope this suppose to works as per your post description.

 

 

BB
*** Rate All Helpful Responses ***

View solution in original post

Beginner

Re: Nexus 6001 initial setup

Thank you, Did it this morning received IP and traffic immediately. Able to get out to the internet.

VIP Advisor

Re: Nexus 6001 initial setup

Hello

You dont need a trunk to connect to a interface ruining a single vlan, Just use a access port


interface Ethernet1/3

switchport mode access
spanning-tree portfast
switchport nonegociate



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Beginner

Re: Nexus 6001 initial setup

Hello Paul, thanks for your help I have made the changes with still no internet on the connected PC.

VIP Expert

Re: Nexus 6001 initial setup

Can you post a diagram of your network  and show what device is doing the routing or what device is the gateway for your user subnet?

CreatePlease to create content
Content for Community-Ad