cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
406
Views
0
Helpful
1
Replies

Nexus Switch Problem with selective QinQ Tunnels

Hello

 

I have two problems with QinQ tunnels on Cisco Nexus 3172PQ.

 

The first problem is - when I set the QinQ tunnel on the interface with commands like below, I stop seeing the other party's mac addresses. Before I switch the port to dot1q tunnel mode, I can see these addresses, after switching they are not visible at all.

 

Ethernet 1/24 interface
switchport mode dot1q-tunnel
switchport vlan mapping 100,200-201 dot1qtunnel 1575
switchport trunk allowed vlan 100, 200-201, 1575
spanning-tree bpdufilter enable

 

The second problem is that I can't create two dot1q tunnels at the same time on one interface. Is it possible to create multiple dot1q tunnels on one interface? for example:

 

Ethernet 1/24 interface
switchport mode dot1q-tunnel
switchport vlan mapping 100,200-201 dot1qtunnel 1575
switchport vlan mapping 330.207-209 dot1qtunnel 1576
switchport trunk allowed vlan 100, 200-201, 207-209, 1575, 1576
spanning-tree bpdufilter enable

 

I attach a picture with a map.

Thanks for the help in advance.

Bez tytułu.jpg

1 REPLY 1
pieterh
VIP Collaborator

I guess you'r out of luck about selective Q-in-Q

Selective Q-in-Q tunneling is not supported. All frames entering the tunnel port are subjected to Q-in-Q tagging.

It is also possible the vlan mapping and allowed vlan commands are ignored because of the mode dot-q-tunnel command
(
just like access vlan is ignored on a trunk port)