cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
2439
Views
0
Helpful
2
Replies
CSCO12052693
Beginner

Non-Cisco IP phone QOS port config?

I am trying to configure new 4510 (SUP7-E, License level:entservices) core switch for qos and I am having difficulty in finding the command migration from Version 12.2(31)SGA4 to Version 03.03.01.SG 15.1(1)SG1. We use ShoreTel for our VoIP solution, and in the past any phones directly connected to our core used this format:

interface GigabitEthernet7/3

switchport access vlan 41

switchport trunk encapsulation dot1q

switchport trunk native vlan 41

switchport mode trunk

switchport voice vlan 172

qos trust cos

spanning-tree portfast

!

and any ports connecting other switches used:

!

interface GigabitEthernet6/11

switchport access vlan 250

switchport trunk encapsulation dot1q

switchport trunk native vlan 250

switchport mode trunk

qos trust cos

auto qos voip trust

tx-queue 3

   priority high

   shape percent 33

spanning-tree portfast

service-policy output autoqos-voip-policy

!

but "qos trust" doesn't seem to have the options it use to. After searching I did find recommendations to use mls qos trust dscp, but no mls commands are available. I haven't been able to find any Updated ShoreTel port recommendations. Anyone have same problem?

1 ACCEPTED SOLUTION

Accepted Solutions
acampbell
Advocate

Jeremy,

QOS is now different when you implement SUP6 or 7

QOS is now on by default.

You build MQC policy maps similar to routers

Please see this link to start with.

http://www.cisco.com/en/US/prod/collateral/switches/ps5718/ps4324/white_paper_c11-539588.html

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.

View solution in original post

2 REPLIES 2
acampbell
Advocate

Jeremy,

QOS is now different when you implement SUP6 or 7

QOS is now on by default.

You build MQC policy maps similar to routers

Please see this link to start with.

http://www.cisco.com/en/US/prod/collateral/switches/ps5718/ps4324/white_paper_c11-539588.html

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.

View solution in original post

Alex,

Thanks for a speedy  reply. I'll definitely read the article. Skimming through, that looks alot like some of the configurations that came up when I tried the auto qos voip trust command. It auto created some policies:

service-policy input AutoQos-VoIP-Input-Cos-Policy
service-policy output AutoQos-VoIP-Output-Policy

but I read somewhere not to trust the auto qos for non-cisco phones.

Thanks,

Jeremy