cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

240
Views
0
Helpful
13
Replies
Beginner

overruns errors on router's port

Dear colleagues!

Switch WS-C3650-24TD is connected to router CISCO3925.

We've noticed that if traffic between them is increasing we see overruns errors on a router's port.

How can we solve an issue?
Patch cord was changed several times.

Thank you in advance.

"sh int " output from the switch port:
-------------------------------------------------------------------------

GigabitEthernet1/0/9 is up, line protocol is up (connected)
Hardware is Gigabit Ethernet, address is 502f.a831.c289 (bia 502f.a831.c289)
Description: ### p-mfapn-tunrtr
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 2/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
input flow-control is off, output flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 1368575
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 1210000 bits/sec, 744 packets/sec
5 minute output rate 9557000 bits/sec, 1144 packets/sec
4482579270 packets input, 949965217910 bytes, 0 no buffer
Received 166993 broadcasts (166945 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 166945 multicast, 0 pause input
0 input packets with dribble condition detected
9056018623 packets output, 9326014990433 bytes, 0 underruns
0 output errors, 0 collisions, 2 interface resets
0 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out

"sh int " output from the router port:
-------------------------------------------------------------------------
GigabitEthernet0/2 is up, line protocol is up
Hardware is PQ3_TSEC, address is acf2.c5bf.0f82 (bia acf2.c5bf.0f82)
Description: ### Trunk To P-edgesw02 Gig 1/0/5 ###
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation 802.1Q Virtual LAN, Vlan ID 1., loopback not set
Keepalive set (10 sec)
Full Duplex, 1Gbps, media type is RJ45
output flow-control is unsupported, input flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output 00:00:00, output hang never
Last clearing of "show interface" counters 11w0d
Input queue: 0/75/4506/0 (size/max/drops/flushes); Total output drops: 7
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 7246000 bits/sec, 923 packets/sec
5 minute output rate 1142000 bits/sec, 645 packets/sec
5187861286 packets input, 5340511619819 bytes, 0 no buffer
Received 113139353 broadcasts (0 IP multicasts)
0 runts, 0 giants, 922 throttles
8586110 input errors, 2 CRC, 0 frame, 8586108 overrun, 0 ignored
0 watchdog, 124572 multicast, 0 pause input
3342277603 packets output, 688324844199 bytes, 0 underruns
0 output errors, 0 collisions, 2 interface resets
124572 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
1 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out

"sh run" output from the switch port:
-------------------------------------------------------------------------
interface GigabitEthernet1/0/9
description ### p-mfapn-tunrtr
switchport trunk allowed vlan 2
switchport mode trunk
switchport nonegotiate
switchport block multicast
storm-control multicast level pps 100

"sh run" output from the router port:
-------------------------------------------------------------------------
interface GigabitEthernet0/2.2
encapsulation dot1Q 2
ip address 91.223.109.21 255.255.255.0
ip access-group Block-E in
ip nat outside
no ip virtual-reassembly in

13 REPLIES 13
Highlighted
Hall of Fame Community Legend

Re: overruns errors on router's port

8586110 input errors

That is a cable issue.  Replace the cable between the two.

Beginner

Re: overruns errors on router's port

1. I wrote that "Patch cord was changed several times."

2. They are not just "input errors". They are just "overruns errors".

VIP Mentor

Re: overruns errors on router's port

Hello,

 

the tx/rx load on both interfaces seems rather low. It looks like both ports are copper ports, so you should be able to hardcode both sides to speed 100 duplex full, can you give that a try ?

 

Also, post the output of 'show buffers' from the 3925...

Beginner

Re: overruns errors on router's port

"you should be able to hardcode both sides to speed 100 duplex full, can you give that a try ?"
Yes, we will try to do that.
"show buffers" from 3925:
---------------------------------------------------------------------------
Buffer elements:
540 in free list (500 max allowed)
2454062606 hits, 0 misses, 618 created

Public buffer pools:
Small buffers, 104 bytes (total 52, permanent 50, peak 85 @ 7w0d):
34 in free list (20 min, 150 max allowed)
136917794 hits, 796 misses, 1009 trims, 1011 created
42 failures (0 no memory)
Middle buffers, 600 bytes (total 25, permanent 25, peak 52 @ 7w0d):
24 in free list (10 min, 150 max allowed)
534845131 hits, 332 misses, 936 trims, 936 created
4 failures (0 no memory)
Big buffers, 1536 bytes (total 50, permanent 50):
49 in free list (5 min, 150 max allowed)
253369931 hits, 0 misses, 0 trims, 0 created
0 failures (0 no memory)
VeryBig buffers, 4520 bytes (total 10, permanent 10):
10 in free list (0 min, 100 max allowed)
49729 hits, 0 misses, 0 trims, 0 created
0 failures (0 no memory)
Large buffers, 5024 bytes (total 1, permanent 0, peak 1 @ 7w0d):
1 in free list (0 min, 10 max allowed)
0 hits, 1 misses, 2227 trims, 2228 created
1 failures (0 no memory)
Huge buffers, 18024 bytes (total 5, permanent 0, peak 28 @ 7w0d):
5 in free list (4 min, 10 max allowed)
2328480 hits, 1055 misses, 9474 trims, 9479 created
0 failures (0 no memory)

Interface buffer pools:
Syslog ED Pool buffers, 600 bytes (total 132, permanent 132):
100 in free list (132 min, 132 max allowed)
566683 hits, 0 misses
pak coalesce engine buffers, 1536 bytes (total 514, permanent 256, peak 514 @ 00:44:24):
1 in free list (0 min, 512 max allowed)
384 hits, 129 misses, 0 trims, 258 created
0 failures (0 no memory)
512 max cache size, 511 in cache
1375154561 hits in cache, 1627 misses in cache
SEC Eng Packet buffers, 1700 bytes (total 1024, permanent 1024):
0 in free list (0 min, 1024 max allowed)
1024 hits, 0 fallbacks
1024 max cache size, 1024 in cache
0 hits in cache, 0 misses in cache
IPC buffers, 4096 bytes (total 2, permanent 2):
1 in free list (1 min, 8 max allowed)
1 hits, 0 fallbacks, 0 trims, 0 created
0 failures (0 no memory)

Header pools:
Header buffers, 0 bytes (total 768, permanent 768):
256 in free list (128 min, 1024 max allowed)
512 hits, 0 misses, 0 trims, 0 created
0 failures (0 no memory)
512 max cache size, 512 in cache
8675273 hits in cache, 0 misses in cache

Particle Clones:
1024 clones, 9344437 hits, 0 misses

Public particle pools:
F/S buffers, 256 bytes (total 768, permanent 768):
256 in free list (128 min, 1024 max allowed)
512 hits, 0 misses, 0 trims, 0 created
0 failures (0 no memory)
512 max cache size, 512 in cache
9344473 hits in cache, 0 misses in cache
Normal buffers, 1548 bytes (total 3840, permanent 3840):
3840 in free list (128 min, 4096 max allowed)
924 hits, 0 misses, 0 trims, 0 created
0 failures (0 no memory)

Private particle pools:
HQF buffers, 0 bytes (total 2000, permanent 2000):
2000 in free list (500 min, 2000 max allowed)
0 hits, 0 misses, 0 trims, 0 created
0 failures (0 no memory)
IDS SM buffers, 240 bytes (total 128, permanent 128):
0 in free list (0 min, 128 max allowed)
128 hits, 0 fallbacks
128 max cache size, 128 in cache
0 hits in cache, 0 misses in cache
SEC Eng Particle Header buffers, 256 bytes (total 1024, permanent 1024):
0 in free list (0 min, 1024 max allowed)
1024 hits, 0 fallbacks
1024 max cache size, 1024 in cache
0 hits in cache, 0 misses in cache
GigabitEthernet0/0 buffers, 1664 bytes (total 768, permanent 768):
0 in free list (0 min, 768 max allowed)
768 hits, 0 fallbacks
768 max cache size, 512 in cache
315006486 hits in cache, 0 misses in cache
GigabitEthernet0/1 buffers, 1664 bytes (total 768, permanent 768):
0 in free list (0 min, 768 max allowed)
768 hits, 0 fallbacks
768 max cache size, 512 in cache
11356536 hits in cache, 0 misses in cache
GigabitEthernet0/2 buffers, 1664 bytes (total 768, permanent 768):
0 in free list (0 min, 768 max allowed)
768 hits, 0 fallbacks
768 max cache size, 508 in cache
127540010 hits in cache, 0 misses in cache
SEC Eng Particle buffers, 1700 bytes (total 1024, permanent 1024):
0 in free list (0 min, 1024 max allowed)
1024 hits, 0 misses
1024 max cache size, 1024 in cache
0 hits in cache, 0 misses in cache
VIP Mentor

Re: overruns errors on router's port

Hello,

 

based on your output, try and globally configure the buffers as below:

 

buffers small permanent 100
buffers small min-free 40
buffers small max-free 300

 

buffers middle permanent 50
buffers middle min-free 20
buffers middle max-free 300

 

buffers huge permanent 15
buffers huge min-free 10
buffers huge max-free 20

Beginner

Re: overruns errors on router's port

We've set on router:

 

buffers small permanent 100 
buffers small min-free 40 
buffers small max-free 300

buffers middle permanent 50 
buffers middle min-free 20
buffers middle max-free 300

buffers huge permanent 15
buffers huge min-free 10
buffers huge max-free 20

 

but i didn't help - overruns errors is going on to increase.

 

Then we've set "hold-queue 1024" on router's interface but no result...

 

Any idea more?

 

VIP Advocate

Re: overruns errors on router's port

Hi,

Something for note down as:

922 throttles: The number of times the receiver on the port is disabled, possibly because of buffer or processor overload. 

Common Causes: Packets which can increase the processor overload include IP packets with options, expired TTL, non-ARPA encapsulation, fragmentation, tunelling, ICMP packets, packets with MTU checksum failure, RPF failure, IP checksum and length errors.


8586108 overrun:The number of times the receiver hardware was unable to hand received data to a hardware buffer. Common Cause: The input rate of traffic exceeded the ability of the receiver to handle the data.

 

It is advised to check with the manual setting of Duplex, speed and with other switch port on the switch. 

 

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!
Beginner

Re: overruns errors on router's port

We've implemented "speed 1000"/"duplex full" on ports of switch and router but overruns errors ig going on to increase.
Any idea more?

VIP Mentor

Re: overruns errors on router's port

Hello,

 

the idea was to set the speed to 100 (not 1000) on both sides (and duplex full)...did you try that ?

Beginner

Re: overruns errors on router's port

Georg, THANK YOU for your idea with "buffers", we'll try to do it today in the evening.
"speed to 100" - if it EVEN fixes a problem we couldn't use it permanently.
Beginner

Re: overruns errors on router's port

We've set on router:

 

buffers small permanent 100 
buffers small min-free 40 
buffers small max-free 300

buffers middle permanent 50 
buffers middle min-free 20
buffers middle max-free 300

buffers huge permanent 15
buffers huge min-free 10
buffers huge max-free 20

 

but i didn't help - overruns errors is going on to increase.

 

Then we've set "hold-queue 1024" on router's interface but no result...

 

Any idea more?

VIP Mentor

Re: overruns errors on router's port

Hello,

 

with those increased buffers, do you still see 'misses' in the 'show buffers' output for the small, middle, and huge buffers ?

Beginner

Re: overruns errors on router's port


@Georg Pauwen wrote:

with those increased buffers, do you still see 'misses' in the 'show buffers' output for the small, middle, and huge buffers ?


Georg, yes, we do:

 

Public buffer pools:
Small buffers, 104 bytes (total 102, permanent 100, peak 102 @ 08:42:33):
84 in free list (40 min, 300 max allowed)
139256118 hits, 796 misses, 1009 trims, 1011 created
42 failures (0 no memory)
Middle buffers, 600 bytes (total 50, permanent 50, peak 52 @ 7w0d):
49 in free list (20 min, 300 max allowed)
542013157 hits, 336 misses, 948 trims, 948 created
4 failures (0 no memory)
Big buffers, 1536 bytes (total 50, permanent 50):
49 in free list (5 min, 150 max allowed)
258609515 hits, 0 misses, 0 trims, 0 created
0 failures (0 no memory)
VeryBig buffers, 4520 bytes (total 10, permanent 10):
10 in free list (0 min, 100 max allowed)
54077 hits, 0 misses, 0 trims, 0 created
0 failures (0 no memory)
Large buffers, 5024 bytes (total 1, permanent 0, peak 1 @ 7w0d):
1 in free list (0 min, 10 max allowed)
0 hits, 1 misses, 2271 trims, 2272 created
1 failures (0 no memory)
Huge buffers, 18024 bytes (total 15, permanent 15, peak 28 @ 7w0d):
15 in free list (10 min, 20 max allowed)
2332391 hits, 1056 misses, 9560 trims, 9560 created
0 failures (0 no memory)

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards