cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Ask the Expert- SD-WAN

1765
Views
0
Helpful
2
Replies
Highlighted
Beginner

Packet loss with LACP 3560E

I have a cisco 3560E switch setup with LACP, when using LACP i receive alot of packet loss / output drops

When a ping from the server behind LACP:

--- google.com ping statistics ---

44 packets transmitted, 39 received, 11% packet loss, time 42990ms

any idea what would cause this packet loss with lacp?

some output from the switch:

Port-channel12 is up, line protocol is up (connected)

  Hardware is EtherChannel, address is d0d0.fd58.7390 (bia d0d0.fd58.7390)

  Description: LACP-PORT

  MTU 1500 bytes, BW 4000000 Kbit/sec, DLY 10 usec,

     reliability 255/255, txload 31/255, rxload 30/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, link type is auto, media type is unknown

  input flow-control is off, output flow-control is unsupported

  Members in this channel: Gi0/12 Gi0/16 Gi0/17 Gi0/18

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output 00:00:00, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 1214

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 479503000 bits/sec, 87693 packets/sec

  5 minute output rate 486574000 bits/sec, 85857 packets/sec

     225358444 packets input, 151428473390 bytes, 0 no buffer

     Received 334 broadcasts (330 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 330 multicast, 0 pause input

Configuration:
 

!

interface Port-channel12

description LACP-PORT

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2

switchport mode trunk

spanning-tree portfast trunk

!

!

interface GigabitEthernet0/12

description LACP-eth2

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2

switchport mode trunk

channel-group 12 mode active

!

!

interface GigabitEthernet0/16

description LACP-eth1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2

switchport mode trunk

channel-group 12 mode active

!

Everyone's tags (3)
2 REPLIES 2
Advisor

Re: Packet loss with LACP 3560E

  Make sure all 4 ports in the port channel are up and active and none of the physical interfaces are showing errors. on either the switch side or the server side.  You are only showing 2 ports in the port channel when there are actually 4 ports configured , verify config and get rid of the other 2 ports if you are not using 4 ports in your setup .

Members in this channel: Gi0/12 Gi0/16 Gi0/17 Gi0/18

Beginner

Packet loss with LACP 3560E

All ports and the portchannel are all up:

Port      Name               Status       Vlan       Duplex  Speed Type

Gi0/12    LACP-eth2          connected    trunk      a-full a-1000 10/100/1000BaseTX

Gi0/16    LACP-eth1          connected    trunk      a-full a-1000 10/100/1000BaseTX

Gi0/17    LACP-eth3          connected    trunk      a-full a-1000 10/100/1000BaseTX

Gi0/18    LACP-eth0          connected    trunk      a-full a-1000 10/100/1000BaseTX

Po12      LACP-PORT          connected    trunk      a-full a-1000

sorry didn't include the last two ports, I didn't want to make my post to long here is the configuration for the last two also:

!

interface GigabitEthernet0/17

description LACP-eth3

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2

switchport mode trunk

channel-group 12 mode active

!

interface GigabitEthernet0/18

description LACP-eth0

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2

switchport mode trunk

channel-group 12 mode active

!

i also have this line in the config:

port-channel load-balance src-dst-ip

Not sure if that is correct..

#sh etherchannel 12 sum

Group  Port-channel  Protocol    Ports

------+-------------+-----------+-----------------------------------------------

12     Po12(SU)        LACP      Gi0/12(P)   Gi0/16(P)   Gi0/17(P)  

                                 Gi0/18(P)  

appreciate any help here, let me know if you need any more info!

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards