cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
2607
Views
1
Helpful
2
Replies
rmv72
Beginner

policy-map AutoQoS-Police

Hi,

policy-map AutoQoS-Police- attached to interface nothing shows ( 0 bytes,0 packets). Anyway traffic is above 0.

How to understand it?

Regards,

Mike

Switch Ports Model              SW Version            SW Image                

------ ----- -----              ----------            ----------              

*    1 52    WS-C3560V2-48PS    12.2(50)SE1           C3560-IPBASEK9-M   

!

class-map match-all AutoQoS-VoIP-RTP-Trust

match ip dscp ef

class-map match-all AutoQoS-VoIP-Control-Trust

match ip dscp cs3  af31

!

!

policy-map AutoQoS-Police-CiscoPhone

class AutoQoS-VoIP-RTP-Trust

  set dscp ef

  police 320000 8000 exceed-action policed-dscp-transmit

class AutoQoS-VoIP-Control-Trust

  set dscp cs3

  police 32000 8000 exceed-action policed-dscp-transmit

!        

!        

!  

interface FastEthernet0/14

switchport access vlan 20

switchport mode access

switchport voice vlan 10

srr-queue bandwidth share 10 10 60 20

priority-queue out

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

spanning-tree portfast

service-policy input AutoQoS-Police-CiscoPhone

end

#sh policy-map int f0/14

FastEthernet0/14

  Service-policy input: AutoQoS-Police-CiscoPhone

    Class-map: AutoQoS-VoIP-RTP-Trust (match-all)

      0 packets, 0 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: ip dscp ef (46)

    Class-map: AutoQoS-VoIP-Control-Trust (match-all)

      0 packets, 0 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: ip dscp cs3 (24) af31 (26)

    Class-map: class-default (match-any)

      0 packets, 0 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: any

        0 packets, 0 bytes

        5 minute rate 0 bps

1 ACCEPTED SOLUTION

Accepted Solutions
Andrew Gossett
Cisco Employee

The "show policy-map interface" command is not supported on this platform (2960/3560/3750).  It is documented in the configuration guide:

"Do not use the show policy-map  interface privileged EXEC command to display classification information for incoming traffic. The control-plane  and interface keywords are not supported, and the statistics shown in the display should be ignored."

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/12.2_52_se/configuration/guide/swqos.html#wp1021811

If you want to see the amount of packets dropped by a policer on a particular port, you will need to use the "show mls qos interface x/x statistics":

3750-A#show mls qos int g1/0/2 statistics

GigabitEthernet1/0/2 (All statistics are in packets)

Policer: Inprofile:     39287773 OutofProfile:         4921

                               |                          |

                               |                          --- number of packets "exceeded"

                               ------------------------------ number of packets "conformed"

To verify that a policy is correctly remarking traffic, the best way on this platform is to run the above command and check the statistics for outgoing dscp and cos values.

-Andy

View solution in original post

2 REPLIES 2
Andrew Gossett
Cisco Employee

The "show policy-map interface" command is not supported on this platform (2960/3560/3750).  It is documented in the configuration guide:

"Do not use the show policy-map  interface privileged EXEC command to display classification information for incoming traffic. The control-plane  and interface keywords are not supported, and the statistics shown in the display should be ignored."

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/12.2_52_se/configuration/guide/swqos.html#wp1021811

If you want to see the amount of packets dropped by a policer on a particular port, you will need to use the "show mls qos interface x/x statistics":

3750-A#show mls qos int g1/0/2 statistics

GigabitEthernet1/0/2 (All statistics are in packets)

Policer: Inprofile:     39287773 OutofProfile:         4921

                               |                          |

                               |                          --- number of packets "exceeded"

                               ------------------------------ number of packets "conformed"

To verify that a policy is correctly remarking traffic, the best way on this platform is to run the above command and check the statistics for outgoing dscp and cos values.

-Andy

View solution in original post

Thank you!