cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
676
Views
0
Helpful
4
Replies

Port Channel between Ubiquiti EdgeSwitch and Cisco 9300

PACC
Level 1
Level 1

Hi all,

I'm trying to create a port channel from an EdgeSwitch 24 to a Cisco 9300, but after testing by connecting just one cable I don't get any connectivity between them. The arp table on the 9300 shows the IP address of the edgeswitch but an incomplete mac address. I also noted an odd behaviour; both switches management IP's are on the same subnet, and after connecting them, the arp table on the 9300 begins listing all the free IP's in that subnet with an Incomplete mac address.

A show lacp neighbor on the Cisco 9300 shows the EdgeSwitch mac address associated with interface GigabitEthernet1/0/2 on channel group 4.

I have successfully connected the two via a basic trunk, but want a port channel. If I remove the channel-group 4 mode active command from the Cisco interface, the link works fine as a normal trunk port.

Here is the relevant config from both (just the config on the two ports I am testing with for brevity):

Cisco 9300 (17.3.4)

interface Port-channel4
 switchport mode trunk

interface GigabitEthernet1/0/2
 switchport mode trunk
 channel-group 4 mode active

EdgeSwitch 24

interface 0/23
  switchport mode trunk
interface lag 1
  switchport mode trunk

I have a Cisco 3750 switch. I configured a port-channel on it as below:

interface Port-channel1
  switchport trunk encapsulation dot1q
  switchport mode trunk

interface GigabitEthernet1/0/23
  switchport trunk encapsulation dot1q
  switchport mode trunk
  channel-group 1 mode active

And it successfully connects to the EdgeSwitch (no configuration change on the EdgeSwitch).

The Cisco 9300 does not have the encapsulation dot1q command.  Is there something else I have missed?

thanks

jc

1 Accepted Solution

Accepted Solutions

PACC
Level 1
Level 1

Solved! Just had to set the edgeswitch management vlan to match the vlan the rest of the network knows that subnet to be in.

Silly thing to miss really...

View solution in original post

4 Replies 4

marce1000
VIP
VIP

 

 - Check this thread for hints : https://community.ui.com/questions/Link-aggregation-between-UniFi-Switch-and-Cisco-Switch/6c20f2a4-5d1f-4bc6-aab6-c165daaf9dce
                      encapsulation dot1q is no longer needed on the 9300 because it is the default, 

 M.



-- Each morning when I wake up and look into the mirror I always say ' Why am I so brilliant ? '
    When the mirror will then always repond to me with ' The only thing that exceeds your brilliance is your beauty! '

How many vlan in trunk?

PACC
Level 1
Level 1

Thanks for the replies.

@marce1000I checked the config to make sure there were no stray vlans on the EdgeSwitch and it is only as I posted.

@MHM Cisco WorldThere are 36 vlans in the Cisco database, and 7 in the EdgeSwitch database.  I have not applied any allowed vlan commands.  The link works fine as a basic trunk.

I enabled lacp debugging (debug lacp) on the 9300, and after connecting them together I could see the interface and port-channel come online, but there were no debug messages at all.

 

PACC
Level 1
Level 1

Solved! Just had to set the edgeswitch management vlan to match the vlan the rest of the network knows that subnet to be in.

Silly thing to miss really...

Review Cisco Networking for a $25 gift card