cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1710
Views
0
Helpful
7
Replies
Highlighted
Beginner

Port-Channel drops traffic temporarily when 1 port goes down

Hello, I have a lab environment with a layer 3 (3850) switch that has a port-channel with a layer 2 4506. What i'm seeing in the logs is a port drops off, then users come over saying they have lost their remote session into the lab:

 

Sep 25 09:46:22: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/3, changed state to up
Sep 25 10:28:51: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/3, changed state to down
Sep 25 10:28:58: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/3, changed state to up

 

My config on the 3850 is:

interface GigabitEthernet1/0/3
 switchport mode trunk
 channel-group 2 mode active
end

Lab#sho run int gi 1/0/4
Building configuration...

Current configuration : 90 bytes
!
interface GigabitEthernet1/0/4
 switchport mode trunk
 channel-group 2 mode active
end

and on the 4506:

interface GigabitEthernet2/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 logging event link-status
 logging event trunk-status
 channel-group 2 mode active
end

4506swa-04#sho run int gi 2/2
Building configuration...

Current configuration : 181 bytes
!
interface GigabitEthernet2/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 logging event link-status
 logging event trunk-status
 channel-group 2 mode active
end

The network outage is minimal, but enough to kill the remote sessions. I have replaced the cable and there are no errors on the interfaces. Why is there an outage with a 2 port channel when 1 port goes down? 

 

Thanks for any advice.

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
VIP Expert

Hello,

on a side note, you might want to try and configure:

no port-channel standalone-disable

on your port channel interfaces (if your IOS supports it). This basically prevents the entire channel from going down when one side becomes unresponsive...

View solution in original post

7 REPLIES 7
Highlighted
VIP Mentor

Hello

Are both physcail interfaces in a up/up state?

Have you tried changing the cabling/ports and recreating the PC .

Can you post -

Show etherchannel summary
show etherchannel port-channel

 

res
Paul



res
Paul



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted
Beginner

Try changing the negotiation protocol used for establishing the port-channel.

In your case you are using LACP as indicated by the word "active" at the end of "channel-group 2 mode active"

 

Try using PaGP (Cisco Proprietary) - keyword is "desirable"

If this doesn't improve things, turn off negotiation protocol altogether by using keyword "on".

 

Also, perform a "shutdown" on the interface before changing the ocnfiguration, this tends to flush out any errors and such, once you're happy, issue a "no shutdown" to bring it back up.

 

Best of luck, keep us posted.

Highlighted
Beginner

Show Etherchannel Summary on 4506:

Number of channel-groups in use: 2
Number of aggregators:           2

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SD)          -
2      Po2(SU)         LACP      Gi2/1(P)    Gi2/2(P)

Show Etherchannel Summary on 4506:

 Channel-group listing:
                ----------------------

Group: 1
----------
                Port-channels in the group:
                ---------------------------

Port-channel: Po1
------------

Age of the Port-channel   = 313d:22h:43m:01s
Logical slot/port   = 11/1          Number of ports = 0
GC                  = 0x00000000
Port state          = Port-channel Ag-Not-Inuse
Protocol            =    -
Port security       = Disabled


Group: 2
----------
                Port-channels in the group:
                ---------------------------

Port-channel: Po2    (Primary Aggregator)

------------

Age of the Port-channel   = 313d:22h:43m:04s
Logical slot/port   = 11/2          Number of ports = 2
Port state          = Port-channel Ag-Inuse
Protocol            =   LACP
Port security       = Disabled

Ports in the Port-channel:

Index   Load   Port     EC state        No of bits
------+------+------+------------------+-----------
  1     00     Gi2/1    Active             0
  0     00     Gi2/2    Active             0

Time since last port bundled:    0d:08h:14m:16s    Gi2/1
Time since last port Un-bundled: 0d:08h:14m:23s    Gi2/1

Show Etherchannel Summary on 3850:

Number of channel-groups in use: 2
Number of aggregators:           2

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(RU)         LACP      Gi1/0/1(P)  Gi1/0/2(P)
2      Po2(SU)         LACP      Gi1/0/3(P)  Gi1/0/4(P)

show etherchannel port-channel on 3850:

 

Group: 1
----------
                Port-channels in the group:
                ---------------------------

Port-channel: Po1    (Primary Aggregator)

------------

Age of the Port-channel   = 44d:22h:47m:50s
Logical slot/port   = 12/1          Number of ports = 2
HotStandBy port = null
Passive port list   = Gi1/0/1 Gi1/0/2
Port state          = Port-channel L3-Ag Ag-Inuse
Protocol            =   LACP
Port security       = Disabled

Ports in the Port-channel:

Index   Load   Port     EC state        No of bits
------+------+------+------------------+-----------
  0     00     Gi1/0/1  Active             0
  0     00     Gi1/0/2  Active             0

Time since last port bundled:    44d:22h:22m:18s    Gi1/0/2
Time since last port Un-bundled: 44d:22h:40m:41s    Gi1/0/1

Group: 2
----------
                Port-channels in the group:
                ---------------------------

Port-channel: Po2    (Primary Aggregator)

------------

Age of the Port-channel   = 44d:22h:47m:50s
Logical slot/port   = 12/2          Number of ports = 2
HotStandBy port = null
Port state          = Port-channel Ag-Inuse
Protocol            =   LACP
Port security       = Disabled

Ports in the Port-channel:

Index   Load   Port     EC state        No of bits
------+------+------+------------------+-----------
  0     00     Gi1/0/3  Active             0
  0     00     Gi1/0/4  Active             0

Time since last port bundled:    0d:08h:16m:42s    Gi1/0/4
Time since last port Un-bundled: 0d:08h:16m:46s    Gi1/0/4

Thanks

Highlighted
VIP Mentor

Hi

Your configuration looks fine, have you tried to replace the SFP (if apply) also check the speed and duplex. Or try to use other ports. 

 




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<
Highlighted
Beginner

The Duplex and Speed look good. They are copper cables. I can try and use a different port and see if that helps.

Highlighted
VIP Expert

Hello,

on a side note, you might want to try and configure:

no port-channel standalone-disable

on your port channel interfaces (if your IOS supports it). This basically prevents the entire channel from going down when one side becomes unresponsive...

View solution in original post

Highlighted
Beginner

This command:

 

no port-channel standalone-disable

 

does seem to keep the port-channel up. Thanks! Now i just need to see why the interface is getting over subscribed.

 

Thanks for the help

Content for Community-Ad