cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1843
Views
0
Helpful
13
Replies
Highlighted

Port Channel issue between VSS 2x3850 and Cross-stack 2x3850

Hi,

I have a strange issue.

at the main office i have 2 3850-48XS-S with VSS stack and at the remote offic 2 3850-12XS-S cross-stack.

i want to activated a port-channel between these two stack.

when i desactivated one link for tested, it's ok

but when i desactivated the second link (after réactivated the first), nothing works.

 

When the 2 link is activated, there are only traffic under the first link, nothing under the second.

 

---------------------------------------------------------------------------

interface Port-channel3
 description vers-faouet
 switchport trunk native vlan 99
 switchport trunk allowed vlan 99,300
 switchport mode trunk
 switchport nonegotiate

 

VSS SWITCH

interface TenGigabitEthernet1/0/3    and      interface TenGigabitEthernet2/0/3
 switchport trunk native vlan 99
 switchport trunk allowed vlan 99,300
 switchport mode trunk
 switchport nonegotiate
 channel-group 3 mode on
 ip nbar protocol-discovery

 

CROSSSTACK SWITCH

interface TenGigabitEthernet1/0/3    and      interface TenGigabitEthernet2/0/3
 switchport trunk native vlan 99
 switchport trunk allowed vlan 99,300
 switchport mode trunk
 switchport nonegotiate
 channel-group 3 mode on
 ip nbar protocol-discovery

 

---------------------------------------------------------------------------

I have also test this but same problem

 

interface Port-channel3
 description vers-faouet
 switchport trunk native vlan 99
 switchport trunk allowed vlan 99,300
 switchport mode trunk
 switchport nonegotiate

 

VSS SWITCH

interface TenGigabitEthernet1/0/3    and      interface TenGigabitEthernet2/0/3
 switchport trunk native vlan 99
 switchport trunk allowed vlan 99,300
 switchport mode trunk
 switchport nonegotiate

 channel-protocole lacp
 channel-group 3 mode active
 ip nbar protocol-discovery

 

CROSSSTACK SWITCH

interface TenGigabitEthernet1/0/3    and      interface TenGigabitEthernet2/0/3
 switchport trunk native vlan 99
 switchport trunk allowed vlan 99,300
 switchport mode trunk
 switchport nonegotiate

 channel-protocole lacp
 channel-group 3 mode active
 ip nbar protocol-discovery

 

---------------------------------------------------------------------------

I have also test this but same problem

 

interface Port-channel3
 description vers-faouet
 switchport trunk native vlan 99
 switchport trunk allowed vlan 99,300
 switchport mode trunk
 switchport nonegotiate

 

VSS SWITCH

interface TenGigabitEthernet1/0/3    and      interface TenGigabitEthernet2/0/3
 switchport trunk native vlan 99
 switchport trunk allowed vlan 99,300
 switchport mode trunk
 switchport nonegotiate

 channel-protocole lacp
 channel-group 3 mode active
 ip nbar protocol-discovery

 

CROSSSTACK SWITCH

interface TenGigabitEthernet1/0/3    and      interface TenGigabitEthernet2/0/3
 switchport trunk native vlan 99
 switchport trunk allowed vlan 99,300
 switchport mode trunk
 switchport nonegotiate

 channel-protocole lacp
 channel-group 3 mode passive
 ip nbar protocol-discovery

 

----------------------------------------------------

Somebody have idea for resolve my problem?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

I have found the resolve issue!

i havé upgrade remote stack with:

- upgrade to 16.6.2

- activated Port-Channel mode lacp (active/active)

- activated cli « lacp rate fast » to physical Link of Port-Channel => because i have L2 provider fiber box.

View solution in original post

13 REPLIES 13
Highlighted
Beginner

Could you paste a diagram? Especially for the cross-stack devices.

Highlighted
Collaborator

Hello,

With both links are active what is the output of "show etherchannel 3 summary"from both switches?

With both links active what is the output of "show cdp neighbor" from both switches?

 

Also, without touching the physical ports, cut and paste the configs for the port-channel 3 interfaces into both switches. I say this just to make sure the physical interfaces acquire the proper configs. I have found that sometimes if you configure a physical interface and just add it to the port channel sometimes things get a little screwy and this just helps get things in line.

 

Regards

 

Highlighted

When i check with "show etherchannel 3 summary" and "show cdp neighbor"on all switch, all output it's ok.

I i have test without port-channel configuration, with spanning-tree enable, it's ok, no problem the second link work fine if i disable the first link.

 

i have cut and past configuration but same problem

 

but i use "case RAD" for convert ethernet to fiber, it's a fulle L2 provider equipment, it's block nothing same as a direct optical fiber.

Highlighted
Beginner

Please, send the following information:

For VSS:

  • sh switch virtual
  • sh switch virtual role
  • sh switch virtual link
  • sh switch virtual link port-channel
  • sh etherchannel sum

For stacked switches:

  • sh etherchannel sum
  • sh switch

 

Highlighted

actually, i can't to do the "sh" command.

 

You can seen the attach configuration.

 

 

Can you confirme that my vss configuration it's ok for 3850

stackwise-virtual
 domain 101

!

interface TenGigabitEthernet1/0/45
 stackwise-virtual dual-active-detection
!
interface TenGigabitEthernet1/0/47
 stackwise-virtual link 1
 !
 interface TenGigabitEthernet1/0/48
 stackwise-virtual link 1

!
interface TenGigabitEthernet2/0/45
 stackwise-virtual dual-active-detection
!
interface TenGigabitEthernet2/0/47
 stackwise-virtual link 1
 !
 interface TenGigabitEthernet2/0/48
 stackwise-virtual link 1

Highlighted

Something in your VSS configuration doesn't convince me. Normally, when you are going to use 2 interfaces to build the VSS domain, a port-channel is required, but I don't see that in your configuration.

 

I'd say you will need to re-check the VSS configuration.

Highlighted

For 3850, no port Channel for VSS

Highlighted

Check this: https://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst3850/software/release/16-3/configuration_guide/b_163_consolidated_3850_cg/b_163_consolidated_3850_cg_chapter_010101001.pdf

 

Perhaps I am misunderstanding it, but read the section 'Multichassis EtherChannels', third paragraph, last phrase.

Highlighted
Hall of Fame Community Legend

Post the complete output to the command "sh version". I remembered seeing a bug involving etherchannels and 3650/3850.
Highlighted

For vss: 16.6.2

for stack: 03.07.05E

Highlighted
Hall of Fame Community Legend


@Gilles Dellaccio wrote:

For vss: 16.6.2

for stack: 03.07.05E


CSCve29061

Do not, under any circumstances, load 16.X because it is very, very unstable.  If possible, stay with 3.6.X or 3.7.X.  

Highlighted

I have found the resolve issue!

i havé upgrade remote stack with:

- upgrade to 16.6.2

- activated Port-Channel mode lacp (active/active)

- activated cli « lacp rate fast » to physical Link of Port-Channel => because i have L2 provider fiber box.

View solution in original post

Highlighted

Thanks for sharing your solution.

Content for Community-Ad