cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1985
Views
15
Helpful
14
Replies
mateens
Beginner

Port channel(MEC) issue with HP procurve

Hi,

I have a pair of cisco 9407R in stackwise virtual. Trying to do multi chasis port channel using lacp with HP pro curve 5412zl. Port channel stays active for few sec and then goes is in err-disable state.

 

Gi 1/6/0/37 & Gi 2/6/0/37 on Cisco are connected to C23 & C24 on HP.

 

HP config:

 

SW-A:

 

vlan 140

   name "Managementnett"

ip address xxxxxxxxxxx

   exit

 

interface C23

lacp active

interface C24

lacp active

 

trunk C23-C24 trk1 lacp

 

vlan 140 tagged trk1

vlan 1 untagged trk1

 

 

 

 

 

Cisco config:

 

vlan 140

name mgmt

int vlan 140 

ip address xxxxxxxxxxxxxx

 

SW1

interface GigabitEthernet 1/6/0/37
switchport mode trunk
channel-group 1 mode active

 

interface GigabitEthernet 2/6/0/37
switchport mode trunk
channel-group 1 mode active

14 REPLIES 14
marce1000
VIP Mentor

 

 - Do you have any more info in the switch-logging, issue - show logging . , just after the interface get's disabled (?)

M.

I suspect STP is doing something i dont understand. Cisco core is running rapid-pvst and hp access is running mst.

Hello
This may not be anything to do with your aggregation but as you stated pertaining to STP however i would check if lacp isn't negating connection also.


The stp boundary between ( the PC's) of the Hp and Cisco may have gone into a inconsistent state due to the cisco expecting a bpdu per vlan and the HP isn't.

What is the defined stp root the cisco or the HP?

 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

There is an old cisco 6509E core switch running pvst acting as CST root to all HP access switches which are running default mst. I am running a test by configuring lacp with our future core a C9407R pair (stackwise virtual) to one of the HP access switches.
I have tried to
-configure pvst filter command at HP side
-portfast trunk command at cisco side
-changed STP mode to pvst
-making etherchannel with ON mode
-used ports on same chasis

result is pretty much the same every time. Link comes up for a few sec and then is err-disabled.

Hello


@mateens wrote:
There is an old cisco 6509E core switch running pvst acting as CST root to all HP access switches which are running default mst.

As the cisco is the cst root and to negate any possible stp pvst simulation failure between the cisco and hp switchesv make sure the cisco vlans has a better stp priority than the mst 0 of the HP ( i guess this is the case anyway)

However on the cisco...
vlan1 has a higher priority  than all other vlans.

example
Cisco:
spanning-tree vlan 1 priority 4096
spanning-tree vlan 2 + priority 0

HP
spanning-tree mst 0  priority 8192

 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

@paul driver
Yes, Thats how it is already on the old cisco core and is working alright. Issue comes while establishing port channel from a Hp to the new cisco switch.
spanning-tree priority 15 is on HP which sets it to highest priority and old cisco has priority set to 24577. The new cisco switch has default 32768.

Hello


@mateens wrote:
@paul driver
Yes, Thats how it is already on the old cisco core and is working alright. Issue comes while establishing port channel from a Hp to the new cisco switch.
spanning-tree priority 15 is on HP which sets it to highest priority and old cisco has priority set to 24577. The new cisco switch has default 32768.

“Old core switch- new core switch”

maybe I have missed something how are all 3 switchs interconnected?

 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Yes, the third one is cisco 9407 pair configured with stackwise virtual. The plan is to replace the old cisco 6509E. All HP access switch would be connected to the new core with multi chasis etherchannel.
C6509E ---- HP(20+ switches) is the old network topology where core is handling inter vlan routing.
I am conecting the new cisco 9407 pair with multi chasis etherchannel to one of the HP switches.

like this:
C6509E ---- HP ====== cisco 9407 stackwise virtual pair.

Hello

why are you connecting the new core to the HP and not connecting it directly to the old core Then you can migrate the hps over to the new core as/when you desire 

 

The plus side of that is the old core would still be the cst root and the new-core would   be the cist regional root for any migrated hp switches and once the hp access switchs have been relocated then remove interconnect between old /new core and enable the L3 routing on the new core

 

If the issue isn’t due to amy lacp mismatch the reason why you are getting stp blocking at present could be due to the hps seeing the old core a stp root and the new core least preffered 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Because i wanted to test mchasis etherchannel behaviour with Hp first before starting migration.
I think i should use a standalone hp switch with basic configurations ...

Hello


@mateens wrote:
Because i wanted to test mchasis etherchannel behaviour with Hp first before starting migration.
I think i should use a standalone hp switch with basic configurations ...

I suggest that would be best to test the connection between your new core and a hp switch off your production network as eventually the hps will just connecting the new Cisco core anyway

 

 

 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul
mateens
Beginner





Logs from Hp



0139:13:48:53.36 lacp mLACPCtrl:LACP: Port C23 is UP

0139:13:48:53.36 lacp mLACPCtrl:LACP: LACP data BPDU Tx on port C23

I 12/18/18 13:08:07 00435 ports: port C23 is Blocked by LACP



0139:13:48:53.44 lacp mLACPCtrl:LACP: Port C24 is UP

0139:13:48:53.44 lacp mLACPCtrl:LACP: LACP data BPDU Tx on port C24

I 12/18/18 13:08:07 00435 ports: port C24 is Blocked by LACP

0139:13:48:54.34 lacp mLACPCtrl:LACP: LACP data BPDU Tx on port C23

0139:13:48:54.34 lacp mLACPCtrl:LACP: Periodic timer has been set to

FAST_PERIODIC_TIME for port C23



0139:13:48:56.18 lacp mLACPCtrl:Manual LACP: Partner info selected for port

C24,partner port 3622,partner system-priority 32768,partner port priority

32768,partner Key 3622

0139:13:48:56.18 lacp mLACPCtrl:Manual LACP: Err: Port C23 is blocked due to

partner info mismatch

0139:13:48:56.18 lacp mLACPCtrl:Manual LACP: System ID 4509ae8 and Port key 1

are matched for port C24

0139:13:48:56.18 lacp mLACPCtrl:LACP: LACP data BPDU Tx on port C24

I 12/18/18 13:08:10 00078 ports: trunk Trk1 is now active



I 12/18/18 13:08:10 00435 ports: port C24 is Blocked by STP

0139:13:48:56.21 lacp mLACPCtrl:LACP: Data BPDU Rx. on port C23

0139:13:48:56.21 lacp mLACPCtrl:Manual LACP: Partner info selected for port

C23,partner port 5670,partner system-priority 32768,partner port priority

32768,partner Key 5670



0139:13:48:56.21 lacp mLACPCtrl:LACP: LACP data BPDU Tx on port C23

I 12/18/18 13:08:10 00435 ports: port C23 is Blocked by STP

0139:13:48:56.34 lacp mLACPCtrl:LACP: LACP data BPDU Tx on port C23

0139:13:48:56.34 lacp mLACPCtrl:LACP: Periodic timer has been set to

FAST_PERIODIC_TIME for port C23

0139:13:48:56.34 lacp mLACPCtrl:LACP: LACP data BPDU Tx on port C24

0139:13:48:56.34 lacp mLACPCtrl:LACP: Periodic timer has been set to

FAST_PERIODIC_TIME for port C24



0139:13:48:58.34 lacp mLACPCtrl:LACP: Periodic timer has been set to

SLOW_PERIODIC_TIME for port C24

I 12/18/18 13:08:13 00076 ports: port C23 in Trk1 is now on-line

I 12/18/18 13:08:13 00076 ports: port C24 in Trk1 is now on-line





0139:13:50:14.16 lacp mLACPCtrl:Manual LACP: System ID 4509d08 and Port key 1

are matched for port C23

0139:13:50:14.16 lacp mLACPCtrl:Manual LACP: Partner info selected for port

C23,partner port 5670,partner system-priority 32768,partner port priority

32768,partner Key 5670

0139:13:50:14.16 lacp mLACPCtrl:Manual LACP: Partner info selected for port

C24,partner port 3622,partner system-priority 32768,partner port priority

32768,partner Key 3622

0139:13:50:14.16 lacp mLACPCtrl:Manual LACP: System ID 4509ae8 and Port key 1

are matched for port C23

0139:13:50:14.16 lacp mLACPCtrl:Manual LACP: System ID 4509ae8 and Port key 1

are matched for port C24

0139:13:50:14.16 lacp mLACPCtrl:LACP: LACP data BPDU Tx on port C24

0139:13:50:14.17 lacp mLACPCtrl:LACP: Data BPDU Rx. on port C23

0139:13:50:14.17 lacp mLACPCtrl:Manual LACP: Partner info selected for port



are matched for port C24

0139:13:50:14.17 lacp mLACPCtrl:LACP: LACP data BPDU Tx on port C23

0139:13:50:14.57 lacp mLACPCtrl:LACP: Port C23 is DOWN

I 12/18/18 13:09:28 00077 ports: port C23 in Trk1 is now off-line



0139:13:50:14.95 lacp mLACPCtrl:LACP: Port C24 is DOWN

I 12/18/18 13:09:28 00079 ports: trunk Trk1 is now inactive

I 12/18/18 13:09:28 00077 ports: port C24 in Trk1 is now off-line





logs from cisco



*Dec 18 13:07:56.622: %LINK-3-UPDOWN: Interface GigabitEthernet1/6/0/37, changed state to up

*Dec 18 13:07:56.660: %LINK-3-UPDOWN: Interface GigabitEthernet2/6/0/37, changed state to up

*Dec 18 13:07:56.788: LACP :lacp_bugpak: Receive LACP-PDU packet via Gi2/6/0/37

*Dec 18 13:07:56.788: LACP : packet size: 124

*Dec 18 13:07:56.788: LACP: pdu: subtype: 1, version: 1

*Dec 18 13:07:56.788: LACP: Act: tlv:1, tlv-len:20, key:0x122, p-pri:0x0, p:0x47, p-state:0x3D,

s-pri:0xB00, s-mac:f062.817f.0b00

*Dec 18 13:07:56.788: LACP: Part: tlv:2, tlv-len:20, key:0x1, p-pri:0x8000, p:0x1626, p-state:0x83,

s-pri:0x8000, s-mac:0000.0000.0000

*Dec 18 13:07:56.788: LACP: col-tlv:3, col-tlv-len:16, col-max-d:0x2710

*Dec 18 13:07:56.788: LACP: term-tlv:0 termr-tlv-len:0

*Dec 18 13:07:56.788: LACP: Gi2/6/0/37 LACP packet received, processing

*Dec 18 13:07:56.788: lacp_rx Gi2/6/0/37 - rx: during state PORT_DISABLED, got event 5(recv_lacpdu) (ignored)

*Dec 18 13:07:57.623: LACP: lacp_hw_on: Gi1/6/0/37 is coming up



*Dec 18 13:07:57.623: LACP: lacp_hw_on: Gi1/6/0/37 set mode 6



*Dec 18 13:07:57.623: lacp_ptx Gi1/6/0/37 - ptx: during state NO_PERIODIC, got event 0(no_periodic)

*Dec 18 13:07:57.623: @@@ lacp_ptx Gi1/6/0/37 - ptx: NO_PERIODIC -> NO_PERIODIC

*Dec 18 13:09:15.603: %PM-4-ERR_DISABLE: channel-misconfig error detected on Po1, putting Gi1/6/0/37 in err-disable state

*Dec 18 13:09:15.607: LACP: lacp_hw_off: Gi1/6/0/37 is going down



*Dec 18 13:09:15.607: LACP: if_down: Gi1/6/0/37

*Dec 18 13:09:15.607: LACP: lacp_hw_off: send pdu out Gi1/6/0/37

*Dec 18 13:09:15.607: LACP: lacp_insert_partner_cd_inhibitor: didn't change sync flag.

*Dec 18 13:09:15.607: LACP: lacp_send_lacp_off: (Gi1/6/0/37) About to send the 110 LACPDU

*Dec 18 13:09:15.607: LACP :lacp_bugpak: Send LACP-PDU packet via Gi1/6/0/37

*Dec 18 13:09:15.607: LACP : packet size: 124

*Dec 18 13:09:15.607: LACP: pdu: subtype: 1, version: 1

*Dec 18 13:09:15.607: LACP: Act: tlv:1, tlv-len:20, key:0x1, p-pri:0x8000, p:0xE26, p-state:0x1,

s-pri:0x8000, s-mac:00b7.717f.4dcc

*Dec 18 13:09:15.607: LACP: Part: tlv:2, tlv-len:20, key:0x122, p-pri:0x0, p:0x48, p-state:0x3D,

s-pri:0xB00, s-mac:f062.817f.0b00

*Dec 18 13:09:15.607: LACP: col-tlv:3, col-tlv-len:16, col-max-d:0x8000

*Dec 18 13:09:15.607: LACP: term-tlv:0 termr-tlv-len:0

*Dec 18 13:09:15.607: LACP: lacp_write: LACP 124 bytes out Gi1/6/0/37

*Dec 18 13:09:15.608: lacp_ptx Gi1/6/0/37 - ptx: during state SLOW_PERIODIC, got event 0(no_periodic)

*Dec 18 13:09:15.608: @@@ lacp_ptx Gi1/6/0/37 - ptx: SLOW_PERIODIC -> NO_PERIODIC

*Dec 18 13:09:15.608: LACP: Gi1/6/0/37 lacp_action_ptx_slow_periodic_exit entered

*Dec 18 13:09:15.608: LACP: lacp_p(Gi1/6/0/37) timer stopped

*Dec 18 13:09:15.608: LACP: Gi1/6/0/37 lacp_action_ptx_no_periodic entered

*Dec 18 13:09:15.608: LACP: lacp_p(Gi1/6/0/37) timer stopped

*Dec 18 13:09:15.608: lacp_rx Gi1/6/0/37 - rx: during state CURRENT, got event 1(port_disabled)

*Dec 18 13:09:15.608: @@@ lacp_rx Gi1/6/0/37 - rx: CURRENT -> PORT_DISABLED

*Dec 18 13:09:15.608: LACP: Gi1/6/0/37 lacp_action_rx_current_exit entered

*Dec 18 13:09:15.608: LACP: lacp_c(Gi1/6/0/37) timer stopped

*Dec 18 13:09:15.608: LACP: Gi1/6/0/37 lacp_action_rx_port_disabled entered

*Dec 18 13:09:15.608: lacp_mux Gi1/6/0/37 - mux: during state COLLECTING_DISTRIBUTING, got event 6(outof_sync)

*Dec 18 13:09:15.608: @@@ lacp_mux Gi1/6/0/37 - mux: COLLECTING_DISTRIBUTING -> ATTACHED

*Dec 18 13:09:15.608: LACP: Gi1/6/0/37 lacp_action_mx_cd_exit is entered

*Dec 18 13:09:15.608: LACP: Gi1/6/0/37 lacp_action_mx_attached entered

*Dec 18 13:09:15.608: LACP: Gi1/6/0/37 Disabling collecting and distributing

*Dec 18 13:09:15.608: LACP: Gi1/6/0/37 set to UNSELECTED

*Dec 18 13:09:15.608: lacp_mux Gi1/6/0/37 - mux: during state ATTACHED, got event 3(unselected)

*Dec 18 13:09:15.608: @@@ lacp_mux Gi1/6/0/37 - mux: ATTACHED -> DETACHED

*Dec 18 13:09:15.608: LACP: Gi1/6/0/37 lacp_action_mx_detached entered

*Dec 18 13:09:15.608: LACP: Gi1/6/0/37 Detaching mux from aggregator

*Dec 18 13:09:15.608: LACP: HA: Syncing LACP IDB GigabitEthernet1/6/0/37

*Dec 18 13:09:15.608: LACP: HA: Sync LACPIDBs

*Dec 18 13:09:15.608: LACP: HA ISSU: xmit xform

*Dec 18 13:09:15.608: lacp_handle_standby_port_internal called, depth = 1

*Dec 18 13:09:15.608: LACP: lacp_handle_standby_port_internal: No Standby port found for LAG 1

*Dec 18 13:09:15.609: LACP: lacp_w(Gi1/6/0/37) timer stopped

*Dec 18 13:09:15.609: LACP: lacp_c(Gi1/6/0/37) timer stopped

*Dec 18 13:09:15.609: LACP: lacp_p(Gi1/6/0/37) timer stopped

*Dec 18 13:09:15.609: LACP: lacp_w(Gi1/6/0/37) timer stopped

*Dec 18 13:09:15.609: LACP: lacp_t(Gi1/6/0/37) timer stopped

*Dec 18 13:09:15.609: %PM-4-ERR_DISABLE: channel-misconfig error detected on Po1, putting Gi2/6/0/37 in err-disable state

*Dec 18 13:09:15.619: LACP: lacp_hw_off: Gi2/6/0/37 is going down



*Dec 18 13:09:15.619: LACP: if_down: Gi2/6/0/37

*Dec 18 13:09:15.619: LACP: lacp_hw_off: send pdu out Gi2/6/0/37

*Dec 18 13:09:15.619: LACP: lacp_insert_partner_cd_inhibitor: didn't change sync flag.

*Dec 18 13:09:15.619: LACP: lacp_send_lacp_off: (Gi2/6/0/37) About to send the 110 LACPDU

*Dec 18 13:09:15.619: LACP :lacp_bugpak: Send LACP-PDU packet via Gi2/6/0/37

*Dec 18 13:09:15.619: LACP : packet size: 124

*Dec 18 13:09:15.619: LACP: pdu: subtype: 1, version: 1

*Dec 18 13:09:15.619: LACP: Act: tlv:1, tlv-len:20, key:0x1, p-pri:0x8000, p:0x1626, p-state:0x1,

s-pri:0x8000, s-mac:00b7.717f.4dcc

*Dec 18 13:09:15.619: LACP: Part: tlv:2, tlv-len:20, key:0x122, p-pri:0x0, p:0x47, p-state:0x3D,

s-pri:0xB00, s-mac:f062.817f.0b00

*Dec 18 13:09:15.619: LACP: col-tlv:3, col-tlv-len:16, col-max-d:0x8000

*Dec 18 13:09:15.619: LACP: term-tlv:0 termr-tlv-len:0

*Dec 18 13:09:15.619: LACP: lacp_write: LACP 124 bytes out Gi2/6/0/37

*Dec 18 13:09:15.620: lacp_ptx Gi2/6/0/37 - ptx: during state SLOW_PERIODIC, got event 0(no_periodic)

*Dec 18 13:09:15.620: @@@ lacp_ptx Gi2/6/0/37 - ptx: SLOW_PERIODIC -> NO_PERIODIC

*Dec 18 13:09:15.620: LACP: Gi2/6/0/37 lacp_action_ptx_slow_periodic_exit entered

*Dec 18 13:09:15.620: LACP: lacp_p(Gi2/6/0/37) timer stopped

*Dec 18 13:09:15.620: LACP: Gi2/6/0/37 lacp_action_ptx_no_periodic entered

*Dec 18 13:09:15.620: LACP: lacp_p(Gi2/6/0/37) timer stopped

*Dec 18 13:09:15.620: lacp_rx Gi2/6/0/37 - rx: during state CURRENT, got event 1(port_disabled)

*Dec 18 13:09:15.620: @@@ lacp_rx Gi2/6/0/37 - rx: CURRENT -> PORT_DISABLED

*Dec 18 13:09:15.620: LACP: Gi2/6/0/37 lacp_action_rx_current_exit entered

*Dec 18 13:09:15.620: LACP: lacp_c(Gi2/6/0/37) timer stopped

*Dec 18 13:09:15.620: LACP: Gi2/6/0/37 lacp_action_rx_port_disabled entered

*Dec 18 13:09:15.620: lacp_mux Gi2/6/0/37 - mux: during state COLLECTING_DISTRIBUTING, got event 6(outof_sync)

*Dec 18 13:09:15.620: @@@ lacp_mux Gi2/6/0/37 - mux: COLLECTING_DISTRIBUTING -> ATTACHED

*Dec 18 13:09:15.620: LACP: Gi2/6/0/37 lacp_action_mx_cd_exit is entered

*Dec 18 13:09:15.620: LACP: Gi2/6/0/37 lacp_action_mx_attached entered

*Dec 18 13:09:15.620: LACP: Gi2/6/0/37 Disabling collecting and distributing

*Dec 18 13:09:15.620: LACP: Gi2/6/0/37 set to UNSELECTED

*Dec 18 13:09:15.620: lacp_mux Gi2/6/0/37 - mux: during state ATTACHED, got event 3(unselected)

*Dec 18 13:09:15.620: @@@ lacp_mux Gi2/6/0/37 - mux: ATTACHED -> DETACHED

*Dec 18 13:09:15.620: LACP: Gi2/6/0/37 lacp_action_mx_detached entered

*Dec 18 13:09:15.620: LACP: Gi2/6/0/37 Detaching mux from aggregator

*Dec 18 13:09:15.620: LACP: HA: Syncing LACP IDB GigabitEthernet2/6/0/37

*Dec 18 13:09:15.620: LACP: HA: Sync LACPIDBs

*Dec 18 13:09:15.620: LACP: HA ISSU: xmit xform

*Dec 18 13:09:15.620: lacp_handle_standby_port_internal called, depth = 1

*Dec 18 13:09:15.620: LACP: lacp_handle_standby_port_internal: No Standby port found for LAG 1

*Dec 18 13:09:15.620: LACP: lacp_w(Gi2/6/0/37) timer stopped

*Dec 18 13:09:15.620: LACP: lacp_c(Gi2/6/0/37) timer stopped

*Dec 18 13:09:15.620: LACP: lacp_p(Gi2/6/0/37) timer stopped

*Dec 18 13:09:15.620: LACP: lacp_w(Gi2/6/0/37) timer stopped

*Dec 18 13:09:15.620: LACP: lacp_t(Gi2/6/0/37) timer stopped

*Dec 18 13:09:15.621: %PM-4-ERR_DISABLE: channel-misconfig error detected on Po1, putting Po1 in err-disable state

*Dec 18 13:09:15.708: LACP: CF: sync successfully completed

*Dec 18 13:09:15.709: LACP: CF: sync successfully completed

*Dec 18 13:09:16.604: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/6/0/37, changed state to down

*Dec 18 13:09:16.609: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet2/6/0/37, changed state to down

*Dec 18 13:09:16.614: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to downsho

*Dec 18 13:09:17.609: %LINK-3-UPDOWN: Interface GigabitEthernet1/6/0/37, changed state to down

*Dec 18 13:09:17.614: %LINK-3-UPDOWN: Interface Vlan140, changed state to down

*Dec 18 13:09:17.619: %LINK-3-UPDOWN: Interface Port-channel1, changed state to down

*Dec 18 13:09:17.620: %LINK-3-UPDOWN: Interface GigabitEthernet2/6/0/37, changed state to downw

Georg Pauwen
VIP Master

Hello,

 

on a side note, when you created a static port channel, did you turn off LACP on the individual HP interfaces ? I have a sample config for a static port channel that would translate, in your case, to:

 

HP SW-A

 

SW-A(config)# interface C23 no lacp
SW-A(config)# interface C24 no lacp
SW-A(config)# trunk C23-C24 trk1 trunk

 

Cisco SW1

 

interface GigabitEthernet 1/6/0/37
switchport mode trunk
channel-group 1 mode on

!

interface GigabitEthernet 2/6/0/37
switchport mode trunk
channel-group 1 mode on

@Georg Pauwen

Yes, same result.