cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
8360
Views
0
Helpful
7
Replies
Highlighted
Beginner

port- channel "waiting to be aggregated"

Good Day everyone,

I am fairly good at configuring Cisco but this I cannot get working.

I have a working port channel on a 3750x 3 switch stack running version 15.0(2)SE2 with a 4 port port-channel, simple trunk configuration and LACP. It is connected to a NetApp storage unit and been working great for a number of years.

interface Port-channel25
description <= PortChannel2 PD2240A =>
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 17,21,300,302,303,2010
switchport mode trunk
switchport nonegotiate

I am trying to replace the 3750x stack with 3850 3 switch stack running version 152-3.E3 with a 4 port port-channel, also simple trunk configured with LACP.

We are trying to move over one cable at a time so as not to have to take down the storage or network and after moving the first cable the port states that it is "waiting to be aggregated" and the port-channel has a SU status (up). 

PD-3850-MDF-ServerRm1#sh run int po 26
Building configuration...

Current configuration : 133 bytes
!
interface Port-channel26
switchport trunk allowed vlan 17,21,300,302,303,2010
switchport mode trunk
switchport nonegotiate
end

PD-3850-MDF-ServerRm1#sh etherch summ
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator

M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port

A - formed by Auto LAG


Number of channel-groups in use: 4
Number of aggregators: 4

Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------

26 Po26(SU) LACP Gi1/0/36(w) Gi1/0/38(D) Gi2/0/35(D) Gi2/0/37(D)

I have defaulted the interfaces, deleted the port-channels, etc twice and it just will not come up. I have also configured port speed, duplex, flow control with no success. I have even show run "all" for the interfaces and port channels and found no differences like encapsulation type, flow control, etc . Any thoughts?

I have scoured this forum and the Internet for solutions with out any resolution. Any thoughts are appreciated.

7 REPLIES 7
Highlighted
VIP Expert

Hello,

the order of operation is important. Create the individual interfaces first and add the 'channel-group' command to the interface before you do anything else.

I have written up a procedure to make sure the order of operation is right, trying to find it...

Highlighted

Thank you for your response gpauwen. Yes, you are correct and I learned that the hard way several years ago when I struggled over and over with making port-channels work. Then I spoke with a Cisco TAC person one day and they told me exactly that and explained the best way to do it. I have not had a problem since (several years). 

Highlighted

Update: I have brain stormed with my co-worker who only does a little bit if Cisco configurations but whose specialty is NetApp storage and servers. We are going to try and take 2 of the four links out of the port channel on both ends and place them into a new channel on the new 3850. This way the NetApp and switch will negotiate with the same unit. Debugging of the negotiation between the device produced some very cryptic information which lead us to a conclusion that maybe the devices are smart enough on the negotiating to know that the one link we are trying to move actually knows that it is not the same and therefore waiting to aggregate. I will post if this works. I hope that makes sense.

Highlighted

Hello
Try let the let the storage negotiate the aggregate via lacp if applicable and set the switch interfaces to passive

For a layer2 PC creation
1) default physical interfaces (if possible) and shut them down
2) configure channel-group x mode passive in physical interfaces

-- let port-channel create automatically

3)create trunking encapsulation or access port mode directly in port-channel interface
4)enable physical interfaces "no shut"

 

Lasty If i am reading your OPs correctly your trying to move a PC off one switch stack over to another switch stack without bringing down originating PC which if i am mistaken cannot be done outside vpc/vss mode configurations which the 3700,3800 dont support!

res
Paul



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted

This worked for me on two 10Gig links between a Cat 9400 and a Cat 9600! Thanks

Highlighted

Hi, my friend, 

 

Could you share this procedure to make all the steps right?

 


Thanks for reading this post. 

 

Best regards, 

David

Highlighted
Beginner

Hi,

Reading your description, I believe you are moving links one by one from 3750 to 3850, but the NetApp end remains connected. So essentially NetApp end is aggregated in a port-channel but on 3750/3850 side you are splitting port-channel in two different devices (3750 and 3850), which is not supported.

Port-channel can only be between two devices i.e. all links in the port-channel from one device must terminate to a single device, in your case it is involving three devices, thus the problem.

Below set-up is not supported.

                          +-------+
+-------+                 |  3850 |
|       +-----------------+       |
|       |-----------------|       |
|netapp +-----------------+       |
|       |                 +-------+
|       |               +------+
|       +---------------+      |
|       |               |3750  |
+-------+               |      |
                        +------+

It is not a good way to move links, better yet, all 4 links in port-channel on 3850 and shut the port-channel, move cables from 3750 to 3850 and unshut the ports.

An alternate method would be to create port-channel on 3850, and keep it shut. Move two cables from 3750 to 3850, and then simultaneously shut port-channel on 3750 and unshut port-channel in 3850, once 3850 has negotiated port-channel with NetApp then you can move other ports.

HTH,

Ashish

Content for Community-Ad