Showing results for 
Search instead for 
Did you mean: 

Port down


4006 ios 12

I configured a port to be trunk and allowed 4 vlans. Now the port is in a "down" state. I've entered the command "no shut" with no luck. I also tried "shut" followed by "no shut."

What I am missing?



Are both ends of the trunk configured with the same trunking encapsulation?


Sounds like you've got a layer 1 issue. Even if the trunk is not working, you should still be getting a physical connection. Is this fiber or copper? If it's fiber, try swapping the fiber ends. If copper, try replacing the cable.

Is it a brand new port that you're just bringing up or has it been up for some time and is being reconfigured? If it's new, you may have bad hardware.

The port is configured trunk. Is the other end trunk or access? Make sure the other end is trunk or some kind of dynamic settings (desirable or auto). Access won't make the trunk.

Check the logs. If there's a problem with the trunk, likely there will be error messages.

Setting up public w/less access. So, we created a separate vlan for the access points.

Set up trunk between 4006 and HP Procurve 1800.

That's when the port on the 4006 showed a down status and "no shut" would not bring it up.

Is the port on the Procurve turned on? How about the encapsulation? It's dot1q?

It really sounds like a layer 1 issue because even if the trunk doesn't get negotiated, you should still see a physical link come up. It just won't pass traffic.

Do you have this port in a channel-group?

If so, you might want to see if the channel group is not shut down.

No, it's not.

Can you please paste your ports' configurations?

Over the weekend, I tried using a 2950 but with the same results. Here are the port configs for both the 4006 and the 2950. Also, the 2950 is fiber connected to a 1000 speed media converter which is plugged into port 21 of the 4006.


interface GigabitEthernet2/21

description Procurve

switchport access vlan dynamic

switchport trunk encapsulation dot1q

switchport mode trunk

speed 1000

duplex full

no snmp trap link-status

spanning-tree portfas


interface GigabitEthernet0/1

switchport mode trunk

switchport nonegotiate

mls qos trust cos

macro description cisco-switch

spanning-tree link-type point-to-point

Have you tried swapping the fiber ends? Using a different fiber patch cable? Do you have a different GBIC you can use?

Are there any errors in the log?

I'm presuming the speed/duplex are the same on the 2950. They should be as 1000/full is the default for gigabit. Why the "spanning-tree link-type point-to-point" if both ends are full duplex? That's implied with a full-duplex connection.

The "switchport access vlan dynamic" makes me nervous, although I can't find a reason why that should be causing your problem since you've declared the ports to be trunk.

Can you include the output of "show int GigabitEthernet0/1" from each switch?

post both output from 4006:

show int gig 2/21

show int gig 2/21 switchport

show cdp neigh int gig 2/21

I finally got it figured out. It was a speed issue. As a test, I plugged a pc with a gig nic into the port. It came up saying 100.

I set the switch speed and duplex to auto. After that, I got connectivity with the 2950.

I'm starting to think that Procurve may be bad. We tried to plug a PoE injector into that was connected to an 802.11n AP but it would only work if we set the port on the Procurve to 100.

Thanks for the help eveyone.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: