cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2866
Views
0
Helpful
6
Replies
Highlighted
Beginner

Port Forwarding Between vLAN's

Hi All,

I hope this finds you well.

We are having an issues with our Cisco network since re-structuring a week or so ago. In short, we have an Exchange Server (small business servers) on vLAN 101 which is a NAT'd vLAN/Subnet with IP Address 192.1681.1.250 and we have added the port forwards for SMTP etc to allow external mail to be received by the server. This is working fine.

The issue is, is that we have a cPanel Web Server on a different vLAN, ID 100 which has a public IP Address directly. Mail sent from this server to the Exchange Server is lost - I was wondering if we need to add further port forwarding to all the mail through. The Router's running config is as follows:

interface GigabitEthernet0/0

description CORESWITCH-VM-UPLINK

ip address 31.210.XX.XX 255.255.255.248

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/2.100

encapsulation dot1Q 100

ip address 31.210.XX.XXX 255.255.255.240

!

interface GigabitEthernet0/2.101

encapsulation dot1Q 101

ip address 192.168.1.254 255.255.255.0

ip nat inside

ip virtual-reassembly in

!

ip nat pool OFFICE 31.210.XX.XXX 31.210.XX.XXX netmask 255.255.255.240

ip nat inside source list 101 pool OFFICE overload

ip nat inside source static tcp 192.168.1.250 25 31.210.XX.XXX 25 extendable

ip nat inside source static tcp 192.168.1.250 80 31.210.XX.XXX 80 extendable

ip nat inside source static tcp 192.168.3.50 430 31.210.XX.XXX 430 extendable

ip nat inside source static tcp 192.168.1.250 443 31.210.XX.XXX 443 extendable

ip nat inside source static tcp 192.168.1.250 3389 31.210.XX.XXX 3389 extendable

ip nat inside source static tcp 192.168.3.50 5050 31.210.XX.XXX 5050 extendable

ip nat inside source static tcp 192.168.4.150 8080 31.210.XX.XXX 8080 extendable

ip route 0.0.0.0 0.0.0.0 31.210.XX.XX

I hope the above makes sense, and I look forward to hearing back from you in the near future.

All the best,

Matthew

6 REPLIES 6
Highlighted
Rising star

Hi,

On cPanel server exchange server configured with IP address private or public? I think there should be public IP address 31.210.
Is Default route on the router pointing to ISPs side?
I hope IP addresses are not overlapping on internet facing link and cPanel server.
Check firewalls on both servers.


Sent from Cisco Technical Support Android App

Best regards,
Abzal
Highlighted

Hi there,

The Exchange Server has a private IP Address as it is also a File Server (Small Business Server 2008) and this receives email fine from the outside world.

The cPanel Web Server is on a pulic IP Adreess and again is serving content to the outside world, but emails it sends to the Exchnage Server aren't being received.

We have checked that no Firewalls are interfering.

Matthew

Highlighted
Rising star

Not that's not what I meant.
I mean mails from cpanel are sent to exchange to it's public or private IP address?
If it's public that should be ok.

Sent from Cisco Technical Support Android App

Best regards,
Abzal
Highlighted

Hi there,

I am not sure how you can "tell" a cPanel Web Server to send emails out using a particular IP Address.

Naturally it uses the MX Records, which are actually running on an external DNS Service, to determine where to send emails to.

For the record, the cPanel Web Server sends email fine to the outside world, it is just the emails destined for email accounts held on the Exchange Server aren't being received.

Matthew

Highlighted

Hi Matthew,

Have you wiresharked a mail being sent from your cPanel server?? What is the MX record result the server receives??  If you verify the external DNS is giving the right information to the cPanel server, we can cross that off the list and go further, but knowing the actual destination the cPanel server is getting is a good first step.

Kindest Regards,

ALAN

Highlighted
Rising star

Ok, let's do this try to put nat staement under cpanel facing interface

Int g0/2.100
...
Ip nat outside


Sent from Cisco Technical Support Android App

Best regards,
Abzal
Content for Community-Ad