cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

345
Views
0
Helpful
2
Replies
Highlighted
Beginner

post 3130x installation issues

We recently went through an upgrade in which we replaced all of our brocade pass through cards in our Dell chassis with new Cisco 3130x switches (stacked). After installation we've had 2 rather strange issues over the last month post installation.

1) All of our Cisco 3750x switches in the closets had their uplink to our 6513 in the datacenter go into err-disable reason loopback. These all are connected to the 6513 only and only have a single fiber connection to said 6513. After bringing the interfaces back online I have yet to see it happen again.

2) DHCP has been randomly failing for both physical systems (laptops, desktops and zero clients) and for systems in our virtual environment. I am still struggling with this issue and after several tests I believe the 3130x might be part of the issue if not all of the issue.

On each chassis we have 16 blade servers which have ESXi 5.1 installed. The NICs for each ESXi host are setup on 2 virtual standard switches with 2 network interfaces per standard switch. The virtual standard switches are configured for route based load balancing.

Our DHCP is a Windows 2008 server that has been virtualized.

All server facing interfaces on the 3130x switches are setup as a simple trunk interface. This is the way the interfaces on the 6513 were configured before we installed the 3130x switches and we experianced no issues.

The 3130x interfaces that connect to our 6513 are broken into 2 LACP port-groups. Ports 17 & 18 of each 3130x in port-group 1 and 19 & 20 in port-group 2. On the 6513 side the second port-group has been placed into an admin down state to act as an "on-demand" backup path.

here are the interface configurations:

interfaces 17 & 18 on all of the 3130x switches:

interface GigabitEthernet1/0/17

switchport mode trunk

channel-group 1 mode active

end

interface port-channel 1 configuration:

interface Port-channel1

switchport mode trunk

spanning-tree cost 1

end

interfaces 19 & 20

interface GigabitEthernet1/0/19

switchport mode trunk

channel-group 2 mode active

end

interface port-channel 2 configuration:

interface Port-channel2

switchport mode trunk

end

ESXi host facing interfaces:

interface GigabitEthernet1/0/1

switchport mode trunk

end

On the 6513 side the port configurations for the interfaces connected to the 3130x switches is as follows.

interface GigabitEthernet1/4

description 6513 -> 3130x Upper Chassis

switchport

switchport mode trunk

channel-group 110 mode active

end

port-channel interface to the 3130x:

interface Port-channel110

description Dell Chassis - upper - 3

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

end

admin down port-channel to the 3130x:

interface Port-channel111

description Dell Chassis - Upper - 2

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

shutdown

end

I am close to pulling out all of my hair at this point. I have never seen anything like this in the past, and I only suspect this has something to do with the 3130x insallations since the trouble started right after we installed the 3130x switches.

Thank you in advance.

Everyone's tags (6)
2 REPLIES 2
VIP Expert

post 3130x installation issues

Can you make the 3130x ports as LACP passive and test again?

interface GigabitEthernet1/0/17

switchport mode trunk

channel-group 1 mode passive

Also, I know that the portchannel numbers are locally significant, but can you put both sides of the connection in the same portchannel number?

Put both sides in portrcahhnel 1

HTH

Beginner

post 3130x installation issues

Originally when i setup the channels I had set the 3130x switches to be passive and the other end to be active. We changed it to active / active during our troubleshooting on this issue.

I cannot change the channel numbers on the 6513 end as those are in use with a connection to our EMC storage.

The issue with DHCP addressing to the physical devices seems to have gone away after I cleared the MAC tables on the 6513.

After extensive head scratching yesterday we seem to have narrowed the issue down to virtual desktops that are on an ESX cluster that spans across 2 different Dell chassis seem to the be the ones having the major issue.

We are going to move some hardware around in our test cluster and see what changes. I can not make too many changes to the 3130x switches until the weekend as all 3 of out Dell chassis have production systems on them.

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards