cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4570
Views
0
Helpful
18
Replies
LEN SNEED
Beginner

Problem changing Vlan 1 ip address

Hi,

I have a 3750 stack that connects to a 3560 at another site.  The are both on the inside of our network and basically a switch to switch connection.  The switchports are in vlan 901.  When I telnet from the 3750 to the 3560 and attempt to change the 3560's vlan 1 ip address I lose connectivity and can only get it back by going to the site and consoling into the 3560 to change the vlan 1 ip address back.  The 3750 vtp mode is server and the remote 3560 is vtp transparent.  Any ideas why this is happening?

Thanks,

Len.

1 ACCEPTED SOLUTION

Accepted Solutions
mlund
Rising star

Hi Len

The reason this is not working is because the vlan1 is not forwarded between the switches.

As I described in my previous contribution You have to have vlan1 forwarded between the switches.

The config You have now are only connecting vlan901, by making the g0/22 and g4/0/1 a trunkport and allowing vlan 1 and 901 will solve the problem.

Or You can connect a new cable between the switches and forward vlan1 that way.

Or, You can give the vlan1 interface on 3560 an ip address that is not overlapping with other neetworks.

/Mikael

View solution in original post

18 REPLIES 18
Reza Sharifi
Hall of Fame Expert

Hi Len,

Is Vlan 1 being used for management?  If you use vlan 1 IP address to telnet and once you login in change the IP address, then you will lose connection.

HTH

Reza

Thanks for the reply Reza,

I was actually telnetted into 3560 via vlan 905.

When the vlan 1 ip was changed not only did the telnet connection drop all network traffic throught the 3560 stopped.

So, the PC that you telent from is in vlan 905 or in vlan 1?

The telnet was made from 10.1.5.38 on 3750 vlan1 to 3560 10.255.254.2 which is vlan905.

3750:

int g4/0/1

switchport access vlan 901

switchport mode access

int vlan1

ip address 10.1.1.1 255.255.0.0

ip helper-address 10.1.5.20

int vlan 901

ip address 10.255.255.1 255.255.255.0

3560:

int g0/21

switchport access vlan 905

int g0/22

switchport access vlan 901

int vlan1

ip address 170.53.73.56 255.255.255.0

int vlan 901

ip address 10.255.255.2 255.255.255.0

int vlan 905

ip address 10.255.254.2 255.255.255.0

Tried to change the 3560 vlan1 ip to 10.1.255.73 255.255.0.0

Leo Laohoo
VIP Community Legend

The telnet was made from 10.1.5.38 on 3750 vlan1 to 3560 10.255.254.2 which is vlan905.

No you didn't.  You telnet from 3750 VLAN 1 to 3560 VLAN 1 and bridged to VLAN 905.

So when I am on terminal server 10.1.5.38 which connects to the 3750 vlan 1 and telnet to 10.255.254.2 (vlan 905)

on the 3560 I am really telnetting to the 3560 vlan 1 bridging to 905.  Then when I changed the vlan 1 ip I would lose my connection but why would all network traffic on other vlans stop?

Leo Laohoo
VIP Community Legend

Then when I changed the vlan 1 ip I would lose my connection but why would all network traffic on other vlans stop?

Good question.  Are you running IP Routing IOS or just IP Base?

IP routing.

Why vlan 1 on the 3750 is on one subnet and on the 3560 a different subnet?

int vlan1

ip address 10.1.1.1 255.255.0.0

3560:

int vlan1

ip address 170.53.73.56 255.255.255.0