cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

1646
Views
0
Helpful
1
Replies
Beginner

Problem with CS3020 Cisco Switches in HP C7000 enclosure.

                   OK, I am no Cisco guru, and am really stuck here. This is probably not difficult, but I am perplexed at this point.

I have 5 ESX servers that are already fully configured, and were talking across my network earlier. The (2) switches in this enclosure were

manipulated and no longer seem to talk. Basically, just dealing with the first switch, and trying to get it working first. I'll just copy the config over when this one is fixed.

So, the first 16 ports on the switch are connected to the positions 1-16 in the enclosure, where blade servers would be. In this case, positions 1-5 are in use.

In the back of the enclosure, the switch has ports 0/17 - 24 for external connections. 2 ports are in use for a LACP uplink to the core switch. 2 ports  are in use for a LAPC uplink to external storage.

I can, from the core switch, pint this switch in the enclosure, and vice versa. I cannot however, from this switch in the enclosure ping any blade switches in the enclosure.

My servers are at 10.10.1.233 - 236

The enclosure's Cisco CS3020 switch is at 10.10.0.18      255.255.0.0

My core switch is 10.10.0.13      255.255.0.0

My config looks like this now:

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname BL465c_SW1

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$e1CS$aYLN09vAVG7LzaKQHseno0

enable password Seagate_2001

!

no aaa new-model

system mtu routing 1500

ip subnet-zero

!

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface Port-channel1

description HP CORE

switchport trunk allowed vlan 1-3,100

switchport mode trunk

!

interface Port-channel2

description ESXi VLAN trunk

switchport trunk allowed vlan 1-3,90,100

switchport mode trunk

!

interface Port-channel5

description storage HP-SW1

switchport trunk allowed vlan 90

switchport mode trunk

!

interface FastEthernet0

description ILO connection

no ip address

no ip route-cache

no ip mroute-cache

shutdown

!

interface GigabitEthernet0/1

switchport access vlan 3

switchport mode access

speed 1000

spanning-tree portfast

         !

interface GigabitEthernet0/2

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/3

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/4

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/5

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/6

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/7

speed 1000

          spanning-tree portfast

!

interface GigabitEthernet0/8

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/9

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/10

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/11

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/12

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/13

          speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/14

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/15

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/16

speed 1000

spanning-tree portfast

!

interface GigabitEthernet0/17

spanning-tree portfast

!

interface GigabitEthernet0/18

spanning-tree portfast

!

interface GigabitEthernet0/19

switchport trunk allowed vlan 1-3,100

          switchport mode trunk

spanning-tree portfast

!

interface GigabitEthernet0/20

description HP CORE

switchport access vlan 3

switchport trunk allowed vlan 1-3,100

switchport mode trunk

channel-protocol lacp

channel-group 1 mode active

spanning-tree portfast trunk

!

interface GigabitEthernet0/21

description Back to HP STORAGE

switchport access vlan 90

switchport trunk allowed vlan 90

switchport mode trunk

channel-protocol lacp

channel-group 5 mode active

spanning-tree portfast trunk

!

interface GigabitEthernet0/22

description HP CORE

          switchport access vlan 3

switchport trunk allowed vlan 1-3,100

switchport mode trunk

speed 1000

channel-protocol lacp

channel-group 1 mode active

spanning-tree portfast trunk

!

interface GigabitEthernet0/23

description Back to HP STORAGE

switchport access vlan 90

switchport trunk allowed vlan 90

switchport mode trunk

channel-protocol lacp

channel-group 5 mode active

spanning-tree portfast trunk

!

interface GigabitEthernet0/24

!

interface Vlan1

ip address 10.10.0.18 255.255.0.0

no ip route-cache

no ip mroute-cache

!

interface Vlan2

no ip address

no ip route-cache

no ip mroute-cache

!

interface Vlan3

no ip address

no ip route-cache

no ip mroute-cache

!

interface Vlan90

no ip address

no ip route-cache

no ip mroute-cache

!

ip default-gateway 10.10.0.1

ip classless

ip http server

ip http secure-server

!

snmp-server community public RO

!

line con 0

line vty 0 4

password xxxxx

login

line vty 5 15

password xxxxx

login

!

end

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname BL465c_SW1

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$e1CS$aYLN09vAVG7LzaKQHseno0

enable password ^&%&^
!
no aaa new-model
system mtu routing 1500
ip subnet-zero
!
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1449868288
revocation-check none
rsakeypair TP-self-signed-1449868288
!

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface Port-channel1
description HP CORE
switchport trunk allowed vlan 1-3,100
switchport mode trunk

!

interface Port-channel2
description ESXi VLAN trunk
switchport trunk allowed vlan 1-3,90,100
switchport mode trunk
!
interface Port-channel5
description storage HP-SW1
switchport trunk allowed vlan 90
switchport mode trunk
!
interface FastEthernet0
description ILO connection
no ip address
no ip route-cache
no ip mroute-cache
shutdown
!
interface GigabitEthernet0/1
switchport access vlan 3
switchport mode access
speed 1000
spanning-tree portfast
         !
interface GigabitEthernet0/2
speed 1000
spanning-tree portfast
!
interface GigabitEthernet0/3
speed 1000
spanning-tree portfast
!
interface GigabitEthernet0/4
speed 1000
spanning-tree portfast
!
interface GigabitEthernet0/5
speed 1000
spanning-tree portfast
!
interface GigabitEthernet0/6
speed 1000
spanning-tree portfast
!
interface GigabitEthernet0/7
speed 1000
         spanning-tree portfast
!
interface GigabitEthernet0/8
speed 1000
spanning-tree portfast
!
interface GigabitEthernet0/9
speed 1000
spanning-tree portfast
!
interface GigabitEthernet0/10
speed 1000
spanning-tree portfast
!
interface GigabitEthernet0/11
speed 1000
spanning-tree portfast
!
interface GigabitEthernet0/12
speed 1000
spanning-tree portfast
!
interface GigabitEthernet0/13
         speed 1000
spanning-tree portfast
!
interface GigabitEthernet0/14
speed 1000
spanning-tree portfast
!
interface GigabitEthernet0/15
speed 1000
spanning-tree portfast
!
interface GigabitEthernet0/16
speed 1000
spanning-tree portfast
!
interface GigabitEthernet0/17
spanning-tree portfast
!
interface GigabitEthernet0/18
spanning-tree portfast
!
interface GigabitEthernet0/19
switchport trunk allowed vlan 1-3,100
          switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/20
description HP CORE
switchport access vlan 3
switchport trunk allowed vlan 1-3,100
switchport mode trunk
channel-protocol lacp
channel-group 1 mode active
spanning-tree portfast trunk
!
interface GigabitEthernet0/21
description Back to HP STORAGE
switchport access vlan 90
switchport trunk allowed vlan 90
switchport mode trunk
channel-protocol lacp
channel-group 5 mode active
spanning-tree portfast trunk
!
interface GigabitEthernet0/22
description HP CORE
          switchport access vlan 3
switchport trunk allowed vlan 1-3,100
switchport mode trunk
speed 1000
channel-protocol lacp
channel-group 1 mode active
spanning-tree portfast trunk
!
interface GigabitEthernet0/23
description Back to HP STORAGE
switchport access vlan 90
switchport trunk allowed vlan 90
switchport mode trunk
channel-protocol lacp
channel-group 5 mode active
spanning-tree portfast trunk
!
interface GigabitEthernet0/24
!
interface Vlan1
ip address 10.10.0.18 255.255.0.0
no ip route-cache
no ip mroute-cache
        !
interface Vlan2
no ip address
no ip route-cache
no ip mroute-cache
!
interface Vlan3
no ip address
no ip route-cache
no ip mroute-cache
!
interface Vlan90
no ip address
no ip route-cache
no ip mroute-cache
!
ip default-gateway 10.10.0.1
ip classless
ip http server
ip http secure-server
!
snmp-server community public RO
!
line con 0
line vty 0 4
password xxxxx
login
line vty 5 15
password xxxxx
login
!
end

Also, those servers in the enclosure are esxi 4.1 hosts, and will each host vm's from  vlan 1, 2, 3. vmware vmotion is on vlan100. All storage is on vlan 90. So, essentially, each port (at least 1-5, currently) will need to talk to all of those vlans.

Can anyone advise?

Everyone's tags (3)
1 REPLY 1
Highlighted
Beginner

Problem with CS3020 Cisco Switches in HP C7000 enclosure.

Looks like you have the config posted twice.

Anyway, you could set the ports to Trunk and tag the Virtual NICs with their respective VLAN.

CreatePlease to create content
Content for Community-Ad