cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1508
Views
0
Helpful
7
Replies
Beginner

Problem with stacking two Cisco 3850 switches

Hello,

I have a question about stacking two cisco 3850 switches. I configured the 3850-12s switches and connected the stack cable. Ater bootup I saw at command show switch:

Switch 1 -> active -> Priority 15 -> ready

Switch 2 -> Standby ->Priority 1 -> ready


At show switches stack-ports summary

1/1 Down -> cable: 50cm -> link ok: yes -> link active: no

1/2 OK -> cable: 50cm -> link ok: yes -> link active: yes

2/1 OK -> cable: 50cm -> link ok: yes -> link active: yes

2/2 down -> cable: no cable -> link ok: no -> link active: no

 
The two stackwise cables are connected and also the powerstack cables are connected.

I shutdown Switch 2 and reversed the cables becouse I want to identify where the „no cable“ message comes from. The following was displayed:

1/1 Down -> cable: 50cm -> link ok: yes -> link active: yes

1/2 OK -> cable: 50cm -> link ok: yes -> link active: no

2/1 OK -> cable: no cable -> link ok: no -> link active: no

2/2 down -> cable: 50cm -> link ok: yes -> link active: yes

 

On every port where the one cable is connected, it is displayed: no cable.

Is it possible that the one cable are be damaged or have I do something wrong with the configuration?

When I opened show ip int brief all interfaces from both switches are displayed

Switch 1 -> GI1 -> 1 – 12
Switch 2 -> GI2 -> 1 – 12

I disconnect all stacking cables but know I have the problem that Switch 1 is working fine but switch 2 has still a wrong configuration it seems to be like the same configuration from switch 1.

For examble Switch 2 has now the hostname of Switch 1 and also the interfaces still named with GI2 (normally is GI1).

What can I do now? How can I delete the complete stack configuration on switch 2 to start the stack configuration again?
When I connect the stack cables now, I only see the active Switch 1. Switch 2 is no more shown at the stack.

Thanks in advance

Sven

7 REPLIES 7
VIP Expert

Hi,

Hi,

To remove switch 2 from the stack follow these steps.:

Removing Provisioned Switch Information

This optional task is available only from the active switch.

SUMMARY STEPS

1.    Remove the provisioned switch from the stack.

2.    no switch stack-member-number provision

3.    copy running-config startup-config

Link for more info:

http://www.cisco.com/en/US/docs/switches/lan/catalyst3850/software/release/3.2_0_se/multibook/configuration_guide/b_consolidated_config_guide_3850_chapter_01100101.html#task_D9842BED4F9A44A694C0FC29B964481C
Also, you may have a damaged stacking cable.  Maybe a bent pin or something causing it not to connect.
HTH

Beginner

Hi,

Hi,

I have removed the provisioned switch from the stack and has entered:

no switch 2 provision

but I get the error message: Error: This location is not prior provisioned

but at show switch I still only see switch 1

thanks for help

Enthusiast

Hi;

Hi;

You are getting the same hostname (switch-1) due to you connect the switch with stack cable. If you want to remove the configuration and interface should start with G1/X/X. Then just write erase and reload the switch.

Thanks & Best regards;

Beginner

Hy,

Hy,

I have done write erase and reload the switch but the interfaces are still start with GI2. Also different other configuration for example the provision of the switch is still present.

I've reconfigured the Switch now and order a RMA for the defective stack cable. When the new cable arrive I will try the stack again.

thanks and best regards

Sven

Beginner

Hello again,

Hello again,

today I received the new stack cable from Cisco. I have turned off switch 2 and connected the stackwise and the powerstack cable, but I think the problem is still the same. (Before switch 2 was resetet completely)

show switch stack-ports summary

Sw#/Port#  Port Status  Neighbor  Cable Length   Link OK   Link Active   Sync OK   #Changes to LinkOK  In Loopback

-------------------------------------------------------------------------------------------------------------------

1/1        OK           2             50cm           Yes       Yes           Yes       1                   No

1/2        DOWN    NONE     No cable       No        No            Yes       1                   No

2/1        DOWN    NONE     50cm           Yes       No            Yes       1                   No

2/2        OK           1             50cm           Yes       Yes           Yes       1                   No

At switch 1 port 2 the cable length is still displayed with No cable. (The old working cable and not the damaged cable is connected on this port)

At show ip int brief all ports of both switches are shown and at show stack-power the power stack is also working fine.

At show switch detail it also looks good

Switch#   Role    Mac Address     Priority Version  State

------------------------------------------------------------

*1       Active   94d4.6937.0400     15     V02     Ready

 2       Standby  94d4.6937.2780     14     V02     Ready

 

How can I check if the stack regardless work correctly?

Should I replace the cable again with each other to check again?

If anybody has I idea why „no cable“ is still shown?

Thanks in advance

Sven

Beginner

Re: Hello again,

Sven,

Did you ever get this resolved?  I ran into the same issue last night trying to move a stack that worked fine in the lab into production.

Thanks!

Highlighted
Frequent Contributor

Re: Hello again,

Hi mate,

 

I had same issue and I got it solved with a reboot of the stack and then finally the command worked.

CreatePlease to create content
Content for Community-Ad