Showing results for 
Search instead for 
Did you mean: 

Problems with software upgrade of C2960G-48TC-L.

Hi. I tried to upgrade software for C2960G-48TC-L from 12.2(35)SE5 to the latest 12.2.50-SE3(ED).

Upgrade was made through web interface from "c2960-lanbasek9-tar.122-50.SE3.tar" file. After all the 4 steps were succesfully finished the switch restarted & now only two orange lamps SYST & RPS are lit :(

P.S. as you certainly understood I'm new to Cisco products & my selfassurance got me into trouble, but I can't even call directly to Cisco, because our service contract ended some time ago & I suppose Cisco forum is the best place to ask in such cases.

Thank God that the network worked not only on that switch, which I "upgraded", so I just plugged users from it to the second one...


Hi Valery,

I am afraid you have perhaps the new image was corrupt. All you have to do is upload a good image using XMODEM. remember it will take longtime, but will work. Just follow the steps in this document listed for 2950, the steps are same for 2960.

Hope This helps...



If you change the xmodem and switch rate to 115200 bps the xmodem process will probably take maybe 10 minutes for a small layer 2 switch like the 2960. Usually it will indicate in the recovery doc on how to do this.

Thanks for the unswer. Here's what the terminal connection says in brief:


!!! WARNING: The switch is not usable !!!


Error unsupported TCAM value size

Actual value = 1, Expected value = 20


Is it what you were talking about or is it smth else?

P.S. Putty's log is in attachment.


to be honest, I have not seen these messages before....

Did you actually try deleting the current IOS and upload the previous IOS you previously had. I have a feeling that the current IOS Version 12.2(50)SE3

which is in the flash is corrupt. try reverting back to the previous IOS version and if you still get this message then you have to RMA this switch.

Hope this helps...


I'm stuck at step 2 of the manual:

I'll describe it,because it's quitу strange:

I use hyperterminal on WinXP to connect to the switch.

After it boots I can see ... & "Press RETURN to get started!"

I press enter & get

"*Mar 1 00:00:14.336: hl2mcm_core_process: hl2mcm_install_hl2mcm_ctrl_entries() failed.

*Mar 1 00:00:14.336: %SYS-3-HARIKARI: Process HL2MCM top-level routine exited

*Mar 1 00:00:15.149: %SPANTREE-5-EXTENDED_SYSID: Extended SysId enabled for type vlanCannot Get the number of ports in MAC notification

*Mar 1 00:00:15.443: %SW_VLAN-4-IFS_FAILURE: VLAN manager encountered file operation error: call = ifs_read_until (header) / file = / code = 21 (Is a directory) / bytes transfered = -1

-Traceback= BB5030 BB577C 1DCBB8 1D890C 108EE50 1085920

*Mar 1 00:00:16.609: %SYS-5-RESTART: System restarted --

Cisco IOS Software, C2960 Software (C2960-LANBASEK9-M), Version 12.2(50)SE3, RELEASE SOFTWARE (fc1)

Technical Support:

Copyright (c) 1986-2009 by Cisco Systems, Inc.

Compiled Wed 22-Jul-09 07:03 by prod_rel_team

*Mar 1 00:00:16.626: Unable to open UDP socket on CMP_PORT

!!! WARNING: The switch is not usable !!!


Error unsupported TCAM value size

Actual value = 1, Expected value = 20


according to the manual ( I should get "switch:" not "switch>"

But I I tried to type init_flash press enter but it says:


Translating "flash_init"...domain server (

% Unknown command or computer name, or unable to find computer address"

What am I doing wrong?

I also tried to press ctrl+break before it starts to load the "corrupted" image file from flash,but ctrl+break does nothing there & there's no such message: "*** The system will autoboot in 15 seconds *** Send break character to prevent autobooting." at all!



try holding the mode button at the front and then connect the power lead

your terminal skip the boot process and you should see a prompt...


and above this prompt you will see 3 commands listed as (flash_init), (load_helper) and (boot).

execute the 1st 2 and then follow the steps to delete current IOS from the flash and then xmodem our previous IOS.

Hope This Helps....


I've got only flash_init & boot commands on this screen :(

And also load_helper gives me:

Unknown cmd: load_helper :(


just issue the flash_init


type ?

this will give you list of command you can use

for example dir flash:

will list the contents in flash

and for example, to delete a file cisco.text from the flash, you will need to type as

delete flash:cisco.text

Hope this helps...rate all helpful posts..


Thnx for such detailed explanations :) I know how to use some commands :)), but I thought that load_helper is a must to type before xmodem tranfer & so on.

Now xmodem transfer is in process.

By the way thnx to glen.grant for advice about sppeding up xmodem transfer. Of cource it was in the manual, but I won't do so, as the mentioning of this was in the very end of the manual.

you are welcome

the only reason i typed basic steps are you mentioned you were new to Cisco in your original post. I did not mean to offend you in any way

thanks for letting us know the issue is resolved.