cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1106
Views
0
Helpful
4
Replies
Beginner

QinQ termination vlan

Hello,

I have to peer with a cloud services with the use of QinQ (802.1ad).

We have a router Catalyst 4500-X connected to our service provider. The cloud services gave us this sample configuration to use on our router:

interface TenGigabitEthernet1/1/11.100

encapsulation dot1q 3000 second-dot1q 100

ip address 10.10.10.1 255.255.255.0

dot1q tunneling ethertype 0x88A8

Problem Catalyst 4500-X doesn't support subinterfaces.

So I found an another solution with SVI but it's not working.

This is the configuration I made (on the 4500X) in the interface facing the service provider:

interface TenGigabitEthernet1/1/11
description TO_CLOUD
switchport mode trunk
switchport vlan mapping 100 dot1q-tunnel 3000
dot1q tunneling ethertype 0x88A8
end

And I create an interface vlan 100:

interface vlan 100
description cust-vlan
ip address 10.10.10.1 255.255.255.0
end

Customer vlan = 100

SP vlan = 3000

Any idea about the issue ?

I attached a diagram showing my interconnection with the SP.

Everyone's tags (2)
4 REPLIES 4
Highlighted
VIP Mentor

Hello,

Hello,

I am not sure if this works at all. Try the additions (in bold) below:

interface TenGigabitEthernet1/1/11
description TO_CLOUD
switchport access vlan 100
switchport trunk allowed vlan all
switchport mode trunk
switchport vlan mapping 100 dot1q-tunnel 3000
dot1q tunneling ethertype 0x88A8

Highlighted
Beginner

Hello Georg,

Hello Georg,

Thank you for your help, I tried to add configuration in bold in my interface but I can't ping the peer IP (10.10.10.2). I learn a mac from the cloud peering but it's stored in vlan 1 inside router"s cam.

I captured traffic using the monitor capture feature on Cata 4500-X I saw arp request from cloud services with the correct tag information in the packet (3000 for S-vlan and 100 for Cust vlan).

When I did a ping I saw an arp request sent by the router but I can't verify tag information because monitor feature operate before encapsulation.

have you already deploy this kind of feature (selective QinQ ) ?

Highlighted
Beginner

Hello,

Hello,

Can you verify the native vlan on both your side and the service provider? And try enabling native vlan tagging globally and on interface?

global command = vlan dot1q tag native

interface TenGigabitEthernet1/1/11
 description TO_CLOUD
 switchport mode trunk
 switchport trunk native vlan ###
 switchport trunk allowed vlan 3000
 switchport vlan mapping 100 dot1q-tunnel 3000
 dot1q tunneling ethertype 0x88A8

Highlighted
Beginner

Re: QinQ termination vlan

Hey!  Were you able to fix this?  I am having a similar problem!

CreatePlease to create content
Content for Community-Ad