cancel
Showing results forĀ 
Search instead forĀ 
Did you mean:Ā 
cancel
287
Views
0
Helpful
3
Replies

QoS on Catalyst Switch

Hi there,

Im in the process of taking over a network. The organization is at the same time in the process of upgrading their phone system (away from Cisco actually). I was tasked with reviewing the existing QoS config. They currently have QoS implemented on their catalyst switches (3550's). The new phone system will be able to mark with dcsp, so the current config will be adjusted. I just want to make sure that im properly interpreting the existing config.

Iā€™ve included only the relevant QoS config (see blow). It seems to be AutoQoS without any manual configurations. All interfaces have the exact same config. The (Cisco) phones are connected to the switch, and PCs are connected to the phones. The switch is configure with Voice Vlans (obviously using CDP to identify the phones). In my new config I will of course need to use trunk ports to identify the voice vlan, buts thatā€™s another story.

Thereā€™s one class-map matching dcsp EF, and a second matching match dscp cs3  af31. Thereā€™s a policy-map limiting the EF traffic to 320Kbps, and the cs3 traffic to 32kbps. The interfaces are configured to trust CoS, not dscp. Im going to assume the Cisco Phone are marking the RTP packets with CoS 5. I  see a cos-dscp map  which is mapping CoS 5 to EF (46).

See my questions/comments below.

------------------------------------------------------------

class-map match-all AutoQoS-VoIP-RTP-Trust
  match ip dscp ef 
class-map match-all AutoQoS-VoIP-Control-Trust
  match ip dscp cs3  af31 
!
policy-map AutoQoS-Police-CiscoPhone
class AutoQoS-VoIP-RTP-Trust
   set dscp ef
  police 320000 8000 exceed-action policed-dscp-transmit - I'm not seeing any "policed-dscp-transmit" mapping (to mark down) for the exceed-action. Is there a default to dscp 0?
class AutoQoS-VoIP-Control-Trust
   set dscp cs3
  police 32000 8000 exceed-action policed-dscp-transmit

interface FastEthernet0/1
switchport mode access
switchport voice vlan 2
srr-queue bandwidth share 10 10 60 20 - Priority queue is enabled for egress traffic (next command), which is queue 1. This command  is using shared round robin to guarantee 10% of the bandwidth (relative weight that is) for queue 1. Correct?
priority-queue out 
 mls qos trust device cisco-phone - needs to be removed
mls qos trust cos - needs to be changed to "mls qos trust dcsp"
macro description cisco-phone | cisco-phone | cisco-phone | cisco-phone
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input AutoQoS-Police-CiscoPhone

 

mls qos map cos-dscp 0 8 16 24 32 46 48 56 - mapping cos to dscp

The command below gives 90% BW ingress to Queue 1, and 10% BW  to queue 2. Is this setting (and all global config ingress settings) automatically applied to all interfaces?
mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16
mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33 
mls qos srr-queue input cos-map queue 1 threshold 2 1
mls qos srr-queue input cos-map queue 1 threshold 3 0
mls qos srr-queue input cos-map queue 2 threshold 1 2
mls qos srr-queue input cos-map queue 2 threshold 2 4 6 7

The command below maps CoS 5 to queue 2 and using threshold 3. Q2 is the default priority queue.  I dont see threshold 3 defined. Is it missing, or is threshold 3 the default when exceeding 100% (meaning it doesnt need to be defined)?
mls qos srr-queue input cos-map queue 2 threshold 3 3 5
mls qos srr-queue input dscp-map queue 1 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3 0 1 2 3 4 5 6 7
mls qos srr-queue input dscp-map queue 1 threshold 3 32
mls qos srr-queue input dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23
mls qos srr-queue input dscp-map queue 2 threshold 2 33 34 35 36 37 38 39 48
mls qos srr-queue input dscp-map queue 2 threshold 2 49 50 51 52 53 54 55 56
mls qos srr-queue input dscp-map queue 2 threshold 2 57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31

Same question as above. The command below is mapping dscp 46 to queue 2 using threshold 3,
mls qos srr-queue input dscp-map queue 2 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output cos-map queue 1 threshold 3 5
mls qos srr-queue output cos-map queue 2 threshold 3 3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3 2 4
mls qos srr-queue output cos-map queue 4 threshold 3 0
mls qos srr-queue output dscp-map queue 1 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3 16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3 32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1 8
mls qos srr-queue output dscp-map queue 4 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3 0 1 2 3 4 5 6 7

Im not seeing any queue-sets configured on the interfaces. Are all interfaces automatically a member of Queue-set 1, and automatically have these settings (defined for queue-set 1)?
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61

 

3 Replies 3

Hello.

I would suggest to review an option to upgrade your switches, as 3550 is EOS (since year 2011)  and not supported any more.

It will be also hard to get any support from community, because just a few people are using them.

So, let me note some general points:

 - changing trust to DSCP is not recommended, as in this case you desktops would be able to abuse your QoS;
 - you don't need trunk on the phone interfaces - keep it with "voice vlan";
 - threshold 3 is 100%.

Hi Vasilii,

Thanks for your response. Were probably going to upgrade the switches in the near future, but for the time being, i need to work with this. However, from a config/conceptual standpoint, its pretty much the same.

Were replacing the Cisco phones with non-cisco phones. If i dont configure trunking (aka vlan tagging), then how will the switch be able to identify traffic originating from the phones? I have the PCs connecting to the back of the phone.

 

 

Hello.

It's sad to hear that you need to work with such old devices. I disagree, that it almost the same - QoS differs a lot between the families and your question is right on it!

About trunking - the only thing you need to have is "swi voice vlan" - it's like a trunk, but for a single tagged vlan. Typically phones should learn about voice vlan from CDP (cisco phone) or DHCP (AVAYA phones use options 176 and 242).

If you have PC connected to the phones, "trust dscp" is not your choice!

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Innovations in Cisco Full Stack Observability - A new webinar from Cisco

Ā