cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
2021
Views
0
Helpful
8
Replies
saiyen_2002
Beginner

qos on cisco 2950

I have been reading through the lots of docs on how about configuring voice vlans on cisco switches, but almost all of them assume you have cisco IP phone. I can not find a definitive guide on how to configure voice vlans with non cisco phone, no CDP. I have the following setup

PC ---- IP-PHONE ------ Catalyst 2950

The PC and the phone are on 2 different subnets

I have read lots of docs on how to create voice vlans.

some say

switchport access vlan 100
switchport voice vlan 200

But I read somewhere that only works when there you CDP enabled phone.

I have come across

switchport trunk allowed vlan 100, 200

switchport mode trunk

switchport voice vlan 200

I am confused as to which way to proceed. Some even say you have to configure dot1p encapsulation on the ports as well. My phone can tag traffic originating from itself with vlan and priority. So which would be the best way to go?

Many Thanks

3 ACCEPTED SOLUTIONS

Accepted Solutions
Eugene Lau
Cisco Employee

Hi mate!

For non-cisco IP phones which do not support CDP you can configure a static trunk - which is what you have found in your research.

At a high level - in the Cisco world, when a Cisco IP phone is connected to a Cisco switch - the Cisco phone uses CDP to automatically detect and create a "internal trunk" that can identify 802.1q tagged traffic - for the voice vlan. Data VLAN is typically untagged.

In this light - non-cisco IP phones work in a similar fashion, so to simulate the internal trunk that is created via CDP we would configure a static trunk.

Configuration:

switchport trunk allowed vlan 100, 200  <<---- this makes sure that phone does not get traffic from other VLANs when in trunk mode

switchport mode trunk

switchport voice vlan 200

switchport trunk native vlan 100 <<---- I would try this for the Data VLAN traffic

mls qos trust cos  <<---- to trust the priority from the phone.

I've seen this a lot on the older 3rd party IP phones which did not support CDP.

HTH

Eugene

View solution in original post

Hi Saiyen,

By default, on Cisco switch, a 802.1q trunk will have a native VLAN of 1 (but doesn't show up in the config). Also, by default, a trunk will carry all VLAN's.

Typically, for Cisco phones - the data VLAN traffic is not tagged and untagged traffic will be switched through the native vlan. So, if you wanted the data VLAN to be 1, I would remove the

switchport access vlan 100

simply because it confuses people who look at the config :). In the context of your configuration, because the port will be a static trunk, it specifies that the access port will be in VLAN100 if in ACCESS mode. In TRUNK mode, it is not taken into account.

I did a quick search in google and found:

http://wiki.snom.com/Web_Interface/V7/Advanced#VLAN

It looks like you can tag the data vlan traffic  if you wish

HTH

Eugene.

View solution in original post

Hi Saiyen,

Yes, that's it! Configure the switchport access vlan 200 for the Asterix port to have the Asterix on the Voice VLAN.

You may need to consider a QoS config such as

#mls qos trust dscp -> if there's a QoS value for signalling traffic from the Asterix (which there should be).

HTH

Eugene.

View solution in original post

8 REPLIES 8
Leo Laohoo
VIP Community Legend

switchport access vlan 100
switchport voice vlan 200

You need to use this.

Don't forget that if you create VLAN 100 and 200, you need to create the VLAN instance.

Thanks leolaohoo. What if I want my pc data to gon on the default native VLAN1. Do I still have to do switchport access vlan 100?

Also, how would I configure the port that is connected to my PBX. I am using asterisk trixbox which will be on the same subnet as the IP phones. I need my IP phones to log into the PBX, so would I configure the port as a simple access VLAN on the same port as the voice VLAN. Like switchport access vlan 200?

Thanks

Eugene Lau
Cisco Employee

Hi mate!

For non-cisco IP phones which do not support CDP you can configure a static trunk - which is what you have found in your research.

At a high level - in the Cisco world, when a Cisco IP phone is connected to a Cisco switch - the Cisco phone uses CDP to automatically detect and create a "internal trunk" that can identify 802.1q tagged traffic - for the voice vlan. Data VLAN is typically untagged.

In this light - non-cisco IP phones work in a similar fashion, so to simulate the internal trunk that is created via CDP we would configure a static trunk.

Configuration:

switchport trunk allowed vlan 100, 200  <<---- this makes sure that phone does not get traffic from other VLANs when in trunk mode

switchport mode trunk

switchport voice vlan 200

switchport trunk native vlan 100 <<---- I would try this for the Data VLAN traffic

mls qos trust cos  <<---- to trust the priority from the phone.

I've seen this a lot on the older 3rd party IP phones which did not support CDP.

HTH

Eugene

View solution in original post

Hi Eugene,

Are you saying that the simple way of

switchport access vlan 100
switchport voice vlan 200

will not work at all? Or that the method you mention is the better one. My Snom360 IP Phone, does not have CDP, but it can tag the traffic with VLAN and priority.

Also, If I want my data to go on the default native VLAN1, i assume I can skip the line switchport trunk native vlan 100?

Hi Saiyen,

By default, on Cisco switch, a 802.1q trunk will have a native VLAN of 1 (but doesn't show up in the config). Also, by default, a trunk will carry all VLAN's.

Typically, for Cisco phones - the data VLAN traffic is not tagged and untagged traffic will be switched through the native vlan. So, if you wanted the data VLAN to be 1, I would remove the

switchport access vlan 100

simply because it confuses people who look at the config :). In the context of your configuration, because the port will be a static trunk, it specifies that the access port will be in VLAN100 if in ACCESS mode. In TRUNK mode, it is not taken into account.

I did a quick search in google and found:

http://wiki.snom.com/Web_Interface/V7/Advanced#VLAN

It looks like you can tag the data vlan traffic  if you wish

HTH

Eugene.

View solution in original post

Thanks for that Eugene, I am almost there. One last thing.

How would I configure the port that is connected to my asterisk trixbox pbx?  I need the IP phones to be able to log into the pbx which is on the same subnet. There is no tagging coming from the pbx, so would I just simply configure the port as an access port which is on the same VLAN as the voice VLAN?

Hi Saiyen,

Yes, that's it! Configure the switchport access vlan 200 for the Asterix port to have the Asterix on the Voice VLAN.

You may need to consider a QoS config such as

#mls qos trust dscp -> if there's a QoS value for signalling traffic from the Asterix (which there should be).

HTH

Eugene.

View solution in original post

Thanks for all the help Eugene. I will try all this out at work tommorw.