cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2060
Views
15
Helpful
9
Replies
Highlighted
Beginner

qos statistics on 2960 with cisco phone

Hi all!

please help me in understanding of "mls qos interface stat"

I took a switch and connected it to my LAN

switch is 2960 with LanBase image and PoE

on it I have 3 interfaces in up state - 2 interfaces with cisco phones (6921 and 9951) nad 1 interface as uplink

here is its configuration

interface FastEthernet0/1

switchport mode access

switchport voice vlan 555

mls qos trust device cisco-phone

spanning-tree portfast

!

interface FastEthernet0/2

switchport mode access

switchport voice vlan 555

mls qos trust device cisco-phone

spanning-tree portfast

!

...

interface GigabitEthernet0/1

switchport mode trunk

priority-queue out

mls qos trust dscp

!

I made just a call from one 9951 towards

I have no other devices on switch. so I have only voip traffic.

but why do I see the next stat screen?

test2960#sh mls qos int f0/1 sta

FastEthernet0/1 (All statistics are in packets)

  dscp: incoming 

-------------------------------

  0 -  4 :           0            0            0            0            0 

  5 -  9 :           0            0            0            0            0 

10 - 14 :           0            0            0            0            0 

15 - 19 :           0            0            0            0            0 

20 - 24 :           0            0            0            0           48 

25 - 29 :           0            0            0            0            0 

30 - 34 :           0            0            0            0            0 

35 - 39 :           0            0            0            0            0 

40 - 44 :           0            0            0            0            0 

45 - 49 :           0         3064            0            4            0 

50 - 54 :           0            0            0            0            0 

55 - 59 :           0            0            0            0            0 

60 - 64 :           0            0            0            0 

  dscp: outgoing

-------------------------------

  0 -  4 :     1512498            0            0            0            0 

  5 -  9 :           0            0            0            0            0 

10 - 14 :           0            0            0            0            0 

15 - 19 :           0            0            0            0            0 

20 - 24 :           0            0            0            0            0 

25 - 29 :           0            0            0            0            0 

30 - 34 :           0            0            0            0            0 

35 - 39 :           0            0            0            0            0 

40 - 44 :         729            0            0            0            0 

45 - 49 :           0            0            0            0            0 

50 - 54 :           0            0            0            0            0 

55 - 59 :           0            0            0            0            0 

60 - 64 :           0            0            0            0 

  cos: incoming 

-------------------------------

  0 -  4 :          27            0            0           48            0 

  5 -  7 :        3064            4            0 

  cos: outgoing

-------------------------------

  0 -  4 :     1581099            0            0            0            0 

  5 -  7 :         729            0            0 

  output queues enqueued:

queue: threshold1 threshold2 threshold3

-----------------------------------------

queue 0:         729           0           0

queue 1:     1569605         425        2043

queue 2:           0           0           0

queue 3:           0           0       11072

  output queues dropped:

queue: threshold1 threshold2 threshold3

-----------------------------------------

queue 0:            0            0            0

queue 1:            0            0            0

queue 2:            0            0            0

queue 3:            0            0            0

Policer: Inprofile:            0 OutofProfile:            0

and

test2960#sh mls qos int f0/2 sta

FastEthernet0/2 (All statistics are in packets)

  dscp: incoming 

-------------------------------

  0 -  4 :           2            0            0            0            0 

  5 -  9 :           0            0            0            0            0 

10 - 14 :           0            0            0            0            0 

15 - 19 :           0            0            0            0            0 

20 - 24 :           0            0            0            0          171 

25 - 29 :           0            0            0            0            0 

30 - 34 :           0            0            0            0            0 

35 - 39 :           0            0            0            0            0 

40 - 44 :           0            0            0            0            0 

45 - 49 :           0         5689            0            0            0 

50 - 54 :           0            0            0            0            0 

55 - 59 :           0            0            0            0            0 

60 - 64 :           0            0            0            0 

  dscp: outgoing

-------------------------------

  0 -  4 :     2095831            0            0            0            0 

  5 -  9 :           0            0            0            0            0 

10 - 14 :           0            0            0            0            0 

15 - 19 :           0            0            0            0            0 

20 - 24 :           0            0            0            0           14 

25 - 29 :           0            0            0            0            0 

30 - 34 :           0            0            0            0            0 

35 - 39 :           0            0            0            0            0 

40 - 44 :        3348            0            0            0            0 

45 - 49 :           0            0            0            1            0 

50 - 54 :           0            0            0            0            0 

55 - 59 :           0            0            0            0            0 

60 - 64 :           0            0            0            0 

  cos: incoming 

-------------------------------

  0 -  4 :          56            0            0          171            0 

  5 -  7 :        5689            0            0 

  cos: outgoing

-------------------------------

  0 -  4 :     2178523            0            0           14            0 

  5 -  7 :        3348            1            0 

  output queues enqueued:

queue: threshold1 threshold2 threshold3

-----------------------------------------

queue 0:        3348           0           0

queue 1:     2164282         590        2397

queue 2:          14           0           0

queue 3:           1           0       13653

  output queues dropped:

queue: threshold1 threshold2 threshold3

-----------------------------------------

queue 0:            0            0            0

queue 1:            0            0            0

queue 2:            0            0            0

queue 3:            0            0            0

Policer: Inprofile:            0 OutofProfile:            0

All incoming traffic is as I expect - DSCP 48, CoS 5

but all outgoing traffic???

Should notice I have next statements in config too:

mls qos map cos-dscp 0 8 16 24 32 46 48 56

mls qos

And I use CUCM 7.1 (if it is important)

Please help me to understand!!!

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Participant

Re: qos statistics on 2960 with cisco phone

Hello,

DSCP 46 suppose to map to COS 5, which is recommended.

Try this on ur uplink

interface GigabitEthernet0/1

switchport mode trunk

priority-queue out

mls qos trust coz

Because this is a layer, 2 interface.

Check this attached document and let me know if had any question

Please rate this information is helpful.

thanks

View solution in original post

9 REPLIES 9
Highlighted
Participant

Re: qos statistics on 2960 with cisco phone

Hello,

DSCP 46 suppose to map to COS 5, which is recommended.

Try this on ur uplink

interface GigabitEthernet0/1

switchport mode trunk

priority-queue out

mls qos trust coz

Because this is a layer, 2 interface.

Check this attached document and let me know if had any question

Please rate this information is helpful.

thanks

View solution in original post

Highlighted
Enthusiast

qos statistics on 2960 with cisco phone

Thanks for the doc Amrinder, actually i was looking to understand the basic wherein you have provided it.

regards

srikanth

Highlighted
Participant

qos statistics on 2960 with cisco phone

Hi Srikanth ,

ur welcome mate.

glad i help u.

cheers

Highlighted
Beginner

qos statistics on 2960 with cisco phone

hi guys!

thanx for a great article, Amrinder!

but I still have questions.

1. "DSCP to QoS map" - what is it?

2. where can I read smth about "Internal DSCP"?

Highlighted
Participant

qos statistics on 2960 with cisco phone

Hi Srikanth ,

You can use see blow its showing both cos to dscp and dscp to cos

Network-Test#sh mls qos maps cos-dscp

   Cos-dscp map:

       cos:   0 1 2 3 4 5 6 7

     --------------------------------

       dscp:   0 8 16 24 32 46 48 56

Network-Test#sh mls qos maps dscp-cos

   Dscp-cos map:

     d1 : d2 0 1 2 3 4 5 6 7 8 9

     ---------------------------------------

     0 :   00 00 00 00 00 00 00 00 01 01

     1 :   01 01 01 01 01 01 02 02 02 02

     2 :   02 02 02 02 03 03 03 03 03 03

     3 :   03 03 04 04 04 04 04 04 04 04

     4 :   05 05 05 05 05 05 05 05 06 06

     5 :   06 06 06 06 06 06 07 07 07 07

     6 :   07 07 07 07

as you can see cos 5 mapped to DSCP 46

Cos is layer 2 marking and DSCP is layer 3. if you enable Auto Qos on switch it will automatically create these table and handle the traffic.

http://www.ciscopress.com/articles/article.asp?p=170743&seqNum=3

check this link for more detail.

please rate if this helps

thanks

Highlighted
Beginner

qos statistics on 2960 with cisco phone

Hello, Amrinder!

please correct me if I'm wrong.

internal DSCP = ingress DSCP if I have "mls qos trust dscp"

internal DSCP is taken from cos-to-dscp map if I have "mls qos trust cos"

egress cos is taken from dscp-to-cos table, where dscp=internal dscp

thanks

Highlighted
Participant

qos statistics on 2960 with cisco phone

Highlighted
Beginner

qos statistics on 2960 with cisco phone

thanx a lot. but this is a brocade cli manual not cisco... is it good idea to use it?

Highlighted
Participant

qos statistics on 2960 with cisco phone

Content for Community-Ad