cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

717
Views
0
Helpful
4
Replies
Beginner

"ip tcp adjust-mss" on interface Port-Channel

Hi Sir,

I have the following port channel config on a Cisco 7609:

!

interface Port-channel1

ip address 10.10.10.10 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip ospf message-digest-key 1 md5 cisco123

logging event link-status

no mpls ldp igp sync

service-policy input POLICER

service-policy output POLICER

!

interface GigabitEthernet2/1

no ip address

no cdp enable

channel-protocol pagp

channel-group 1 mode desirable

!

interface GigabitEthernet2/6

no ip address

no cdp enable

channel-protocol pagp

channel-group 1 mode desirable

!

Module 2 is a WS-X6724-SFP.

I want to configure the "ip tcp adjust-mss" command on the interface. Please advise whether I should apply the command on the Port-Channel or the physical interfaces or both.

Thank you.

B.Rgds,

Lim TS

4 REPLIES 4
Hall of Fame Expert

Re: "ip tcp adjust-mss" on interface Port-Channel

Hello Lim,

you can configure a command regarding TCP OSI layer4 only on L3 interfaces so member links of the port channel don't need it.

You may need to consider a change on interface mtu and ip mtu.

Also I would consider if the command has to be given on the layer3 interface on the client Vlan.

It is likely that th bundle is a core facing link.

So it may be the wrong place for the command also on the logical interface

Hope to help

Giuseppe

Beginner

Re: "ip tcp adjust-mss" on interface Port-Channel

Hi Giuseppe,

Thanks for your reply.

The port-channel interface is facing client.

Thank you.

B.Rgds,

Lim TS

Hall of Fame Cisco Employee

Re: "ip tcp adjust-mss" on interface Port-Channel

Hello Lim,

Please allow me a question: Why do you want to use the "ip tcp adjust-mss" command? Do you have a special reason to manipulate the MSS?

Best regards,

Peter

Highlighted
Beginner

Re: "ip tcp adjust-mss" on interface Port-Channel

I too am considering adjust-mss on an LACP facing a WLC.

 

I noted that you cannot apply to the LACP (int Po1 ) 

 

I've TAC'd and they've explained that it should not applied on virtual interfaces.

 

I'm tempted to apply at the physical ports in the Po1 : but I've seen the port channel go down when the physical interface have anything on them that are not applied from the int Po1>

 

Any input here would be appreciated.

 

in answer to the "why" questions:   i use GRE through ipsec.   we must resize to accommodate the L3/Gre/IpSec header size.      as you will find in 16.3.x  you can apply an Adjust-Mss at the GRE, but (based on what TAC tells me) it does not actually resize / fragment anything.    When encountering a server that was set to try jumbo packets and not resize its own mss (Linux box)  we found that it lost traffic.   When reviewing PCAP we found that the traffic (too big) arrived at the GRE and was dropped.  The Switch did NOT send notification of the drop back to the apache system and so it was not re-transmitted.     This manifested as www surfing on the machine reported as "lost"

 

Fix I decided was adjusting MSS at a L3 link between the server system and the desktop.

 

 

 

 

_ M

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards