cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
68711
Views
186
Helpful
23
Replies

"No password set" on c3745

philuu
Beginner
Beginner

Hi,

My c3745 printed "No password set" when I tried to get to the enable mode. So, I tried to do password-recovery, but it is always in the user-mode mode despite the attempts to type "Cntrl-Break", "Alt-b", "Cntrl-C" during the initial reload.

It failed to go into the Rommon mode, is it has to do with "no service password-recovery ..." being set? What else can I do to solve the problem?

Thanks in advance....

PL

23 REPLIES 23

sourabhagarwal
Enthusiast
Enthusiast

you have forgot enable password and want to do password recovery with "no service password-recovery" command set. this command will enable ROMMON security which disable access to ROMMON due to which you are unable to go into the ROMMON mode.

There are only a few methods mentioned in the below URL which you can use to recover from a lost password, but all of them destroy the start-up configuration.

http://www.cisco.com/en/US/products/hw/routers/ps274/products_configuration_example09186a00801d8113.shtml

hope to help ... rate if it does ....

ankbhasi
Cisco Employee
Cisco Employee

Hi Pl,

I believe you have no password configured for your enable mode and that is the reason it is prompting you a message as "NO Password Set".

I believe you are telnetting into the router?

Do you have a console access of your router? If yes try to console into it and then set the enable password as well as the telnet password.

Regards,

Ankur

philuu
Beginner
Beginner

Hi, sourabhagarwal:

It's not stuck in ROMMON mode, it's in user-mode instead. I don't want to do password recovery with "no service password-recovery", just simply want to be able to get into the enable mode.

The link you pointed me suggests to boot via Flash SIMM or PCMCIA card, I already have the image in my PCMCIA card. I turned off/on the router but it still reloaded right into user-mode, not giving me a chance to see text during loading-up process, thus Cntrl-break into ROMMON.

PL

is enable password set or not on the router?

do you know what is the enable password?

if enable password is not set, can you set enable and telnet password through console and then try to telnet?

if you forget enable password, and you have configure "no service password-recovery", then you need to recover password using steps mentioned in that URL.

Hi, sourabhagarwal:

Unfornately, I don't know the password, but I cannot even get to the enable mode to begin the configuration.

Therefore, I cannot do "no service ..." or setting the password yet.

PL

if you don't know the enable password, you won't be able to get into the enable mode and hence can't get into configuration mode to make any config changes.

only option is to do password recovery as mentioned in that URL or to check with someone who knows the password which I hope you have already done.

Correct me if I'm wrong, but if I'm experiencing the exact same problem, and I think I am, then when we type "enable" to go into Priviledged EXEC mode, we get message "% No password set." It appears there is NO Enable mode password to type in! I am doing this from a direct Console connection. When I boot from Power OFF state, I do NOT see any messages at all, then suddenly I see the USER Mode prompt with hostname. That's it!

I will keep searching for updates to this problem.

James

Is it possible that you are connected to the aux port instead of the console port? The behavior that you describe of boot the router, see no messages, and then see the user prompt is the behavior I would expect on the aux and would be very surprising on the console.

HTH

Rick

HTH

Rick

Well, let me first say in my defense, I just started wearing reading glasses! Secondly, I did lean around the side of the rack case and reach over to connect my Console cable, without my glasses on, AND plugged right into the AUX Port!!! Duh! So much for working in confined spaces.

Thanks.

LOL. This is a very old post but I gotta say, it just saved my life while working with a smart-hands at a very, very remote location. Much appreciated!!!

Don't feel bad. Same thing with me. You helped me solve my issue, so respect to ya...

Ric has hit it on the head you are plugged into the aux port instead of the console port. You will not see any messages on the aux port until the box is totally bootedup , use the console port to break in .

You saved the day .Thanks.

Thank you very much ..
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: