cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Ask the Expert- SD-WAN

265
Views
0
Helpful
9
Replies
Highlighted
Beginner

Redunancy with Nexus to HP Procurve

Dear all,

 

In our data center are two HP ProCurve 6120XG Blade Switches connected to two Nexus 5000 switches.

Hp procurve switch no.1 is connected to Nexus switch no.1 with one link (blue)

HP procurve switch no.2 is connected to Nexus switch no.2 with one link (blue)

Current connection is without red links, only with blue links.

Snímka1.JPG

I'd like to add another two links (red) for 100% redunancy.

What is the best way for best redunancy connection and what do I need to configure on the switches ?

I guess it would be possible with vPC .... ??

Sorry for my english ...

 

Thank you for your reply.

 

Everyone's tags (1)
9 REPLIES 9

Re: Redunancy with Nexus to HP Procurve

Hi @JakubMalik1782,

Yes, you can make use of the vPC feature on your Cisco Nexus 5000. The advantage of vPC is that you can utilize all your uplinks (100% bandwidth capacity) instead of having Spanning-Tree (STP) blocking your redundant links (50% bandwidth capacity).

Here a good whitepaper that can start helping you with the configuration Virtual PortChannel Quick Configuration Guide.

Once you have configured the following on both or your Nexus 5000:

  1. enable the vPC feature
  2. configured a vPC domain
  3. configured the vPC keepalive link
  4. configured the vPC peer-link 

You can enable LACP on your HP Switches and in your bundle of vPC lins on your Nexus 5000s.

I hope this helps.

VIP Advisor

Re: Redunancy with Nexus to HP Procurve

Hello

Are the nxos vCP peered together - meaning are they multi-chassis ether-channeled together - If so you can create vPC members of the hp switches so resiliency is introduced for them just like you have shown in your topology. 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
VIP Advisor

Re: Redunancy with Nexus to HP Procurve

As long as both the nexus configured in vPC domain (in the picture not shown as connected) - that is the best practice, then add the red link as per your requirement for the resilience connection for high availability.

 

BB
*** Rate All Helpful Responses ***
Beginner

Re: Redunancy with Nexus to HP Procurve

Yes, nexus switches are configured in vPC domain.

Here is config:


N5K-1# sh running-config interface po1

!Command: show running-config interface port-channel1
!Time: Wed Jul  3 13:50:11 2019

version 7.1(0)N1(1b)

interface port-channel1
  description vPC peer-link
  switchport mode trunk
  spanning-tree port type network
  vpc peer-link

N5K-1# sh running-config interface eth1/47

!Command: show running-config interface Ethernet1/47
!Time: Wed Jul  3 13:50:56 2019

version 7.1(0)N1(1b)

interface Ethernet1/47
  description vPC peer-link #1
  switchport mode trunk
  channel-group 1 mode active

N5K-1# sh running-config interface eth1/48

!Command: show running-config interface Ethernet1/48
!Time: Wed Jul  3 13:50:59 2019

version 7.1(0)N1(1b)

interface Ethernet1/48
  description vPC peer-link #2
  switchport mode trunk
  channel-group 1 mode active

So, how should be configured interfaces with red and blue links ? Same as po1 or eth1/48 ?

 

Thanks

 

VIP Mentor

Re: Redunancy with Nexus to HP Procurve

Hi
on Cisco side use a vpc PO on HP side use standard port-channel

example Cisco side config ,e1/1 on both switches , po4 needs to be on both sides too so iyt forms the VPC between the switches

interface port-channel4
description xxxxxxxxxxxxxxxxxxxxxxxxxxx
switchport mode trunk
no lacp suspend-individual
switchport trunk allowed vlan 2,10-11,17-18,20,28,31,33-34,36-39,48,50,64-65,70,72,74,76,78,80,90-96,102-103,105,107,226,400,1226,2224,2512,3020,3025-3028
logging event port link-status
logging event port trunk-status
speed 10000
vpc 4

interface Ethernet1/1
description xxxxxxxxxxxxxxxx
switchport mode trunk
switchport trunk allowed vlan 2,10-11,17-18,20,28,31,33-34,36-39,48,50,64-65,70,72,74,76,78,80,90-96,102-103,105,107,226,400,1226,2224,2512,3020,3025-3028
channel-group 4 mode active

interface Ethernet1/1
description
switchport mode trunk
switchport trunk allowed vlan 2,10-11,17-18,20,28,31,33-34,36-39,48,50,64-65,70,72,74,76,78,80,90-96,102-103,105,107,226,400,1226,2224,2512,3020,3025-3028
channel-group 4 mode active

##################################################

sh vpc 4


vPC status
----------------------------------------------------------------------------
id Port Status Consistency Reason Active vlans
------ ----------- ------ ----------- -------------------------- -----------
4 Po4 up success success 2,10-11,17-
18,20,28,31
,33-34,36-3
9,48,50,64-
65,70,72....

Beginner

Re: Redunancy with Nexus to HP Procurve

Hello Mark,

 

Is this config OK ?

 

interface port-channel4
description HP_c7000_Blade vPC peer-link #2
switchport mode trunk
no lacp suspend-individual
switchport trunk allowed vlan 1,20,43-44,61,80,100,127,413-415,419,503,505-506
logging event port link-status
logging event port trunk-status
speed 10000
vpc 4

interface Ethernet1/37
description HP_c7000_Blade_SW1
switchport mode trunk
switchport trunk allowed vlan 1,20,43-44,61,80,100,127,413-415,419,503,505-506
channel-group 4 mode active

interface Ethernet1/38
description HP_c7000_Blade_SW2
switchport mode trunk
switchport trunk allowed vlan 1,20,43-44,61,80,100,127,413-415,419,503,505-506
channel-group 4 mode active

VIP Mentor

Re: Redunancy with Nexus to HP Procurve

Hi
yes looks good , this would be all ports , each server would have a link back to each 5k under its own VPC
identical config on both sides , best to match the ports , so 37 on each side for serverA and port 38 on each side for serverB

#############################################################################
5KA

interface port-channel4
description HP_c7000_Blade vPC 4
switchport mode trunk
no lacp suspend-individual
switchport trunk allowed vlan 1,20,43-44,61,80,100,127,413-415,419,503,505-506
logging event port link-status
logging event port trunk-status
speed 10000
vpc 4

interface Ethernet1/37
description HP_c7000_Blade_SW1 vpc4
switchport mode trunk
switchport trunk allowed vlan 1,20,43-44,61,80,100,127,413-415,419,503,505-506
channel-group 4 mode active



interface port-channel5
description HP_c7000_Blade vPC 5
switchport mode trunk
no lacp suspend-individual
switchport trunk allowed vlan 1,20,43-44,61,80,100,127,413-415,419,503,505-506
logging event port link-status
logging event port trunk-status
speed 10000
vpc 5

interface Ethernet1/38
description HP_c7000_Blade_SW2 VPC5
switchport mode trunk
switchport trunk allowed vlan 1,20,43-44,61,80,100,127,413-415,419,503,505-506
channel-group 5 mode active

#############################################################################
5KB

interface port-channel4
description HP_c7000_Blade vPC 4
switchport mode trunk
no lacp suspend-individual
switchport trunk allowed vlan 1,20,43-44,61,80,100,127,413-415,419,503,505-506
logging event port link-status
logging event port trunk-status
speed 10000
vpc 4

interface Ethernet1/37
description HP_c7000_Blade_SW1 vpc4
switchport mode trunk
switchport trunk allowed vlan 1,20,43-44,61,80,100,127,413-415,419,503,505-506
channel-group 4 mode active


interface port-channel5
description HP_c7000_Blade vPC 5
switchport mode trunk
no lacp suspend-individual
switchport trunk allowed vlan 1,20,43-44,61,80,100,127,413-415,419,503,505-506
logging event port link-status
logging event port trunk-status
speed 10000
vpc 5

interface Ethernet1/38
description HP_c7000_Blade_SW2 VPC5
switchport mode trunk
switchport trunk allowed vlan 1,20,43-44,61,80,100,127,413-415,419,503,505-506
channel-group 5 mode active


Beginner

Re: Redunancy with Nexus to HP Procurve

Hello,

 

On HP Procurve switch should be turn on feauture LACP ?

VIP Mentor

Re: Redunancy with Nexus to HP Procurve

Yes you will need LACP on the HP side too , it just will not support the VPC syntax
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards