cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2585
Views
15
Helpful
13
Replies
Highlighted
Beginner

Redundant links between switches

So in my building I have a switch closet on each floor with a stack of 3750's. Each floor switch stack has a single fiber link to the core switch (3750) in the server room. Both switches are L3 and I've configured the link between as a dot1q trunk. I would like to run another fiber cable to each switch closet for redundancy and increased throughput from each floor. Basically I want gi1/0/49 and gi2/0/49 on the floor switch to be bonded and gi1/0/4 and gi2/0/4 on the core switch to be bonded so if I lose a link, the switches will still operate. I am not sure how to go about setting this up. Can I just configure the new interfaces the same and connect them? or do I need to set up an etherchannel port group? or maybe something else? Thanks,

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Engager

Hi Tom, typically you would

Hi Tom, typically you would create an etherchannel between your access switches and the core/distribution. You can use LACP for the negotiation of this (my preference). If the SVI sits on the access layer, then only a point to point L3 needs to be created between your collapsed core/distrbution and your access switch where traffic can be routed from and to the access switch

Layer 2 Example config below where the SVI sits on the Core/Dist:

interface po1

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface gi1/0/49

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode active

!

interface gi2/0/49

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode active

 

Layer 3 Example config below where the access switch is routing at the core:

interface po1

no switchport

ip address x.x.x.x x.x.x.x

!

interface gi1/0/49

no switchport

no ip address

channel-group 1 mode active

!

interface gi2/0/49

no switchport

no ip address

channel-group 1 mode active

 

Any questions about this, let us know.

 

Bilal

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

View solution in original post

13 REPLIES 13
Highlighted
Hall of Fame Guru

TomBoth switches are L3 What

Tom

Both switches are L3

What do you mean by this ?

Where is the routing between vlans being done ie. on each closet stack or the core.

Is it just one core switch or is a stack ?

Jon

Highlighted
Beginner

Where is the routing between

Where is the routing between vlans being done ie. on each closet stack or the core.

The core switch has the WLAN vlans which are distributed to the floors. Each floor switch has a vlan for data and voice for that floor on it. 

Is it just one core switch or is a stack ?

Core switch is a stack of 2 3750's

Highlighted
Engager

Hi Tom, typically you would

Hi Tom, typically you would create an etherchannel between your access switches and the core/distribution. You can use LACP for the negotiation of this (my preference). If the SVI sits on the access layer, then only a point to point L3 needs to be created between your collapsed core/distrbution and your access switch where traffic can be routed from and to the access switch

Layer 2 Example config below where the SVI sits on the Core/Dist:

interface po1

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface gi1/0/49

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode active

!

interface gi2/0/49

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode active

 

Layer 3 Example config below where the access switch is routing at the core:

interface po1

no switchport

ip address x.x.x.x x.x.x.x

!

interface gi1/0/49

no switchport

no ip address

channel-group 1 mode active

!

interface gi2/0/49

no switchport

no ip address

channel-group 1 mode active

 

Any questions about this, let us know.

 

Bilal

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

View solution in original post

Highlighted
Beginner

Bilal,Thanks! Do I specify

Bilal,

Thanks! Do I specify switchport trunk allowed vlan XX on the port-channel interface, the physical interfaces or both?

Highlighted
Engager

Only on the port-channel -

Only on the port-channel - make sure your physical interfaces are already under the port-channel before you do this :)


 

Please rate useful posts & remember to mark any solved questions as answered. Thank you.
Highlighted
VIP Expert

DisclaimerThe Author of this

Disclaimer

The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.

Liability Disclaimer

In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.

Posting

Just want to add that sometimes you should configure the port-channel and sometimes the bundled ports.  Also, there's some variety between IOS versions in how well port-channel configuration statements are "pushed" to the bundled ports.  (Later IOS versions generally work better.)

PS:

Tips:

  • Etherchannels use stack master's MAC, if you don't configure persistent stack MAC, loss of your stack master will cause your etherchannel to reset.
  • You might want to change the stack's default load balancing algorithm.
Highlighted
Beginner

Bilal,Thanks for your

Bilal,

Thanks for your guidance on this, I was actually able to complete this a little more simply than your instructions. I based mine off http://www.cisco.com/c/en/us/support/docs/switches/catalyst-3750-series-switches/69979-cross-stack-etherchannel.html

FLOOR SWITCH:
int range gi1/0/X , gi1/0/Y
channel-group 1 mode active
description link to core
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan A,B,C,D
exit

CORE:
int range gi1/0/X , gi1/0/Y
channel-group 1 mode active
description link to Floor
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan A,B,C,D
exit

I have tested this and the failover portion seems to work well, however if I do sh in po1 it shows Full-duplex, 1000Mb/s, link type is auto, media type is unknown

I was expecting it to be 2000Mb/s. Am I actually getting 2x1Gbps with LACP if both links are UP?

Highlighted
Engager

Hi Tom, you should see 2gb

Hi Tom, you should see 2gb.

whats the output of 'show etherchannel summary' please?

Please rate useful posts & remember to mark any solved questions as answered. Thank you.
Beginner

ServerRoom_Int#show

ServerRoom_Int#show etherchannel summary

Flags:  D - down        P - bundled in port-channel

        I - stand-alone s - suspended

        H - Hot-standby (LACP only)

        R - Layer3      S - Layer2

        U - in use      f - failed to allocate aggregator

 

        M - not in use, minimum links not met

        u - unsuitable for bundling

        w - waiting to be aggregated

        d - default port

 

 

Number of channel-groups in use: 1

Number of aggregators:           1

 

Group  Port-channel  Protocol    Ports

------+-------------+-----------+-----------------------------------------------

1      Po1(SU)         LACP      Gi1/0/1(P)  Gi1/0/7(P) 

Highlighted
VIP Expert

DisclaimerThe Author of this

Disclaimer

The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.

Liability Disclaimer

In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.

Posting

That Etherchannel summary shows both links bundled and active.  Do the ports both show active traffic?  If so, it might be a cosmetic bug.  Again, some IOSs just don't deal as well with Etherchannel as others, although they all usually function fine.

Highlighted
Engager

Further to Joseph's comments,

Further to Joseph's comments, if you have traffic flowing through - what he describes as "show active traffic", the counters should increase. So you can do "show int gi1/0/1" as well as "show int gi1/0/7" to see the input/output statistics to determine if both are forwarding and receiving.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.
Highlighted
VIP Expert

Exactly.

Exactly.

Highlighted
Beginner

Yes I see traffic on both

Yes I see traffic on both ports, so I guess all is good. Thank you both for your help with this!

CreatePlease to create content
Content for Community-Ad