cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Ask the Expert- SD-WAN

1927
Views
0
Helpful
8
Replies
Beginner

RIP configuration not visible on C6509

HI everyone

i needed to activate RIP 2 on catalist 6509

i'm entering all configuration commands like

conf t

version 2

passive-interface Vlan16

passive-interface GigabitEthernet7/48

....

passive-interface GigabitEthernet8/44

....

.passive-interface GigabitEthernet9/45

passive-interface Loopback0

neighbor X.X.X.X

no auto-summary

network X.X.X.X

redistribute eigrp 20

Switch accepts all commands but when i run

"show run" i don't see  any configured command for RIP

Also when i try to run show ip protocols only EIGRP is visiblde - no RIP at all 

What's wrong ?

Everyone's tags (3)
8 REPLIES 8
Advocate

RIP configuration not visible on C6509

You need the network statement, otherwise how does the device know which interface to use?

BTW a better way of configuring passive-interfaces is:-

passive-interface default

Then you just need to unpassive the interface you want to use - scales better.

HTH>

Beginner

RIP configuration not visible on C6509

I Do have network statement

i entered all networks that i wanted to advertise

network 10.10.11.0

network 192.168.10.0

......

Network 10.10.12.0

etc ..

passive-interface default - yo are right it's easier to use

anyway queston is not answered yet .. why don't i see configuration onthe switch

why RIP protocol is not activated ?  

Advocate

RIP configuration not visible on C6509

The question is very much answered.....What type of protocol is RIP - it is a distance vector, what else do we know? it is

a Classfull protocol.

So what is wrong with your config?

network 10.10.11.0

network 192.168.10.0

network 10.10.12.0

Beginner

RIP configuration not visible on C6509

Hi hari,

Point you have raised is very interesting.

As per orignal post, aklyka is able to observe eigrp details when sh ip protocols is issued but not RIP details.

Is it so that ,if "ip routing" is disabled,still we would see details of "sh ip protocols" command??

Thanks in adv.

Ameya

Highlighted
Cisco Employee

RIP configuration not visible on C6509

Do you have "ip routing" disabled by chance. I too could not see the RIP configs once "ip routing" was disabled on my 6509 box :-

PE1#show running-config | section router rip

router rip

version 2

network 10.0.0.0

network 192.168.0.0

no auto-summary

PE1#configure terminal

PE1(config)#no ip routing

PE1(config)#

PE1(config)#end

PE1#

*Sep 17 18:20:55.131 IST: %SYS-5-CONFIG_I: Configured from console by console

PE1#

PE1#show running-config | section router rip

PE1#

Beginner

Re: RIP configuration not visible on C6509

Hi Aklyka,

First enter below commands:

Commands:

router rip

version 2

network 10.10.11.0

network10.10.12.0

network 192.168.10.0

Now share output of these commands.

1)show history

2)show running-config

3)show run | b r r

4)sh ip protocols

5)debug ip rip

Andrew as per initial query ripv2 is to be implemented which is classless.

Please rate if helpful.

Ameya

Advocate

Re: RIP configuration not visible on C6509

Ameya,

What does the command Version 2 implement? It allows the subnet mask to be sent with the RIP update, which allows classless routing.  HOWEVER the config of the network statements MUST BE CLASSFULL.

So if you configure:-

network 10.10.11.0

network10.10.12.0

network 192.168.10.0

The router will not recognise/accept this as they are NOT classfull config statements, for those networks to be recognised they must be changed to:-

network 10.0.0.0

network 192.168.0.0

Why:-

because 10.10.11.0 = class A = 10/8

because 192.168.10.0 = class B = 192.168/16

Helpfull?

Beginner

RIP configuration not visible on C6509

Hi Andrew,

Well, I am aware of the fact that network statement must be classful.

But my objection was pertaining to below statement.

"

what else do we know? it is

a Classfull protocol.

"

Even though the network statement are classful, we can not declare RIP v2 as Classfull routing Protocol and shoud refer it to be a Classless Routing Protocol.

Regret, for my words were misleading.

Anyways , Every reply is helpful and welcomed.

Thanks and Regards

Ameya

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards