cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco announces new innovations in SD-WAN, ISRs, SD-WAN Services, and Catalyst 9000 Series switches


227
Views
15
Helpful
24
Replies
Beginner

RipV2 cant ping another pc a different network

Hello, I am stuck and don't know how to solve this issue when I try to ping my other PC on the other network I get the following message Destination host unreachable.

 

 Router 1

interface GigabitEthernet0/0

ip address 192.168.72.49 255.255.255.248

duplex auto

speed auto

ipv6 address 2001:DB8:ACAD:1::1/64

!

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Serial0/0/0

ip address 192.168.72.66 255.255.255.252

!

interface Serial0/0/1

ip address 192.168.72.62 255.255.255.252

!

interface Vlan1

no ip address

shutdown

!

router rip

version 2

network 192.168.72.0

 

Router 2 

 

interface GigabitEthernet0/0

ip address 192.168.72.33 255.255.255.240

duplex auto

speed auto

ipv6 address 2001:DB8:ACAD:2::1/64

!

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Serial0/0/0

ip address 192.168.72.65 255.255.255.252

ipv6 address 2001:DB8:ACAD:CE::2/64

clock rate 2000000

!

interface Serial0/0/1

ip address 192.168.72.58 255.255.255.252

ipv6 address 2001:DB8:ACAD:CF::2/64

!

interface Vlan1

no ip address

shutdown

!

router rip

version 2

network 192.168.72.0

 

 

 

 

 

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Collaborator

Re: RipV2 cant ping another pc a different network

I agreed with Richard, you need to understand what you doing, and provide more information
so we understand your goal and assignment for the labs


Summerise as per your setup
============================

R1 Serial 0/0/0 connected to R3 Serial 0/0/1
R1 Serial 0/0/1 connected to R2 Serial 0/0/0
R2 Serial 0/0/1 connected to R3 Serial 0/0/0

you point to point configuration should be as below :


R1

interface serial 0/0/0
ip address 192.168.72.62 255.255.255.252
!
interface serial 0/0/1
ip address 192.168.72.66 255.255.255.252

 

R2

Serial configuration

interface serial 0/0/0
ip address 192.168.72.65 255.255.255.252
!
interface serial 0/0/1
ip address 192.168.72.58 255.255.255.252

 


R3

Serial configuration

interface serial 0/0/0
ip address 192.168.72.57 255.255.255.252
!
interface serial 0/0/1
ip address 192.168.72.61 255.255.255.252

 

ping from R1 192.168.72.65 and 192.168.72.61
ping from R2 192.168.72.57 and 192.168.72.66
ping from R3 192.168.72.58 and 192.168.72.52

If all pinging then your point to point links are working, then check the RIP configuration and check the routing table you able get routes

BB
*** Rate All Helpful Responses ***
24 REPLIES
Collaborator

Re: RipV2 cant ping another pc a different network

If i understand correctly you have connected these devices using Serial connection ?

 

or Do you have topology ? what is the other device you trying to ping, what is the IP and where it is connected.

From where to where you pinging, provide source and destination.

 

can you post both the side show ip route 

BB
*** Rate All Helpful Responses ***
Beginner

Re: RipV2 cant ping another pc a different network

192.168.72.0/24 is variably subnetted, 6 subnets, 3 masks

C 192.168.72.48/29 is directly connected, GigabitEthernet0/0

L 192.168.72.49/32 is directly connected, GigabitEthernet0/0

C 192.168.72.60/30 is directly connected, Serial0/0/1

L 192.168.72.62/32 is directly connected, Serial0/0/1

C 192.168.72.64/30 is directly connected, Serial0/0/0

L 192.168.72.66/32 is directly connected, Serial0/0/0

 

i am trying to ping from (PC1)192.168.72.50 to (PC2)192.168.72.34 on another network i just cant get rip to work

 

Collaborator

Re: RipV2 cant ping another pc a different network

Looking in to your Ruoting output, it do not have routes from IGP RIP.

 

Basic diagnosis before we get on to IGP RIP testing.

 

Do you have basic connectivity between these interface and you can source interface and ping other side ?

 

good if you can make some network topo to understand what interface connected to what devices where your PING fails have idea.

 

ping from (PC1)192.168.72.50 to (PC2)192.168.72.34 on another network i just cant get rip to work

 

 

BB
*** Rate All Helpful Responses ***
Highlighted
VIP Advisor

Re: RipV2 cant ping another pc a different network

Hello

Not really able to check your config but for starters can you try disabling auto-summerisation 

 

router rip

no auto-summary

exit

 



kind regards
Paul

Please don't forget to rate any posts that have been helpful.
Beginner

Re: RipV2 cant ping another pc a different network

i dont have auto-summary on i tried to do rip 192.168.72.0 since both networks use 192.168.72.0 but nothing happens

Hall of Fame Master

Re: RipV2 cant ping another pc a different network

Yes auto summarization would come into play if there were different major networks involved. But since all subnets are in the same class C 192.168.72 then summarization does not come into play.

 

One thing that I notice is that the subnet of the serial interface on the first router does not match up with either of the subnets on serial interfaces on the second router. It is not clear what connects to what. But you need to have both ends of that connection in the same subnet.

 

HTH

 

Rick

Hall of Fame Master

Re: RipV2 cant ping another pc a different network

I have read through the thread again and realize that I was sort of incorrect in my statement about subnets on connected interfaces. But my fundamental point is still correct.  The diagram does make clear that the routers are connected on their serial 0/0/1 interfaces. Here is the config from R1

interface Serial0/0/1

ip address 192.168.72.62 255.255.255.252

and it is clearly in subnet 192.168.72.60

And here is the config from R2

interface Serial0/0/1

ip address 192.168.72.58 255.255.255.252

and it is clearly in subnet 192.168.72.56

 

I believe that there is additional insight into the problem if we look at the post that has the output of show ip route. It is clearly from R1. As we look at that output we would notice that it has only local and connected entries. It is not receiving any routing updates from its neighbor. Clearly the reason that ping fails is that there is no route to the destination subnet in the routing table. I suspect that this is due to the mismatch of addressing on the serial interfaces used for this connection.

 

HTH

 

Rick

 

Beginner

Re: RipV2 cant ping another pc a different network

so what do you suggest we do to fix this problem because i cant seem to find the issue myself.

Hall of Fame Master

Re: RipV2 cant ping another pc a different network

I suggest the first thing you should do is to fix the mismatch in subnets between your serial interfaces. The second thing I would suggest is to test on each of your 3 routers whether it is able to ping the IP address of its neighbor on the serial interfaces. If you fix the problem with addressing and if each router is able to ping each of its neighbor serial interface addresses then we will see where we are with routing. But those two things need to be done first.

 

HTH

 

Rick

Beginner

Re: RipV2 cant ping another pc a different network

Router 2 cannot ping Router 1 S0/0/1 192.168.72.62

 

Router 3 cannot ping S0/0/0 192.168.72.66

 

Router 1 cannot ping S0/0/0 192.168.72.57

 

Router 1 cannot ping 0/0/1 192.168.72.58

 

everything else seems to work but those things doesnt seem to work.

Collaborator

Re: RipV2 cant ping another pc a different network

post the full configuration and show how physically connected. personally still try to understand how these connected.

underlay reachable before overlay RIP can advertise the routes.

 

BB
*** Rate All Helpful Responses ***
Beginner

Re: RipV2 cant ping another pc a different network

alright i hope this helps.

Hall of Fame Master

Re: RipV2 cant ping another pc a different network

Thank you for posting more information with configs and with a diagram. It confirms what I have been saying about the problem.

 

Do you understand what I have been saying about mismatched subnets on the serial interfaces? Do you need help in figuring out how to fix it?

 

As an example of the issue R1 connects to R2 using Serial0/0/1 on both routers. R1 has configured its subnet to be 192.168.72.60. But R2 has configured its subnet to be 192.168.72.56. R1 has no idea of where 192.168.72.58 (the IP of R2) is or how to get there. And similar issue on R2 which has no idea where 192.168.72.62 is or how to get there. That is why ping does not work and probably why RIP does not work.

 

HTH

 

Rick

Beginner

Re: RipV2 cant ping another pc a different network

yes please i need help to solve this problem i understand what you mean but i dont know in what way i can solve it.

CreatePlease to create content
Content for Community-Ad
Ask the Expert- Introduction to Network Design