cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

246
Views
0
Helpful
9
Replies
Beginner

Router on stick

I was trying to configure routeron stick.

1) I configured sub interfaces on Router and assign  IP address

1) I configured switch 1 as VTP server and made 3 uplink ports as Trunk , also created 4 Vlans

 

Problem : Vlans are showing on Switch 1 only not on Switch 2,3 and 4

while those are configured as Clients.

 

So, please help me where I am missing

 

123.JPG

 

 

 

Configuration are as below

---------------------

Router

 

Router#   sh ip int brief

Interface              IP-Address      OK? Method Status                Protocol

FastEthernet0/0        unassigned      YES unset  up                    up

FastEthernet0/0.1      192.168.1.1     YES manual up                    up

FastEthernet0/0.2      192.168.2.1     YES manual up                    up

FastEthernet0/0.3      192.168.3.1     YES manual up                    up

FastEthernet0/0.4      192.168.4.1     YES manual up                    up

 

 

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

description DATA

encapsulation dot1Q 100

ip address 192.168.1.1 255.255.255.0

!

interface FastEthernet0/0.2

description WIRELESS

encapsulation dot1Q 200

ip address 192.168.2.1 255.255.255.0

!

interface FastEthernet0/0.3

description VOICE

encapsulation dot1Q 300

ip address 192.168.3.1 255.255.255.0

!

interface FastEthernet0/0.4

description CLIENTS

encapsulation dot1Q 400

ip address 192.168.4.1 255.255.255.0

===========================================================

Switch#1

 

Vlan1                  10.10.20.1      YES manual up                    up

Vlan100                192.168.1.2     YES manual up                    up

Vlan200                192.168.2.2     YES manual up                    up

Vlan300                192.168.3.2     YES manual up                    up

Vlan400                192.168.4.2     YES manual up                    up

Switch_1:core#sh int trunk

Port        Mode         Encapsulation  Status        Native vlan

Fa0/2       on           802.1q         trunking      1

Fa0/3       on           802.1q         trunking      1

Fa0/4       on           802.1q         trunking      1

 

Port        Vlans allowed on trunk

Fa0/2       1-1005

Fa0/3       1-1005

Fa0/4       1-1005

 

Port        Vlans allowed and active in management domain

Fa0/2       1,100,200,300,400

Fa0/3       1,100,200,300,400

Fa0/4       1,100,200,300,400

 

Port        Vlans in spanning tree forwarding state and not pruned

Fa0/2       1,100,200,300,400

Fa0/3       1,100,200,300,400

Fa0/4       1,100,200,300,400

 

Switch_1:core#

Switch_1:core#sh vlan

 

VLAN Name                             Status    Ports

---- -------------------------------- --------- -------------------------------

1    default                          active    Fa0/1, Fa0/5, Fa0/6, Fa0/7

                                                Fa0/8, Fa0/9, Fa0/10, Fa0/11

                                                Fa0/12, Fa0/13, Fa0/14, Fa0/15

                                                Fa0/16, Fa0/17, Fa0/18, Fa0/19

                                                Fa0/20, Fa0/21, Fa0/22, Fa0/23

                                                Fa0/24, Gig0/1, Gig0/2

100  Data                             active   

200  Wireless                         active   

300  Voice                            active   

400  Clients                          active 

 

 

Switch_1:core# sh vtp status

VTP Version                     : 2

Configuration Revision          : 0

Maximum VLANs supported locally : 255

Number of existing VLANs        : 9

VTP Operating Mode              : Server

VTP Domain Name                 : Cisco

=========================================================

 

Switch:2#sh vlan

 

VLAN Name                             Status    Ports

---- -------------------------------- --------- -------------------------------

1    default                          active    Fa0/11, Fa0/16, Fa0/17, Fa0/23

                                                Fa0/24, Gig0/1, Gig0/2

1002 fddi-default                     active   

1003 token-ring-default               active   

1004 fddinet-default                  active   

1005 trnet-default                    active   

 

 

Switch:2#  sh int trunk

Port        Mode         Encapsulation  Status        Native vlan

Fa0/1       on           802.1q         trunking      1

 

Switch:2#sh vtp status

VTP Version                     : 2

Configuration Revision          : 0

Maximum VLANs supported locally : 255

Number of existing VLANs        : 5

VTP Operating Mode              : Client

VTP Domain Name                 : Cisco

VTP Pruning Mode                : Disabled

VTP V2 Mode                     : Disabled

VTP Traps Generation            : Disabled

2 ACCEPTED SOLUTIONS

Accepted Solutions
VIP Collaborator

Re: Router on stick

Hello,

 

Do all the switches have the same VTP domain, password and version? the others switches are in Client mode? the best practices are putting all switches in "transparent mode" for security reasons, but you can propagate the vlans first and after disable VTP and begin to configure the vlans device by device, or you can leave this enabled to do the vlans configurations in a easy way, is your desicion.
Please do not forget to rate useful post.

 

Best Regards,

VIP Mentor

Re: Router on stick

Hello,

 

your Switch 2 is in VTP transparent mode, it needs to be in client mode:

 

vtp mode client

9 REPLIES 9
VIP Mentor

Re: Router on stick

Hello,

 

first of all, you don't need IP addresses for the VLANs on switch 1.

Post the full configurations of both Switch 1 and Switch 2...

Beginner

Re: Router on stick

Hello Georg,

 

This the configuration

current configuration : 1510 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch_1:core
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
 switchport mode trunk
!
interface FastEthernet0/3
 switchport mode trunk
!
interface FastEthernet0/4
 switchport mode trunk
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!

Switch_1:core#
Switch_1:core#
-----------------------------------
Switch 2

Current configuration : 2018 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch:2
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport mode trunk
!
interface FastEthernet0/2
 switchport access vlan 100
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 100
 switchport mode access
!
interface FastEthernet0/4
 switchport access vlan 100
 switchport mode access
!
interface FastEthernet0/5
 switchport access vlan 100
 switchport mode access
!
interface FastEthernet0/6
 switchport access vlan 200
 switchport mode access
!
interface FastEthernet0/7
 switchport access vlan 200
 switchport mode access
!
interface FastEthernet0/8
 switchport access vlan 200
 switchport mode access
!
interface FastEthernet0/9
 switchport access vlan 200
 switchport mode access

Switch:2#

Highlighted
Beginner

Re: Router on stick

Switch 1's revision number is 0, which is not greater than the other switches. Try to add a vlan on switch 1 and then remove it. This should increase the revision number and force the vlan database to be shared out.

 

VIP Collaborator

Re: Router on stick

Hello,

 

Do all the switches have the same VTP domain, password and version? the others switches are in Client mode? the best practices are putting all switches in "transparent mode" for security reasons, but you can propagate the vlans first and after disable VTP and begin to configure the vlans device by device, or you can leave this enabled to do the vlans configurations in a easy way, is your desicion.
Please do not forget to rate useful post.

 

Best Regards,

Beginner

Re: Router on stick

Hello Diana Rojas and dbeattie

 

First of all Thanks for giving our time and helping me.

 

I made some changes like add vlan and delete , increase revision number . change VTP to transparent but still Vlans are not populating on downlink switches.

Here again i am posting outputs . Please have a look and help me

 

 


ROUTER

interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 description DATA
 encapsulation dot1Q 100
 ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0.2
 description WIRELESS
 encapsulation dot1Q 200
 ip address 192.168.2.1 255.255.255.128
!
interface FastEthernet0/0.3
 description VOICE
 encapsulation dot1Q 300
 ip address 192.168.3.1 255.255.255.192
!
interface FastEthernet0/0.4
 description CLIENTS
 encapsulation dot1Q 400
 ip address 192.168.4.1 255.255.255.224
!

FastEthernet0/0        unassigned      YES unset  up                    up
FastEthernet0/0.1      192.168.1.1     YES manual up                    up
FastEthernet0/0.2      192.168.2.1     YES manual up                    up
FastEthernet0/0.3      192.168.3.1     YES manual up                    up
FastEthernet0/0.4      192.168.4.1     YES manual up                    up
FastEthernet1/0        unassigned      YES unset  administratively down down
Serial2/0   
-------------------------

Switch 1 = core switch

Vlan1                  10.10.20.1      YES manual up                    up
Vlan100                192.168.1.2     YES manual up                    up
Vlan200                192.168.2.2     YES manual up                    up
Vlan300                192.168.3.2     YES manual up                    up
Vlan400                192.168.4.2     YES manual up                    up
Switch_1:core#

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/5, Fa0/6, Fa0/7
                                                Fa0/8, Fa0/9, Fa0/10, Fa0/11
                                                Fa0/12, Fa0/13, Fa0/14, Fa0/15
                                                Fa0/16, Fa0/17, Fa0/18, Fa0/19
                                                Fa0/20, Fa0/21, Fa0/22, Fa0/23
                                                Fa0/24, Gig0/1, Gig0/2
100  Data                             active    
200  Wireless                         active    
300  Voice                            active    
400  Clients                          active    
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active    

--------------
Switch_1:core#sh vtp status
VTP Version                     : 2
Configuration Revision          : 5
Maximum VLANs supported locally : 255
Number of existing VLANs        : 9
VTP Operating Mode              : Server
VTP Domain Name                 : XYZ
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0xE0 0x55 0x7D 0xD2 0xA1 0x9D 0x5A 0x67
Configuration last modified by 10.10.20.1 at 3-1-93 00:34:55
Local updater ID is 10.10.20.1 on interface Vl1 (lowest numbered VLAN interface found)
Switch_1:core#
Switch_1:core#
-------------------------------

Switch2 = Host name Switch 2

Vlan1                  10.10.30.1      YES manual up                    up
Switch:2#

Switch:2#sh vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/11, Fa0/16, Fa0/17, Fa0/23
                                                Fa0/24, Gig0/1, Gig0/2
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active    

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0   
1003 tr    101003     1500  -      -      -        -    -        0      0   
1004 fdnet 101004     1500  -      -      -        ieee -        0      0   
1005 trnet 101005     1500  -      -      -        ibm  -        0      0   

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

Remote SPAN VLANs

Switch:2#  sh vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 255
Number of existing VLANs        : 5
VTP Operating Mode              : Transparent
VTP Domain Name                 : XYZ
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x2D 0x26 0x20 0xAA 0x25 0xA0 0x80 0x2B
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
Switch:2#

 

VIP Mentor

Re: Router on stick

Hello,

 

your Switch 2 is in VTP transparent mode, it needs to be in client mode:

 

vtp mode client

Beginner

Re: Router on stick

.

Beginner

Re: Router on stick

Hello Georg

I make the change but still not working

Switch:2#sh vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 255
Number of existing VLANs        : 5
VTP Operating Mode              : Client
VTP Domain Name                 : XYZ
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x2D 0x26 0x20 0xAA 0x25 0xA0 0x80 0x2B
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
Switch:2#
Switch:2#sh vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/11, Fa0/16, Fa0/17, Fa0/23
                                                Fa0/24, Gig0/1, Gig0/2
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active    

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0   
1003 tr    101003     1500  -      -      -        -    -        0      0   
1004 fdnet 101004     1500  -      -      -        ieee -        0      0   
1005 trnet 101005     1500  -      -      -        ibm  -        0      0   

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

Beginner

Re: Router on stick

Hello Everone,
Got the solution, password was not set on switch2.

Thanks Diana

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards