Routing problem..
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
02-07-2005 11:19 AM - edited 03-05-2019 11:25 AM
Hi,
I have a 192.168.0.0/24 network and a 192.168.1.0/24 network connected by a Cisco 1711.
Even though the two networks are directly connected to each other, there is no routing done.
From a host in 192.168.0.0/24, I can't ping any hosts in the 192.168.1.0/24 network, except the routers ip. The only way I "resolved" this is by doing NAT.
Please help ;)
Configuration:
interface FastEthernet0
ip address 192.168.1.254 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
shutdown
!
interface FastEthernet3
no ip address
shutdown
!
interface FastEthernet4
no ip address
shutdown
!
interface Vlan1
ip address 192.168.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Async1
no ip address
!
router rip
network 192.168.0.0
network 192.168.1.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0
no ip http server
no ip http secure-server
ip nat inside source list 1 interface FastEthernet0 overload
!
!
!
access-list 1 permit 192.168.0.0 0.0.0.255
!
!
control-plane
!
!
line con 0
line 1
line aux 0
line vty 0 4
!
end
- Labels:
-
LAN Switching

- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
02-07-2005 12:11 PM
Hello,
try the global command ´ip subnet-zero´, this will enable the use of subnet 0 for interface addresses and routing updates. 192.168.0 0/24 is the so-called subnet-zero, which will not be routed without that command.
HTH,
GP
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
02-07-2005 01:25 PM
Hi,
I tried it and it still doesn't work.
Any other ideas?
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
02-07-2005 01:45 PM
It looks like you have two subnets on the inside of fe0, and they won't communicate, right?
If so, NAT is an ugly solution. What you need to do is setup both VLANs, an IP from each, and trunking between the 1711 and the switch your are running the VLANs on.
Unless I'm missing something about your setup. Can you give a quick diagram?
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
02-07-2005 01:58 PM
The two subnets are on different interfaces:
192.168.1.0/24 ------ 192.168.1.254[router]192.168.0.1 ----- 192.168.0.0/24
So without NAT, a host say 192.168.0.2 can ping both 192.168.0.1 and 192.168.1.254, but nothing beyond that interface.
This is really bugging me, there shouldn't be any problems with routing 2 directly connected subnets =/
Thanks for your help
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
02-07-2005 02:51 PM
Sorry...I had a reply typed out and lost it. Hope this doesn't double post.
Anyway.
First off, you aren't defining the VLAN to exist on any particular physical interface. So, while the VLAN will respond to pings, the router has no idea where to forward the packets.
Second, you might try enabling IP routing manually, but entering 'ip routing' at a config prompt. RIP serves no purpose in your environment.
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
02-07-2005 06:55 PM
Well since VLAN1 is the default vlan, it should include all of the ports by default, but i'll try associating it manually.
As for the "ip routing" command, already tried that :P
Thanks for your help.
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
02-08-2005 12:19 AM
Georg,
I don't think ip subnet-zero will help here. 192.168.0.0/24 is not a subnet-zero - it is a full Class-C network, and so is unaffected by the subnet-zero command.
Kevin Dorrell
Luxembourg
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
02-08-2005 12:32 AM
Is this a WIC-4ESW? I presume 192.168.0.0/24 is supposed to be on F1. Is F1 actually protocol up? Is there anything connected on F1? If I remember right, if all the switchports are down, the VLAN interface will also be down.
Kevin Dorrell
Luxembourg
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
02-08-2005 05:41 AM
Yes, it is a WIC-4ESW.
F1 is up and VLAN1 is up also. I can both of the inside interface (VLAN1) and the outside interface (F0) from the inside network (192.168.0.0/24).
What doesn't work is accessing anything beyond the outside interface. It just stops there, unless I do NAT.
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
02-08-2005 06:56 AM
It sounds like the problem may be that there is not anything beyond the outside interface with a route back to the inside subnet.
One way to test this would be to use extended ping on the router. Ping to some outside address and in extended ping specify that the source address is the inside Ethernet interface of the router.
When you NAT it looks like you are making the inside devices appear to be members of the outside subnet, which is routable. If you provide routes outside to the inside network then you should not need NAT.
HTH
Rick
Rick
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
02-08-2005 08:06 AM
You are absolutely right.
I added a route back to my router and everything works perfect.
Thanks!
