cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
505
Views
0
Helpful
3
Replies
network_user
Beginner

RSPAN not capturing required data

                   Hello,

I have a RSPAN session configured between a Cisco 3750 and Cisco 2950 switches and I dont see the traffic I am expecting to see on the destination port. I only see broadcast traffic .. HRSP hellos etc. Below is what I have configured on both switches. What is not correct here?

3750 (gi1/0/33)----TRUNK------(fa0/47)2950(fa0/4)-----windows server

3750

---------

monitor session 1 source interface gi1/0/18

monitor session 1 destination remote vlan 901

3750#sh vlan id 901

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
901  RSPAN                            active    Gi1/0/33, Gi2/0/34

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
901  enet  100901     1500  -      -      -        -    -        0      0

Remote SPAN VLAN
----------------
Enabled

Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------

interface GigabitEthernet1/0/33

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 11,20,50,80,102,104-106,108,109,901

switchport mode trunk

speed 100

duplex full

end

2950

-------

monitor session 1 destination interface Fa0/4

monitor session 1 source remote vlan 901

2950#sh vlan id 901

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
901  RSPAN                            active    Fa0/4, Fa0/47, Fa0/48

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
901  enet  100901     1500  -      -      -        -    -        0      0

Remote SPAN VLAN
----------------
Enabled

Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------

interface FastEthernet0/47

  switchport trunk allowed vlan 11,20,50,80,102,104-106,108,109,901

switchport mode trunk

no ip address

duplex full

speed 100

end

interface FastEthernet0/4

switchport access vlan 901

switchport mode access

no ip address

duplex full

speed 100

end

Thank you.

3 REPLIES 3
Giuseppe Larosa
Hall of Fame Master

Hello,

on C2950 that is an older platform you need to configure a reflector port (first generation of remote span)

see

http://www.cisco.com/en/US/docs/switches/lan/catalyst2950/software/release/12.1_22_ea11x/configuration/guide/swspan.html#wp1415189

the refllector port cannot be used for other purposes

Hope to help

Giuseppe

Hello Giuseppe,

My RSPAN VLAN 901 is the RSPAN source on Cisco 2950. And I think I am not supposed to or cannot configure "reflector port" when RSPAN is source. My RSPAN VLAN is destination on Cisco 3750 which does not require a reflector port. So I dont have a way to configure reflector port in my case. Does this make any sense ?

Thank you.

Hello Network user,

you are right the reflector port is not needed in all cases as it is explained in the configuration chapter guide I have linked to my previous post.

I apologize for the misleading information.

The real problem with your configuration is that you have put the destination port in Vlan 901 !!!!

interface FastEthernet0/4

>>>>>switchport access vlan 901

switchport mode access

no ip address

duplex full

speed 100

end

This is wrong, the destination port doesn't need to be a member of RSPAN vlan

Hope to help

Giuseppe