cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Serial line will not stay up

jake052399
Beginner
Beginner

I am unable to get my back to back serial line to stay up. I configure 2 2501 routers as such:

Router1

e0 - 10.0.1.254 /24

s0 - 10.0.2.254 /24

s1 - 10.0.3.254 /24

Router2

e0 - 10.0.4.254 /24

s0 - 10.0.5.254 /24

s1 - 10.0.6.254 /24

Router 1 has the DCE end of the cable and I ran the command of clockrate 64000. This seemed to bring up the line. Then the line starts to loop where the line protocol comes up for 30seconds, then down for 30 seconds.

Any help you can provide is appreciated.

13 REPLIES 13

c.chaffee
Beginner
Beginner

I believe you can fix the problem by setting one 2501's timing to internal, and the other one defaults to network. This provides one source of timing, and I think that is what you are experiencing.

Hope I am right, and I hope this helps.

Hi C.Chaffee,

Could you please let us know the command that needs to be stuck to enable the timing to internal and also the cmd to set it to the network ?

Hi Kevin

I feel the keepalive for HDLC is 10 sec by default.

What is the 30 sec keepalive that you are suggesting here ?

On the HDLC interfaces, I see :

Keepalive set (10 sec)

Thanks in advance !

Arav

Sorry, I was on vacation until about 25 mins ago.

clock source internal

clock source network / clock source line

The second one depends on what version of IOS you are running. If this doesn't work, could you post your configuration for the two interfaces?

Kevin Dorrell
Advocate
Advocate

If you are running HDLC encapsulation (the default), this means the line is not coming up at all. HDLC has no connection protocol, so it relies on keepalives to signal that the line is up. When you connect the line, it flags it as "up" immediately, and if it does not receive a keepalive within 30 seconds only then does it flag it as "down". Make sure that it really is the DCE end that has the clockrate (use show controllers S0 to do this), and make sure that keepalives are enabled on both ends.

The other comment I would make is that both ends of each link need to be in the same subnet. For example, if S0 is connected to S0, and one end is 10.2.254/24, then the other S0 needs to be something like 10.0.2.253/24.

Does this help?

Kevin Dorrell

Luxembourg

hello,

By default serial interface is DTE. IP address/ Encapsualtion is your choice. If you choose not to configure the encapsulation by default HDLC will be configured.

You have to configure the follwing commands on your DCE side interface

ip address 192.168.4.1 255.255.255.252

encapsulation ppp

dce-terminal-timing-enable

clock rate 64000

no shutdown

on DTE side

ip address 192.168.4.2 255.255.255.252

encapsulation ppp

no shutdown

Regards

suresh.krishnamurthy

I have tried the suggestions. It stills seems to loop. I set encapsulation back to HDLC as PPP didn't even want to come up for 30 seconds. Here is the output of my config. As you can notice itis hard to fit in commands as you keep getting messages that the line protocol is down/up. Any help is appreciated.

That confirms what I thought: neither PPP nor HDLC is coming up at all. The two encapsulations behave differently during startup. With PPP, it marks the connection is down, and does not mark it up until it has successfully established a connection. With HDLC, it marks it as up immediately regardless of the state of the protocol, and then looks for keepalives; if it does not see a keepalive within 30 seconds, only then does it mark it as down.

I would stick to HDLC for the moment because it is a lot simpler, and does not depend on any connection protocol. But that does not tell you yet why it is not coming up.

I do notice that Test1 is receiving and transmitting frames OK. Test2 is transmitting frames, but has never received anything. So I would suspect that the cable is broken - in particular the data pin transmitted from Test1 and received by Test2. If not, possible the receiver in Test2 is defective.

Kevin Dorrell

Luxembourg

Thanks. I ordered a new cable and will give that a try. I'll post the results.

Thanks

Here is the Cisco link for configuring back-to-back serial connections. I have several of these in use at home using 2500's without any issues. I haven't had to config any keep-alive settings.

http://www.cisco.com/en/US/customer/tech/tk713/tk317/technologies_configuration_example09186a00800944ff.shtml

I'd have to agree with Kevin on a possible bad cable. Let us know how you make out once you replace the cable.

Sean

Sean,

Just to add to your point about keepalives: with HDLC, the default is one keepalive every 10 seconds, and a dead-time of 30 seconds. If you configure no keepalive, then the interface will always appear "line protocol up", even if it is not working at all, provided the "modem" signals are valid.

Kevin Dorrell

Luxembourg

Hi,

I believe all you need to do is just make sure the end with the DCE has a clock rate set. This end will provide clocking for the line. You only need the clock source line commands if you have internal CSU's on your routers.

I also think your IP info doesn't matter. Of course if you want IP comminucation to function, the interfaces will need to be in the same subnet, but for the purposes of bringing up the line, it's irrelevant. That's a layer three issue and all we're trying to accomplish is getting the line up.

Hope this helps.

Danny

katoleecn
Beginner
Beginner

I think you must be make some mistake in your network. The IP address you gived us are not in the same subnet, so it cannot run well. You can do like this.

Router1

e0 - 10.0.1.254 /24

s0 - 10.0.2.254 /24

s1 - 10.0.3.254 /24

Router2

e0 - 10.0.4.254 /24

s0 - 10.0.2.253 /24

s1 - 10.0.6.254 /24

and configure interface s0 of route1 and route2 like this:

route1:

config t

int s0

ip address 10.0.2.254 255.255.255.0

clock rate 64000

no shut

route2:

config t

int s0

ip address 10.0.2.253 255.255.255.0

no shut

Thanks. I made those changes after noticing the IP address error and the line would still fluctuate. I received a new cable this morning and as soon as I put it on the line came up and stayed up.

Thanks for all the help provided!

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: