cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
676
Views
0
Helpful
15
Replies
Highlighted

SFP not communicating

Hi all,

Greetings!!

Am working in a firm that have more than 10 Cisco switches connected to one core master switch via SFP . But one of the Switch not communicate after few hours of working, when i check that SFP Connector in that switch it not blinking. when i power off the switch and turn it On again, it works after few hours it went out and the problem continues.

Please Help me to solve this issue since am not IT guy please explain in detail and attach Commands if any. 

 

Thanks & Regards,

Abdul Rawoof

15 REPLIES 15
Highlighted
VIP Mentor

Hello,

 

I guess if it works for a few hours and then stops working, you have three options:

 

1. Try the same SFP in a different port

2. Try another SFP in the same port

3. Exchange the (fiber) cable

 

Basically, you want to find which component is malfunctioning. If the same SFP works in a different port, there is a problem with the port. If the same SFP does NOT work in a different port, there is a problem with either the SFP or the cable.

 

That said, the problem could also be on the other side of the link, at the core switch. Check the logs of both devices (show log) for any relevant messages...

Highlighted

Hi ,
I have tried your options but SFP is good but it doesn't go well. same problem exists. Is any configuration required for SFP ? if so pls reply with complete commands to configure.

Thanks,
Rawoof
Highlighted
Hall of Fame Community Legend

Post the complete output to the following commands:
1. sh version; and
2. sh interface <PORT>
Highlighted

fyi

My Switch version and interface status

Highlighted
Hall of Fame Community Legend

Layer 1 issue.
Are you sure the fibre link is active?
Get a visible light and see if light appears at the far end.
Highlighted

Hi All,

Greetings !!

I am working in a firm that has 10 Cisco catalyst 2960 switch connected with Core Switch WS-C6509 via optic fibre. when i joined, it was working good but now 3 of them not communicating with core switch after getting power cut. No Link Light up in SFP on Catalyst C 2960 . when i check that interface status , It shows " TenGigabitEthernet1/0/2 is down, line protocol is down (notconnect) ". i also tried shut no shut command but no use . Please assist me to solve this. here with i attached full commands i tried.

Note: Previously working good ,no any changes done but only power off .

Highlighted
Hall of Fame Community Legend

Read my last response.
Highlighted

my cisco switch model is " Cisco catalyst 2960-x-series 24P and my core switch is WS-C6509-E-48P

Highlighted

Have you tried to move the SPFs to another working port and vice versa, there looks like an error in the attached commands which indicates a failure with the SFP.
You can try and use show interface transciever details to see what the power levels look like.
Highlighted

Hi shaps,

i have already tried by switching to next port , firstly it shows errdisable state once i clear that it went into same like prior port ( not connected).i check with inventory but i shows my sfp.

Highlighted

Hi,
this can be a bug. check below link to check is that your OS affected with this.

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCuy89858/?rfs=iqvred
Highlighted

Was going to ask, what code? Also, is there a stack module installed? I have seen issues with a certain manufacturing run of stack modules and 2960x. Causes the SFP port uplinks to stop working. Generally a code change will fix it, with the exception of one specific small run of modules that just weren't compatible with our 2960x chassis that Cisco had to replace directly. 

Highlighted
Hall of Fame Community Legend

What is the exact model of the switch?
Highlighted

Cisco Catalyst 3850 24 POE+

Content for Community-Ad