cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

961
Views
0
Helpful
4
Replies
Highlighted
Beginner

Sharing a 10 mbps connection

I have a Router 877 and a switch 3750 also a 10 mbps internet connection and I want to share the internet connection to 5 different vlans with a maximum of 2mbps each one or 2 mbps guaranteed. The switch and the router are connected for a trunk port and the vlans are defined in both devices. I have tried many configurations of this with no succes.

Can you tell me if this is possible? which could be the best guidelines to configure.

Thanks (Sorry for my english)

Everyone's tags (3)
4 REPLIES 4
Hall of Fame Community Legend

Sharing a 10 mbps connection

5 different vlans

What IOS is your router running?

Beginner

Sharing a 10 mbps connection

Cisco IOS Software, C870 Software (C870-ADVIPSERVICESK9-M), Version 12.4(15)T12, RELEASE SOFTWARE (fc3)

Hall of Fame Community Legend

Sharing a 10 mbps connection

12.4(15)T12

This is going to be an issue.  870 will only support up to 3 VLANs (VLAN 1 included) if you are running IOS version 12.4.  If you want to run up to 10 VLANs (VLAN 1 included) then you need to downgrade the IOS to version 12.3.

Beginner

Sharing a 10 mbps connection

For the record...

I try the next example and it works...

*****

ip access-list extended VLAN1
permit ip 192.168.1.0 0.0.0.255 any
ip access-list extended VLAN2
permit ip 192.168.1.0 0.0.0.255 any
ip access-list extended VLAN3
permit ip 192.168.1.0 0.0.0.255 any
ip access-list extended VLAN4
permit ip 192.168.1.0 0.0.0.255 any
ip access-list extended VLAN5
permit ip 192.168.1.0 0.0.0.255 any
!
class-map match-any VLAN1
match access-group name VLAN1
class-map match-any VLAN2
match access-group name VLAN2
class-map match-any VLAN3
match access-group name VLAN3
class-map match-any VLAN4
match access-group name VLAN4
class-map match-any VLAN5
match access-group name VLAN5
!
policy-map CBWFQ
class VLAN1
  bandwidth 2000
class VLAN2
  bandwidth 2000
class VLAN3
  bandwidth 2000
class VLAN4
  bandwidth 2000
class VLAN5
  bandwidth 2000
!
policy-map SHAPING
class class-default
  shaping average 10000000
  service-policy CBWFQ
!
interface FastEthernet0/0

description TO INTERNET
service-policy output SHAPING

*****

At the end it wasn't necesary to put 5 VLANS only two.

Thanks anyway

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards