cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1545
Views
0
Helpful
4
Replies
davidhuynh5
Beginner

Show Log - Administratively Down

When I manually shutdown an interface, the syslog message "administratively down" does not appear in the log. How can I correct this?

Thanks in advance.

ms-3722d-man-r1(config)#inter s6/1/0
ms-3722d-man-r1(config-if)#shut
ms-3722d-man-r1(config-if)#do sh log
Syslog logging: enabled (0 messages dropped, 11 messages rate-limited, 0 flushes, 0 overruns, xml disabled, filtering disabled)

No Active Message Discriminator.

Log Buffer (8192 bytes):

May 23 20:27:03: %OSPF-5-ADJCHG: Process 2020, Nbr 10.0.1.37 on Serial6/1/0 from FULL to DOWN, Neighbor Down: Interface down or detached
May 23 20:27:03: %PIM-5-NBRCHG: neighbor 10.0.252.9 DOWN on interface Serial6/1/0 non DR
ms-3722d-man-r1(config-if)#

1 ACCEPTED SOLUTION

Accepted Solutions

Hi David,

Just posting up a quick thought on the run. I'm not sure what platform you are running but some devices may have the logging of the event off as default.

You can have a look at

#logging event link-status

or similar config under the interface, or as a global toggle to switch on the event logging for interface status.

HTH

Eugene.

View solution in original post

4 REPLIES 4
Reza Sharifi
Hall of Fame Expert

David,

The default is to log messages to the console.  May be it is turned off

So try this command and test again

config t

logging con

HTH

Nope. No luck. I need the syslog message "administratively down" so that I create a EEM script to perform certain tasks.

Hi David,

Just posting up a quick thought on the run. I'm not sure what platform you are running but some devices may have the logging of the event off as default.

You can have a look at

#logging event link-status

or similar config under the interface, or as a global toggle to switch on the event logging for interface status.

HTH

Eugene.

Thanks Eugene. That worked.