cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3073
Views
0
Helpful
11
Replies
lonelyadmin
Beginner

Simple hsrp not working as expected

Hello,

 

I have a simple setup, or so I thought. 2960L switches. switch 1 and 2 standby IPs work fine, but switch 3 wants to be active despite it having a lower priority than neighbor. Debug logs and configs below.  Am I doing it wrong?

 

I removed the standby config from vlan1 and re-added it during the time of those logs.

 

switch1 gi0/24 <-> gi0/1 switch2 gi0/2 <-> gi0/24 switch3

All of those interfaces:

 

interface GigabitEthernet0/24
switchport mode trunk
ip dhcp snooping trust
end

switch1:

 

interface Vlan1
description Management
ip address 192.168.10.2 255.255.255.0
standby 1 ip 192.168.10.1
standby 1 preempt
end

 

 

switch2:

 

interface Vlan1
ip address 192.168.10.3 255.255.255.0
standby 1 ip 192.168.10.1
standby 1 priority 90
end

 

 

switch3:

 

interface Vlan1
ip address 192.168.10.4 255.255.255.0
standby 1 ip 192.168.10.1
standby 1 priority 80
end



 

switch2 logs:

Jan 27 22:25:42.620: HSRP: Vl1 Nbr 192.168.10.4 Adv in, active 1 passive 0
Jan 27 22:25:42.620: HSRP: Vl1 Nbr 192.168.10.4 is no longer passive
Jan 27 22:25:42.620: HSRP: Vl1 Nbr 192.168.10.4 destroyed
Jan 27 22:25:42.620: HSRP: Vl1 Grp 1 Hello in 192.168.10.4 Active pri 80 vIP 192.168.10.1
Jan 27 22:25:42.620: HSRP: Vl1 Grp 1 Ignoring Hello (80/192.168.10.4 < 100/192.168.10.2)
Jan 27 22:25:42.621: HSRP: Vl1 Grp 1 Coup in 192.168.10.2 Active pri 100 vIP 192.168.10.1
Jan 27 22:25:42.621: HSRP: Vl1 Grp 1 Hello in 192.168.10.2 Active pri 100 vIP 192.168.10.1
Jan 27 22:25:44.990: HSRP: Vl1 Grp 1 Hello out 192.168.10.3 Standby pri 90 vIP 192.168.10.1
Jan 27 22:25:45.252: HSRP: Vl1 Grp 1 Hello in 192.168.10.4 Active pri 80 vIP 192.168.10.1
Jan 27 22:25:45.252: HSRP: Vl1 Grp 1 Ignoring Hello (80/192.168.10.4 < 100/192.168.10.2)
Jan 27 22:25:45.252: HSRP: Vl1 Grp 1 Coup in 192.168.10.2 Active pri 100 vIP 192.168.10.1
Jan 27 22:25:45.253: HSRP: Vl1 Grp 1 Hello in 192.168.10.2 Active pri 100 vIP 192.168.10.1
Jan 27 22:25:47.602: HSRP: Vl1 Grp 1 Hello out 192.168.10.3 Standby pri 90 vIP 192.168.10.1
Jan 27 22:25:47.713: HSRP: Vl1 Grp 1 Hello in 192.168.10.2 Active pri 100 vIP 192.168.10.1
Jan 27 22:25:47.731: HSRP: Vl1 Grp 1 Hello in 192.168.10.4 Active pri 80 vIP 192.168.10.1
Jan 27 22:25:47.731: HSRP: Vl1 Grp 1 Ignoring Hello (80/192.168.10.4 < 100/192.168.10.2)
Jan 27 22:25:47.733: HSRP: Vl1 Grp 1 Coup in 192.168.10.2 Active pri 100 vIP 192.168.10.1
Jan 27 22:25:47.733: HSRP: Vl1 Grp 1 Hello in 192.168.10.2 Active pri 100 vIP 192.168.10.1
Jan 27 22:25:50.054: HSRP: Vl1 Grp 1 Hello out 192.168.10.3 Standby pri 90 vIP 192.168.10.1
Jan 27 22:25:50.185: HSRP: Vl1 Grp 1 Hello in 192.168.10.2 Active pri 100 vIP 192.168.10.1
Jan 27 22:25:50.214: HSRP: Vl1 Interface adv out, Passive, active 0 passive 1
Jan 27 22:25:50.715: HSRP: Vl1 Grp 1 Hello in 192.168.10.4 Active pri 80 vIP 192.168.10.1
Jan 27 22:25:50.715: HSRP: Vl1 Grp 1 Ignoring Hello (80/192.168.10.4 < 100/192.168.10.2)
Jan 27 22:25:50.716: HSRP: Vl1 Grp 1 Coup in 192.168.10.2 Active pri 100 vIP 192.168.10.1
Jan 27 22:25:50.717: HSRP: Vl1 Grp 1 Hello in 192.168.10.2 Active pri 100 vIP 192.168.10.1
Jan 27 22:25:52.686: HSRP: Vl1 Grp 1 Hello out 192.168.10.3 Standby pri 90 vIP 192.168.10.1
Jan 27 22:25:53.145: HSRP: Vl1 Grp 1 Hello in 192.168.10.2 Active pri 100 vIP 192.168.10.1
Jan 27 22:25:53.466: HSRP: Vl1 Grp 1 Hello in 192.168.10.4 Active pri 80 vIP 192.168.10.1
Jan 27 22:25:53.466: HSRP: Vl1 Grp 1 Ignoring Hello (80/192.168.10.4 < 100/192.168.10.2)
Jan 27 22:25:53.468: HSRP: Vl1 Grp 1 Coup in 192.168.10.2 Active pri 100 vIP 192.168.10.1
Jan 27 22:25:53.468: HSRP: Vl1 Grp 1 Hello in 192.168.10.2 Active pri 100 vIP 192.168.10.1
Jan 27 22:25:55.598: HSRP: Vl1 Grp 1 Hello out 192.168.10.3 Standby pri 90 vIP 192.168.10.1
Jan 27 22:25:56.300: HSRP: Vl1 Grp 1 Hello in 192.168.10.4 Active pri 80 vIP 192.168.10.1
Jan 27 22:25:56.300: HSRP: Vl1 Grp 1 Ignoring Hello (80/192.168.10.4 < 100/192.168.10.2)
Jan 27 22:25:56.301: HSRP: Vl1 Grp 1 Coup in 192.168.10.2 Active pri 100 vIP 192.168.10.1
Jan 27 22:25:56.302: HSRP: Vl1 Grp 1 Hello in 192.168.10.2 Active pri 100 vIP 192.168.10.1
Jan 27 22:25:58.614: HSRP: Vl1 Grp 1 Hello out 192.168.10.3 Standby pri 90 vIP 192.168.10.1
Jan 27 22:25:58.911: HSRP: Vl1 Grp 1 Hello in 192.168.10.4 Active pri 80 vIP 192.168.10.1
Jan 27 22:25:58.911: HSRP: Vl1 Grp 1 Ignoring Hello (80/192.168.10.4 < 100/192.168.10.2)
Jan 27 22:25:58.913: HSRP: Vl1 Grp 1 Coup in 192.168.10.2 Active pri 100 vIP 192.168.10.1
Jan 27 22:25:58.913: HSRP: Vl1 Grp 1 Hello in 192.168.10.2 Active pri 100 vIP 192.168.10.1
Jan 27 22:26:01.158: HSRP: Vl1 Grp 1 Hello out 192.168.10.3 Standby pri 90 vIP 192.168.10.1
Jan 27 22:26:01.377: HSRP: Vl1 Grp 1 Hello in 192.168.10.2 Active pri 100 vIP 192.168.10.1
Jan 27 22:26:01.499: HSRP: Vl1 Grp 1 Hello in 192.168.10.4 Active pri 80 vIP 192.168.10.1
Jan 27 22:26:01.499: HSRP: Vl1 Grp 1 Ignoring Hello (80/192.168.10.4 < 100/192.168.10.2)
Jan 27 22:26:01.499: HSRP: Vl1 Grp 1 Coup in 192.168.10.2 Active pri 100 vIP 192.168.10.1
Jan 27 22:26:01.501: HSRP: Vl1 Grp 1 Hello in 192.168.10.2 Active pri 100 vIP 192.168.10.1
#sh standby
Vlan1 - Group 1
State is Standby
1 state change, last state change 00:39:52
Virtual IP address is 192.168.10.1
Active virtual MAC address is 0000.0c07.ac01 (MAC Not In Use)
Local virtual MAC address is 0000.0c07.ac01 (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 0.928 secs
Preemption disabled
Active router is 192.168.10.2, priority 100 (expires in 10.032 sec)
Standby router is local
Priority 90 (configured 90)
Group name is "hsrp-Vl1-1" (default)

switch3 logs:

Oct 18 17:06:54.743: HSRP: Vl1 Interface UP 
Oct 18 17:06:54.743: HSRP: Vl1 Initialize swsb, Intf state Up
Oct 18 17:06:54.743: HSRP: Vl1 Starting minimum intf delay (1 secs) - uptime 779887
Oct 18 17:06:54.743: HSRP: Vl1 Grp 1 Set virtual MAC 0000.0c07.ac01 type: v1 default
Oct 18 17:06:54.744: HSRP: Vl1 MAC hash entry 0000.0c07.ac01, Added Vl1 Grp 1 to list
Oct 18 17:06:54.744: HSRP: Vl1 Grp 1 Priority 100 -> 80
Oct 18 17:06:55.756: HSRP: Vl1 Intf min delay expired - uptime 779888
Oct 18 17:07:05.422: HSRP: BFD client status 0 -> 1
Oct 18 17:07:05.422: HSRP: Vl1 Grp 1 fhrp mac, can reserve 0000.0c07.ac01, type v1 default - Succeeded
Oct 18 17:07:05.422: HSRP: Vl1 Added 192.168.10.1 to hash table
Oct 18 17:07:05.422: HSRP: Vl1 Grp 1 Has mac changed? cur 0000.0c07.ac01 new 0000.0c07.ac01
Oct 18 17:07:05.422: HSRP: Vl1 Grp 1 fhrp mac, reserved 0000.0c07.ac01, type: v1 default
Oct 18 17:07:05.422: HSRP: Vl1 Grp 1 Disabled: a/HSRP enabled
Oct 18 17:07:05.423: HSRP: Vl1 Grp 1 Disabled -> Listen
Oct 18 17:07:05.423: HSRP: Vl1 Interface adv out, Passive, active 0 passive 1
Oct 18 17:07:05.423: HSRP: Vl1 Grp 1 Redundancy "hsrp-Vl1-1" state Disabled -> Backup
Oct 18 17:07:05.423: HSRP: Vl1 IP Redundancy "hsrp-Vl1-1" added
Oct 18 17:07:05.423: HSRP: Vl1 IP Redundancy "hsrp-Vl1-1" update, Disabled -> Backup
Oct 18 17:07:06.852: %SYS-5-CONFIG_I: Configured from console by admin on vty0 (192.168.10.152)
Oct 18 17:07:15.933: HSRP: Vl1 Grp 1 Listen: c/Active timer expired (unknown)
Oct 18 17:07:15.933: HSRP: Vl1 Grp 1 Listen -> Speak
Oct 18 17:07:15.933: HSRP: Vl1 Grp 1 Redundancy "hsrp-Vl1-1" state Backup -> Speak
Oct 18 17:07:15.933: HSRP: Vl1 Grp 1 Hello out 192.168.10.4 Speak pri 80 vIP 192.168.10.1
Oct 18 17:07:15.933: HSRP: Vl1 IP Redundancy "hsrp-Vl1-1" update, Backup -> Speak
Oct 18 17:07:18.708: HSRP: Vl1 Grp 1 Hello out 192.168.10.4 Speak pri 80 vIP 192.168.10.1
Oct 18 17:07:21.492: HSRP: Vl1 Grp 1 Hello out 192.168.10.4 Speak pri 80 vIP 192.168.10.1
Oct 18 17:07:24.012: HSRP: Vl1 Grp 1 Hello out 192.168.10.4 Speak pri 80 vIP 192.168.10.1
Oct 18 17:07:25.228: HSRP: Vl1 Grp 1 Speak: d/Standby timer expired (unknown)
Oct 18 17:07:25.228: HSRP: Vl1 Grp 1 Standby router is local
Oct 18 17:07:25.228: HSRP: Vl1 Grp 1 Speak -> Standby
Oct 18 17:07:25.228: HSRP: Vl1 Grp 1 Redundancy "hsrp-Vl1-1" state Speak -> Standby
Oct 18 17:07:25.228: HSRP: Vl1 Grp 1 Hello out 192.168.10.4 Standby pri 80 vIP 192.168.10.1
Oct 18 17:07:25.228: HSRP: Vl1 IP Redundancy "hsrp-Vl1-1" standby, unknown -> local
Oct 18 17:07:25.228: HSRP: Vl1 IP Redundancy "hsrp-Vl1-1" update, Speak -> Standby
Oct 18 17:07:27.548: HSRP: Vl1 Grp 1 Standby: c/Active timer expired (unknown)
Oct 18 17:07:27.548: HSRP: Vl1 Grp 1 Active router is local
Oct 18 17:07:27.548: HSRP: Vl1 Grp 1 Standby router is unknown, was local
Oct 18 17:07:27.548: HSRP: Vl1 Grp 1 Standby -> Active
Oct 18 17:07:27.548: HSRP: Vl1 Interface adv out, Active, active 1 passive 0
Oct 18 17:07:27.548: %HSRP-5-STATECHANGE: Vlan1 Grp 1 state Standby -> Active
Oct 18 17:07:27.548: HSRP: Vl1 Grp 1 Redundancy "hsrp-Vl1-1" state Standby -> Active
Oct 18 17:07:27.548: HSRP: Vl1 Grp 1 Hello out 192.168.10.4 Active pri 80 vIP 192.168.10.1
Oct 18 17:07:27.548: HSRP: Vl1 Grp 1 Added 192.168.10.1 to ARP (0000.0c07.ac01)
Oct 18 17:07:27.549: HSRP: Vl1 Grp 1 Activating MAC 0000.0c07.ac01
Oct 18 17:07:27.549: HSRP: Vl1 Grp 1 Adding 0000.0c07.ac01 to MAC address filter
Oct 18 17:07:27.549: HSRP: Vl1 IP Redundancy "hsrp-Vl1-1" standby, local -> unknown
Oct 18 17:07:27.549: HSRP: Vl1 IP Redundancy "hsrp-Vl1-1" update, Standby -> Active
Oct 18 17:07:30.180: HSRP: Vl1 Grp 1 Hello out 192.168.10.4 Active pri 80 vIP 192.168.10.1
Oct 18 17:07:30.564: HSRP: Vl1 IP Redundancy "hsrp-Vl1-1" update, Active -> Active
#sh standby
Vlan1 - Group 1
State is Active
2 state changes, last state change 00:01:11
Virtual IP address is 192.168.10.1
Active virtual MAC address is 0000.0c07.ac01 (MAC In Use)
Local virtual MAC address is 0000.0c07.ac01 (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 2.032 secs
Preemption disabled
Active router is local
Standby router is unknown
Priority 80 (configured 80)
Group name is "hsrp-Vl1-1" (default)    

 

1 ACCEPTED SOLUTION

Accepted Solutions
lonelyadmin
Beginner

<sigh>

 

Figured it out. Switch 3 did not have ip routing enabled...even though the command was in the script to configure it, the ios version was 152-6.E1 and not "E2" which evidently is the first one to support ip routing on the 2960.

 

So, upgraded ios,enabled ip routing, hsrp works as expected.

 

My apologies for wasting your time on this!

 

 

View solution in original post

11 REPLIES 11
Georg Pauwen
VIP Master

Hello,

 

can all switches ping each other ?

Actually, since your switch 1 has the default priority (100) and is configured to preempt, it should always be the active one...

Yes, and it is, the problem is that switch 3 also becomes active.

Hello,

 

odd indeed. Are all three switches using the same HSRP version ? Try and configure version 2 on all three switches (standby version 2)...

They were all default v1, I changed to v2. Behavior is unchanged.

Hello,

 

is this a 'real', live network, or a simulator such as Packet Tracer ? Check which one of the three switches is the root switch (show spanning-tree vlan 1)...

Real switches. WS-2960L-24PS-LL  15.2-6E2 (E1 same behavior)

 

switch1:

 

#sh run | inc span
spanning-tree mode rapid-pvst
spanning-tree extend system-id
spanning-tree vlan 1 priority 0

 

#show spanning-tree vlan 1

VLAN0001
Spanning tree enabled protocol rstp
Root ID Priority 1
Address 70d3.7998.f400
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 1 (priority 0 sys-id-ext 1)
Address 70d3.7998.f400
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec

 

switch2:

#show spanning-tree vlan 1

VLAN0001
Spanning tree enabled protocol rstp
Root ID Priority 1
Address 70d3.7998.f400
Cost 4
Port 1 (GigabitEthernet0/1)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 2c86.d201.2880
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec

#sh run | inc span
spanning-tree mode rapid-pvst
spanning-tree extend system-id

 

switch3:

show spanning-tree vlan 1

VLAN0001
Spanning tree enabled protocol rstp
Root ID Priority 1
Address 70d3.7998.f400
Cost 8
Port 24 (GigabitEthernet0/24)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
Address 70d3.7999.2980
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec

#sh run | inc span
spanning-tree mode rapid-pvst
spanning-tree extend system-id

 

Yes. Pings between .2, .3, and .4 always work. .1 is different as it's basically a dup IP with 2 actives.

Hello

Are these readouts from Sw2 & Sw3 respectively? 

 Active virtual MAC address is 0000.0c07.ac01 (MAC Not In Use)
Local virtual MAC address is 0000.0c07.ac01 (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 0.928 secs
Preemption disabled
Active router is 192.168.10.2, priority 100 (expires in 10.032 sec)
Standby router is local
Priority 90 (configured 90)
#sh standby
Vlan1 - Group 1
State is Active
2 state changes, last state change 00:01:11
Virtual IP address is 192.168.10.1
Active virtual MAC address is 0000.0c07.ac01 (MAC In Use)
Local virtual MAC address is 0000.0c07.ac01 (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 2.032 secs
Preemption disabled
Active router is local
Standby router is unknown
Priority 80 (configured 80)
Group name is "hsrp-Vl1-1" (default)

even though you can ping between the switchs i am guesting you may have some interface misconfiguration?

SW1/2/3

sh int trunk





Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Here is the sh standby and sh int trunk for each switch.

switch1:

#sh standby
Vlan1 - Group 1 (version 2)
State is Active
4 state changes, last state change 02:36:24
Virtual IP address is 10.10.10.1
Active virtual MAC address is 0000.0c9f.f001 (MAC In Use)
Local virtual MAC address is 0000.0c9f.f001 (v2 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 2.064 secs
Preemption enabled
Active router is local
Standby router is 10.10.10.3, priority 90 (expires in 9.840 sec)
Priority 100 (default 100)
Group name is "hsrp-Vl1-1" (default)
#sh int trunk

Port Mode Encapsulation Status Native vlan
Gi0/1 on 802.1q trunking 1
Gi0/24 on 802.1q trunking 1

Port Vlans allowed on trunk
Gi0/1 1-4094
Gi0/24 1-4094

Port Vlans allowed and active in management domain
Gi0/1 1-2
Gi0/24 1-2

Port Vlans in spanning tree forwarding state and not pruned
Gi0/1 1-2
Gi0/24 1-2

switch2:

#sh standby
Vlan1 - Group 1 (version 2)
State is Standby
4 state changes, last state change 02:33:41
Virtual IP address is 10.10.10.1
Active virtual MAC address is 0000.0c9f.f001 (MAC Not In Use)
Local virtual MAC address is 0000.0c9f.f001 (v2 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 0.624 secs
Preemption disabled
Active router is 10.10.10.2, priority 100 (expires in 9.456 sec)
MAC address is 70d3.7998.f440
Standby router is local
Priority 90 (configured 90)
Group name is "hsrp-Vl1-1" (default)
#sh int trunk

Port Mode Encapsulation Status Native vlan
Gi0/1 on 802.1q trunking 1
Gi0/2 on 802.1q trunking 1

Port Vlans allowed on trunk
Gi0/1 1-4094
Gi0/2 1-4094

Port Vlans allowed and active in management domain
Gi0/1 1-2
Gi0/2 1-2

Port Vlans in spanning tree forwarding state and not pruned
Gi0/1 1-2
Gi0/2 1-2

 

switch3:

#sh standby
Vlan1 - Group 1 (version 2)
State is Active
5 state changes, last state change 02:33:30
Virtual IP address is 10.10.10.1
Active virtual MAC address is 0000.0c9f.f001 (MAC In Use)
Local virtual MAC address is 0000.0c9f.f001 (v2 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 1.856 secs
Preemption disabled
Active router is local
Standby router is unknown
Priority 80 (configured 80)
Group name is "hsrp-Vl1-1" (default

#sh int trunk

Port Mode Encapsulation Status Native vlan
Gi0/24 on 802.1q trunking 1

Port Vlans allowed on trunk
Gi0/24 1-4094

Port Vlans allowed and active in management domain
Gi0/24 1,888

Port Vlans in spanning tree forwarding state and not pruned
Gi0/24 1,888

lonelyadmin
Beginner

<sigh>

 

Figured it out. Switch 3 did not have ip routing enabled...even though the command was in the script to configure it, the ios version was 152-6.E1 and not "E2" which evidently is the first one to support ip routing on the 2960.

 

So, upgraded ios,enabled ip routing, hsrp works as expected.

 

My apologies for wasting your time on this!