ANNOUNCEMENT - The community will be down for maintenace this Thursday August 13 from 12:00 AM PT to 02:00 AM PT. As a precaution save your work.
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
230
Views
5
Helpful
2
Replies
Highlighted
Beginner

Spanning tree always blocks ether channel

Hello, I was creating a small network in packet tracer to learn about Port channels. I've run into a problem where my PC's cannot ping my router because of spanning tree protocol. My Arp's or IMCP packets ever make it to the router because of spanning tree blocking  my port channels. It also appears that Spanning tree is constantly changing what it is blocking. I was wondering if someone could help clarify what I am doing wrong. the networkthe network

Using the Simulation I've been able to trace the issue to the switch closer to the router, labeled as switch 0. 

(switch 0 pictured closer to the router)

!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
interface Port-channel1
 switchport trunk allowed vlan 10,20
 switchport mode trunk
!
interface Port-channel2
 switchport trunk allowed vlan 10,20
 switchport mode trunk
!
interface FastEthernet0/1
 switchport trunk allowed vlan 10,20
 switchport mode trunk
 channel-group 1 mode desirable
!
interface FastEthernet0/2
 switchport trunk allowed vlan 10,20
 switchport mode trunk
 channel-group 1 mode desirable
!
interface FastEthernet0/3
 switchport trunk allowed vlan 10,20
 switchport mode trunk
 channel-group 2 mode desirable
!
interface FastEthernet0/4
 switchport trunk allowed vlan 10,20
 switchport mode trunk
 channel-group 2 mode desirable
!
interface FastEthernet0/5
 switchport trunk allowed vlan 10,20
 switchport mode trunk
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end

This is the  other switch connected to my PC's

Current configuration : 1708 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
interface Port-channel1
 switchport trunk allowed vlan 10,20
 switchport mode trunk
!
interface Port-channel2
 switchport trunk allowed vlan 10,20
 switchport mode trunk
!
interface FastEthernet0/1
 switchport trunk allowed vlan 10,20
 switchport mode trunk
 channel-group 1 mode auto
!
interface FastEthernet0/2
 switchport trunk allowed vlan 10,20
 switchport mode trunk
 channel-group 1 mode auto
!
interface FastEthernet0/3
 switchport trunk allowed vlan 10,20
 switchport mode trunk
 channel-group 2 mode auto
!
interface FastEthernet0/4
 switchport trunk allowed vlan 10,20
 switchport mode trunk
 channel-group 2 mode auto
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/24
 switchport access vlan 20
 switchport mode access
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end

This is what simulation mode is able to tell me 

ccna_qu2.png

I can see this is clearly a layer 2 issue and the router is not very important for this particular question but i've also included the configuration here just in case.

!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2911/K9 sn FTX1524YQ5P-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 192.168.1.97 255.255.255.252
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.1
 encapsulation dot1Q 10
 no ip address
!
interface GigabitEthernet0/0.2
 encapsulation dot1Q 20
 no ip address
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/1.1
 encapsulation dot1Q 10
 ip address 192.168.1.2 255.255.255.224
!
interface GigabitEthernet0/1.2
 encapsulation dot1Q 20
 ip address 192.168.1.34 255.255.255.224
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

I've previously been able to ping my router but Spanning tree has taken over and stop me from progressing. I know well enough that using a work around like disabling spanning tree would not be a correct solution.

2 REPLIES 2
Highlighted
Beginner

Re: Spanning tree always blocks ether channel

I just got everything working after restarting packet tracer, i'm still beyond stumped why such a thing would happen.
Highlighted
Collaborator

Re: Spanning tree always blocks ether channel

 

it happens in PT often especially when you have too many devices; 

why do you have 2 channel-groups between same switches ?  maybe PT does not like that.

 

Regards, ML
**Please Rate All Helpful Responses **

  

Content for Community-Ad