cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2299
Views
0
Helpful
6
Replies

Spanning Tree PVID Inconsistency

mdepalmaevr
Level 1
Level 1

We had an issue the other day where a port channel was blocked due to a "SPANTREE-2-RECV_PVID_ERR". We have a port channel (channel-group 42) configured on this switch with 8 ports. This port channel is configured as a trunk and those 8 ports are tied to an ESXi host with 8 NICs. Right before the block occurred a VM was vMotioned from one host to another. The other ESXi host is also connected to the same switch another port channel (channel-group 41). The VM that was vMotioned was actually dual homed and had a leg on VLAN4 and VLAN225. We are trying to figure out what could have caused this.

 

Jan 25 20:17:21.809: %SPANTREE-2-RECV_PVID_ERR: Received BPDU with inconsistent peer vlan id 4 on Port-channel42 VLAN225.

Jan 25 20:17:21.809: %SPANTREE-2-BLOCK_PVID_PEER: Blocking Port-channel42 on VLAN0004. Inconsistent peer vlan.

Jan 25 20:17:21.809: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking Port-channel42 on VLAN0225. Inconsistent local vlan.

Jan 25 20:17:36.810: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking Port-channel42 on VLAN0004. Port consistency restored.

Jan 25 20:17:36.810: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking Port-channel42 on VLAN0225. Port consistency restored.

6 Replies 6

Reza Sharifi
Hall of Fame
Hall of Fame

Are both Portchannels and physical interfaces configured exactly the same?

Also, have a look at this doc

https://www.cisco.com/c/en/us/support/docs/lan-switching/etherchannel/20625-127.html

HTH

Here are relevant port channel and interface configs. Both are on the same switch and like I said the other end of both of these port channels is an ESXi host. Everything is consistent below.

 

interface Port-channel41
description ESX03
switchport
switchport access vlan 4
switchport trunk allowed vlan 2-7,14,15,40,50,55,60,99,104,204,205,224,225,227
switchport trunk allowed vlan add 228,230,240,248,304
switchport mode trunk
switchport nonegotiate
mtu 9000
spanning-tree portfast trunk
spanning-tree guard loop
!
interface Port-channel42
description ESX04
switchport
switchport access vlan 4
switchport trunk allowed vlan 2-7,14,15,40,50,55,60,99,104,204,205,224,225,227
switchport trunk allowed vlan add 228,230,240,248,304
switchport mode trunk
switchport nonegotiate
mtu 9000
spanning-tree portfast trunk
spanning-tree guard loop
!
interface GigabitEthernet1/3
description ESX04
switchport access vlan 4
switchport trunk allowed vlan 2-7,14,15,40,50,55,60,99,104,204,205,224,225,227
switchport trunk allowed vlan add 228,230,240,248,304
switchport mode trunk
switchport nonegotiate
mtu 9000
no cdp enable
channel-group 41 mode on
spanning-tree portfast trunk
spanning-tree guard loop
!
interface GigabitEthernet1/4
description ESX04
switchport access vlan 4
switchport trunk allowed vlan 2-7,14,15,40,50,55,60,99,104,204,205,224,225,227
switchport trunk allowed vlan add 228,230,240,248,304
switchport mode trunk
switchport nonegotiate
mtu 9000
no cdp enable
channel-group 41 mode on
spanning-tree portfast trunk
spanning-tree guard loop
!
interface GigabitEthernet1/5
description ESX04
switchport access vlan 4
switchport trunk allowed vlan 2-7,14,15,40,50,55,60,99,104,204,205,224,225,227
switchport trunk allowed vlan add 228,230,240,248,304
switchport mode trunk
switchport nonegotiate
mtu 9000
no cdp enable
channel-group 41 mode on
spanning-tree portfast trunk
spanning-tree guard loop
!
interface GigabitEthernet1/6
description ESX04
switchport access vlan 4
switchport trunk allowed vlan 2-7,14,15,40,50,55,60,99,104,204,205,224,225,227
switchport trunk allowed vlan add 228,230,240,248,304
switchport mode trunk
switchport nonegotiate
mtu 9000
no cdp enable
channel-group 41 mode on
spanning-tree portfast trunk
spanning-tree guard loop
!
interface GigabitEthernet1/7
description ESX04
switchport access vlan 4
switchport trunk allowed vlan 2-7,14,15,40,50,55,60,99,104,204,205,224,225,227
switchport trunk allowed vlan add 228,230,240,248,304
switchport mode trunk
switchport nonegotiate
mtu 9000
no cdp enable
channel-group 41 mode on
spanning-tree portfast trunk
spanning-tree guard loop
!
interface GigabitEthernet1/8
description ESX04
switchport access vlan 4
switchport trunk allowed vlan 2-7,14,15,40,50,55,60,99,104,204,205,224,225,227
switchport trunk allowed vlan add 228,230,240,248,304
switchport mode trunk
switchport nonegotiate
mtu 9000
no cdp enable
channel-group 41 mode on
spanning-tree portfast trunk
spanning-tree guard loop
!
interface GigabitEthernet1/9
description ESX04
switchport access vlan 4
switchport trunk allowed vlan 2-7,14,15,40,50,55,60,99,104,204,205,224,225,227
switchport trunk allowed vlan add 228,230,240,248,304
switchport mode trunk
switchport nonegotiate
mtu 9000
no cdp enable
channel-group 41 mode on
spanning-tree portfast trunk
spanning-tree guard loop
!
interface GigabitEthernet1/10
description ESX04
switchport access vlan 4
switchport trunk allowed vlan 2-7,14,15,40,50,55,60,99,104,204,205,224,225,227
switchport trunk allowed vlan add 228,230,240,248,304
switchport mode trunk
switchport nonegotiate
mtu 9000
no cdp enable
channel-group 41 mode on
spanning-tree portfast trunk
spanning-tree guard loop
!
interface GigabitEthernet1/15
description ESX03
switchport access vlan 4
switchport trunk allowed vlan 2-7,14,15,40,50,55,60,99,104,204,205,224,225,227
switchport trunk allowed vlan add 228,230,240,248,304
switchport mode trunk
switchport nonegotiate
mtu 9000
no cdp enable
channel-group 42 mode on
spanning-tree portfast trunk
spanning-tree guard loop
!
interface GigabitEthernet1/16
description ESX03
switchport access vlan 4
switchport trunk allowed vlan 2-7,14,15,40,50,55,60,99,104,204,205,224,225,227
switchport trunk allowed vlan add 228,230,240,248,304
switchport mode trunk
switchport nonegotiate
mtu 9000
no cdp enable
channel-group 42 mode on
spanning-tree portfast trunk
spanning-tree guard loop
!
interface GigabitEthernet1/17
description ESX03
switchport access vlan 4
switchport trunk allowed vlan 2-7,14,15,40,50,55,60,99,104,204,205,224,225,227
switchport trunk allowed vlan add 228,230,240,248,304
switchport mode trunk
switchport nonegotiate
mtu 9000
no cdp enable
channel-group 42 mode on
spanning-tree portfast trunk
spanning-tree guard loop
!
interface GigabitEthernet1/18
description ESX03
switchport access vlan 4
switchport trunk allowed vlan 2-7,14,15,40,50,55,60,99,104,204,205,224,225,227
switchport trunk allowed vlan add 228,230,240,248,304
switchport mode trunk
switchport nonegotiate
mtu 9000
no cdp enable
channel-group 42 mode on
spanning-tree portfast trunk
spanning-tree guard loop
!
interface GigabitEthernet1/19
description ESX03
switchport access vlan 4
switchport trunk allowed vlan 2-7,14,15,40,50,55,60,99,104,204,205,224,225,227
switchport trunk allowed vlan add 228,230,240,248,304
switchport mode trunk
switchport nonegotiate
mtu 9000
no cdp enable
channel-group 42 mode on
spanning-tree portfast trunk
spanning-tree guard loop
!
interface GigabitEthernet1/20
description ESX03
switchport access vlan 4
switchport trunk allowed vlan 2-7,14,15,40,50,55,60,99,104,204,205,224,225,227
switchport trunk allowed vlan add 228,230,240,248,304
switchport mode trunk
switchport nonegotiate
mtu 9000
no cdp enable
channel-group 42 mode on
spanning-tree portfast trunk
spanning-tree guard loop
!
interface GigabitEthernet1/21
description ESX03
switchport access vlan 4
switchport trunk allowed vlan 2-7,14,15,40,50,55,60,99,104,204,205,224,225,227
switchport trunk allowed vlan add 228,230,240,248,304
switchport mode trunk
switchport nonegotiate
mtu 9000
no cdp enable
channel-group 42 mode on
spanning-tree portfast trunk
spanning-tree guard loop
!
interface GigabitEthernet1/22
description ESX03
switchport access vlan 4
switchport trunk allowed vlan 2-7,14,15,40,50,55,60,99,104,204,205,224,225,227
switchport trunk allowed vlan add 228,230,240,248,304
switchport mode trunk
switchport nonegotiate
mtu 9000
no cdp enable
channel-group 42 mode on
spanning-tree portfast trunk
spanning-tree guard loop

What is the purpose of this command?

switchport access vlan 4

If vlan 4 supposed to be the native vlan than the command should be 

switchport trunk native vlan 4

HTH

Yea


@Reza Sharifi wrote:

What is the purpose of this command?

switchport access vlan 4

If vlan 4 supposed to be the native vlan than the command should be 

switchport trunk native vlan 4

HTH


I actually need to find that out. I didn't understand the purpose of that command with it being a trunk. Should this be causing an issue? I was under the assumption that it would basically be ignored because the port was configured a trunk.

I am just struggling to find a reason why a port channel that is connected to an ESXi host would have a spanning tree issue when hosts/vSwitches don't even participate in STP. The vSwtich drops STP frames also, so it isn't even possible for a VM to receive and forward.

will
Level 3
Level 3

If all other answers are coming up short, verify that the native vlan for the port-channel, or trunk is defined on both sides of the switch trunk link. for example:

vlan 999
name native

 

and that the spanning tree versions; i.e. rapid-pvst is the same on both sides.

Review Cisco Networking products for a $25 gift card