cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
810
Views
0
Helpful
8
Replies
Highlighted
Beginner

SRW2048 Limited Connectivity Issue

I have a Win 2003 server set up as my DHCP server. It is connected to port 13 of my SRW2048 switch.

Every port from 1-12 and from 25-36 get a "Limited or No Connectivity" error when I plug an ethernet cable in them from a computer (Win XP). However, all of the other ports receive an IP address and connect to our network just fine. I've noticed that they are all in the two right hand banks of ports, though, so I'm in need of assistance as to how I can get the first two banks of ports to behave the same way. In other words, I want all of the ports on the switch to be able to populate an IP address from the DHCP server attached to port 13.

Thanks for any help.

8 REPLIES 8
Highlighted
Contributor

What changed and when?

Have you rebooted device?

To me sounds like those ports stopped passing traffic, you ran out of DHCP addresses, or wrong vlan assignments.  Is this a managed switch?

Highlighted

Apparently this was an issue from day 1. I've never had a need for the other ports, but now that our DHCP server is attached to port 13 I thought I'd put our newest towers on the same port and found the issue.

The switch was rebotted twice on Friday due to power outages, and once today when I updated the firmware.

There are plenty of unleased DHCP addresses on the DHCP server on port 13 left for use.

I'm not trying to manage the switch at all, but there is one VLAN setup on it. Do I need to have a default VLAN at all setup or could that be the issue?

Highlighted

Actually if the port is in the wrong vlan or not trunked properly, you will see the symptoms.  can you give a PC a static IP, SM, and GW, then try to ping the GW?

If it was a vlan issue, we would need more info....are all the ports on the same vlan?, is your DHCP server is directly attached to port 13?  What ports are in what vlans?  Maybe when it was rebooted due to power issues it lost its config?  I an not familiar with your model, but whatever vlan your working ports are in will (probably) be the vlan you want the non-working ports in.  I say probably because it doesnt sound your site is segmented.

Message was edited by: Jimmy Sands Found these screen shots: http://screenshots.portforward.com/routers/Linksys/SRW2048/Ports_to_VLAN.htm Are all your ports in the same vlan?

Highlighted

I can give a PC a static IP, SM, and GW and get through so long as it's not connected to ports 1-12 or 25-36 on the switch.

The only VLAN set up is VLAN-1, which appears to be a default, and my ports are all a part of it. They also are all Access and Untagged, as shown in the picture you provided the link to.

Yes, my DHCP server is directly connected to port 13.

I haven't done any segmentation, and I did find another Cisco community messsage describing the exact same problem but no solution was provided.

I'm not sure why ports 1-12 and 25-36 (on the left side of the switch) can't pass traffic to port 13, but if there's a way to do it I'd love to know so I can use those ports.

Thanks

Highlighted

Well Ian, I am busy here myself today, but if your getting limited or no connectivity, then layer 1 is good.

So ports you can have one PC connected to say port 14, works great, same cable moved to port say 4, no money, correct?   This rules out cabling and the PC.

Has ports 1-12 25-36 ever worked?  They could be up but not passing traffic.  I am assuming you do get link.

Other than that I would default the switch (if you have not already), making note of any specific settings so you can re-enter them.

Someone else might chime, if not, I can reply tonight.

Of...if the the  ASIC or some other part went out controlling 1-12 and 25-36, looks like ports 13-24 work and 37-48 work, maybe seeing a pattern here.

Good luck,

Jimmy

Highlighted

Any update Ian?

Highlighted

I haven't had a chance to default the switch when no one's on it yet. Meantime I installed a DLink switch above it to I have the same number of ports.

I'm going to try to default it sometime early next week.

Highlighted

I have exactly same problem.

switch updated to latest firmware and reseted to factory defaults  - still no connection between left section (1-12/25-36) to right (13-24/37-48).

In web interface I can see, that PC is connected, I see what is the connection type, but no traffic between left/right parts of the switch.

Any ideas?

Content for Community-Ad