cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
133
Views
5
Helpful
6
Replies

SSH to CISCO Catalyst 2950 and using the ports on the switch

awsdeveloper
Beginner
Beginner

I have recently started learning switches and routers. As a first step I bought a 2650 and started playing with it.

took a static IP from Vodafone and tried applying that to the switch, but couldn't ping it so assigned a static IP like below and now I can ping the IP address but cannot SSH to it. Please advise where I am going wrong

Attached is the image of my switch.

To the first port is the cable from my Vodafone router. Second port I have connected to one of my servers. likewise I want to use 3rd and 4th port for two of my other servers. do I have to configure these ports or something. what other configurations should I be doing on this switch.

Cisco2950(config)#do show run
Building configuration...

Current configuration : 1521 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Cisco2950
!

!

ip subnet-zero
!
ip domain-name example.com
ip ssh time-out 120
ip ssh authentication-retries 3
ip ssh version 2
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission

spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9

!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
ip address 192.168.1.150 255.255.255.0
no ip route-cache
!
ip default-gateway 192.168.1.1
ip http server
banner motd ^C
Unauthorised access is strictly probihited
^C
!
line con 0
login local
line vty 0 4
login local
transport input ssh

line vty 5 15
login local
transport input ssh
!
!
end

 

 

6 Replies 6

awsdeveloper
Beginner
Beginner

I have a static IP from Vodafone, how do I use it for my switch and the servers connected too the switch

please check configuration folllow information as bellow:

hostname r1
ip domain name cisco.com
crypto key generate rsa modulus 2048
username cisco privilege 15 password c!sco
line vty 0 4
transport input ssh
login authentication default
end
wr

 

@awsdeveloper has asked 2 significant questions. The first question is about problems with SSH to the switch. To help address this question please post the output of show ip ssh from the switch.

The second question is "I have a static IP from Vodafone, how do I use it for my switch and the servers connected too the switch" Am I correct in assuming that the IP from Vodafone is a Public IP (not in 10.0.0.0 or 172.16 or in 192.168) and is a single IP address? In this case your servers would be using Private IP addresses. For them to communicate with a Public IP you would need to do Address Translation. Unfortunately your 2960 does not do address translation. You would need a device that does do address translation (a firewall or a router) for the servers to be able to get to Vodafone.

HTH

Rick

@Richard Burts 

Cisco2950>show ip ssh
SSH Enabled - version 2.0
Authentication timeout: 120 secs; Authentication retries: 3
Cisco2950>en
Password:
Cisco2950#
Cisco2950#
Cisco2950#show ip ssh
SSH Enabled - version 2.0
Authentication timeout: 120 secs; Authentication retries: 3

the static IP given by Vodafone is in the range 93.107.x.x

I have a CISCO 2651MX router, would it help me in anyway to prepare this lab.

Thanks,

 

NetworkDave
Beginner
Beginner

@awsdeveloper ,

In regards to Pinging & SSHing into the switch: From where are you trying to do this? Locally (ie. a pc connected to one of the switch ports) or remotely (via internet)?

Observation: The picture of your switch shows three cables connected to it. You mentioned what the first two cables are for.                           What is the third cable connected to ?

In regards to your network setup, it appears you are trying to connect a new LAN (Switch and servers) to your existing network; is this what you are trying to do? Are the servers up on your existing network or are they additions? What else is connected to the Vodafone and which devices are currently up and working on you existing network?

You mentioned that your IP range was 93.107.x.x that's quite a few public addresses. Is this a home network?

 

Thanks for the information that I requested. It does verify that SSH is enabled. I have looked at the posted config and believe that I see the problem. Your configuration of the vty lines specifies login local. This expects to use a locally configured ID and password. But your config does not show any user ID and password. If you configure a user ID and password I expect that SSH will work.

If you have a 2651 router it could be quite useful for your lab. If you want the devices in your lab to be able to access the Internet then you need to do address translation. Most Cisco switches do not support NAT but routers do.

HTH

Rick
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers