cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
291
Views
5
Helpful
2
Replies
Highlighted
Beginner

STP broked the stack. 3750G

Hello, colleagues.


We have faced an STP bug\problem, that later caused a switch-stack to brake.

I would like to know, if anybody had faced similar problem before, and what could be the reason of it.


Hardware is 2*WS-C3750G-48TS stacked with 15.0(2)SE11 IOS running.

STP config:

spanning-tree mode rapid-pvst
spanning-tree logging
spanning-tree portfast bpduguard default
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
spanning-tree vlan 1-1000 priority 4096


Steps, causing the crash:

First - We have faced a problem after creating new VLAN 707 - deviced added to this VLAN could not ping each other, though their MAC-addresses where seen in CAM-table of the switch.

Second - during the troubleshooting we have found strange behaviour of STP:

#show spanning-tree summary
...
Name Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------
...
VLAN0517 0 0 0 5 5
VLAN0518 0 0 0 10 10
VLAN0520 0 0 0 15 15
VLAN0521 0 0 0 14 14
VLAN0523 0 0 0 19 19
VLAN0526 0 0 0 2 2
VLAN0527 0 0 0 11 11
VLAN0528 0 0 0 20 20
VLAN0529 0 0 0 15 15
VLAN0530 0 0 0 3 3
VLAN0535 0 0 0 8 8
VLAN0580 0 0 0 2 2
VLAN0598 0 0 0 2 2
VLAN0702 0 0 0 9 9
VLAN0704 0 0 0 4 4
VLAN0707 - 253 -1872756560 2087191206 -1872756548 2080375983

Port counters showed some impossible values, so we decided to use "clear spanning-tree counters interface ***"  where *** are interfaces witch VLAN 707 in trunk.

Third - immediately after this command, second switch of the stack disconnected, like it was powered of. Show switch command showed is as "provisioned".

Fourth - we had to reload second switch by powering it off\on. Unfortunately we have had no time to do additinal troubleshooting of this switch, cause it was a production environment.

Fifth - second switch booted and returned to the stack. All devices in VLAN 707 began to work and show spanning-tree summary now shows correct values.


Any suggestions?

2 REPLIES 2
Highlighted
VIP Mentor

sounds like buggy behavior and i see a few STP bugs in that release of v15 but nothing matching exactly, there was a newer release later that year but its a v12 release thats supposed to be more stable if you dont require specific features of v15

when the devices could not ping did you check the arp table too , was it complete for these macs

have you tried to replicate the issue , it may have just been a once off but if you can replicate i would get off that image
Highlighted

when the devices could not ping did you check the arp table too , was it complete for these macs \\\
yes, mac were seen correctly, including macs from another switch via trunk

ave you tried to replicate the issue \\\
I dont see the way to replicate the initial broken-STP-stance. Creating new VLANs works good for now.

sounds like buggy behavior and i see a few STP bugs in that release\\\
please tell, where can I find known bugs for this ios?
Content for Community-Ad