cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

185
Views
10
Helpful
7
Replies
Beginner

SVI Stopped working but Traffic is passing C2950

Description:

SVI stopped working in many switches of my inside network but some switches are still working fine. There is a difference of days and hours from 1 switch to other switche when SVI stopped. I tired all the possible solutions from blogs/google and from my own knowledge and nothing worked at all. This network was working fine from many years and no new changes in it.

Troubleshooting done:

  • clear arp & mac addresses
  • create new vlan interface
  • assign new ip address
  • debug ip packets of switch shows encapsulation failed when ping to gateway
  • Switchport mode changed and tried
  • remove all overhead configurations and only vlan 1 is configured in all switches
  • pull out the switch which has non-working SVI and connect it to another fresh router

Solution:

  • A hard reboot to the switch bring the SVI up and all back to normal for 4 to 6 days max and again SVI stopped.

Attached:

configs and vlan info

   

7 REPLIES 7
Highlighted
VIP Mentor

Re: SVI Stopped working but Traffic is passing C2950

Hi
are these switches running same IOS version ?

 

Are these switches L2 , if they are the SVI is only for MGMT , if SVI is dropping could be an STP issue i causing it too , the switch has very little config , trunk port set to allow vlan 2 only and the rest of the ports are vlan 1 , even though vlan 1 is not really blocked on a trunk should still be permitted if access ports are working on vlan 1

VIP Mentor

Re: SVI Stopped working but Traffic is passing C2950

This command canb show if there is constant L2 changes in the network which could cause interruptions to the SVIs ,if the timers are constantly resetting there is issues at layer 2

show spanning-tree detail | inc ieee|occurr|from|is exec
Beginner

Re: SVI Stopped working but Traffic is passing C2950

Hi Mark,

 

"Output of the command"

 

Switch.Test#

Switch.Test#show spanning-tree detail | inc ieee|occurr|from|is exec
VLAN0002 is executing the ieee compatible Spanning Tree protocol
Number of topology changes 4 last change occurred 04:37:12 ago
from FastEthernet0/1
Switch.Test#

Beginner

Re: SVI Stopped working but Traffic is passing C2950

Hi Mark,

-Different IOS versions because i have 48 ports to 24 ports switches.

-SVI is only for MGMT

-yes, L2 switches

-Vlan2 is only for the simulation...in my actual configs, there is no vlan2 except native vlan 1 in all switches.

 

Further; since these switches has been logged on cacti, no abrupt high cpu utilization found.

VIP Advisor

Re: SVI Stopped working but Traffic is passing C2950

Hello
in addition to @Mark Malone  comments


@Mike202 wrote:

Description:

SVI stopped working in many switches of my inside network but some switches are still working fine. There is a difference of days and hours from 1 switch to other switche when SVI stopped. I tired all the possible solutions from blogs/google and from my own knowledge and nothing worked at all. This network was working fine from many years and no new changes in it.

Troubleshooting done:

  • remove all overhead configurations and only vlan 1 is configured in all switches

interface Vlan1
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
no ip route-cache
shutdown

interface Vlan2
ip address 172.16.16.2 255.255.255.0
no ip route-cache
ip default-gateway 172.16.16.1


VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/2, Fa0/3, Fa0/4, Fa0/5
Fa0/6, Fa0/7, Fa0/8, Fa0/9
Fa0/10, Fa0/11, Fa0/12, Fa0/13
Fa0/15, Fa0/16, Fa0/17, Fa0/18
Fa0/19, Fa0/20, Fa0/21, Fa0/22
Fa0/23, Fa0/24

2 test active Fa0/1, Fa0/14

interface FastEthernet0/1
switchport access vlan 2
switchport trunk native vlan 2

interface FastEthernet0/14
switchport access vlan 2
no ip address

 

 

Looks like you are running vlan 2 - Suggest you make sure all you switches interconnects have the correct trunk configuration and their specifying the native vlan as above

 

Also enable spanning-tree portfast and BPDU Guard on ALL access ports

interface FastEthernet0/1
description trunk port
switchport mode trunk  <--------
switchport trunk native vlan 2 <-----

interface x/x
description ACCESS Ports
switchport host
spanning-tree bpduguard enable



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Beginner

Re: SVI Stopped working but Traffic is passing C2950

Hi Paul,

 

After this incident started, i put all my switches in VTP mode Transparent. The Problem is once the SVI stopped, it can't be retrieved in any way except to reload the switch. That is the reason i took out 1 non-working SVI switch and configure int vlan 2 for the test purposes with another router. the attached config of switch.test has 1standalone router, 1 switch, 1 pc and still SVI has no response.

 

 

Beginner

Re: SVI Stopped working but Traffic is passing C2950

Hello Experts,

 

Looking for a solution from your deep knowledge/experience!

 

As previously recommended by Paul/Mark. i have done all the steps and again 1 of my switch SVI stopped responding after 6 days in the network.

Attached details of config/output.

  • No STP topology changes observed
  • No BPDU messages observed
  • Nothing happened which i can see causes this switch to stop responding to other network devices.

Awaiting your suggestions.

 

BR,

Mike

 

 

 

Everyone's tags (5)
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards