cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
984
Views
20
Helpful
6
Replies
Highlighted
Beginner

Switch DHCP for Avaya Phone

for the life of me i can not get a consistent result for our remote site switches to handout DHCP addresses for our Avaya 9611 phones.  I have a new location that will not work.  the switch is a   WS-C2960S-48FPD-L, 15.2(2)E5.  Switch settings are:

 

ip dhcp excluded-address 172.16.2.65 172.16.2.90
!
ip dhcp pool vlan306
network 172.16.2.64 255.255.255.192
default-router 172.16.2.65
option 242 "MCIPADD=172.20.106.140,MCPORT=1719,HTTPSRVR=172.20.101.207,VLANTEST=0,L2Q=1,L2QVLAN=306"

 

lldp run

 

interface GigabitEthernet1/0/11
switchport access vlan 136
switchport voice vlan 306
mls qos trust dscp
no cdp enable
spanning-tree portfast

 

other remote sites work.  i seem to have to fight each location to get to work.  This one is the exception.

 

any ideas?

 

thanks

 

 

 

 

 

 

2 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted

for the IP phones at remote sites, we had been statically assigning the ip addresses.  Now we want to use DHCP to preform this task.  The layer 3/routing for this subnet is at the Core with DHCP being defined for this subnet at the switch.

 

thanks

 

View solution in original post

Highlighted

Hello

As stated by pieterh , If the switch is ruining dhcp then it require a L3 ip address for those users on that scope it is servicing.

 

So if you have a switch running as a host, ( no ip routing and just SVI mgt address)  then even if you have dhcp enabled on that switch any host attached to it will not receive a reply to their dhcp requests.



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

View solution in original post

6 REPLIES 6
Highlighted
VIP Rising star

as you configure the scope on the switch I'm missing something like

  interface vlan 306

        ip address 172.16.2.65 255.255.255.192 

if the dhcp server is another device, than you don't need this scope on the switch

Highlighted

for the IP phones at remote sites, we had been statically assigning the ip addresses.  Now we want to use DHCP to preform this task.  The layer 3/routing for this subnet is at the Core with DHCP being defined for this subnet at the switch.

 

thanks

 

View solution in original post

Highlighted
VIP Mentor

Hello

So to confirm the switch at this site is l3 switch and running its own dhcp service, and these voip devices are local to that site?



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted

WS-C2960S-48FPD-L is a layer two switch that can do DHCP services.

the phones are local to this switch.

 

BMI_2960S(config)#service ?
dhcp                                             Enable DHCP server and relay agent

 

Thanks,

Highlighted

ip repeat: does the switch has an ip-address in the voice vlan?

if not, it will not issue ip addresses to connected devices.

Highlighted

Hello

As stated by pieterh , If the switch is ruining dhcp then it require a L3 ip address for those users on that scope it is servicing.

 

So if you have a switch running as a host, ( no ip routing and just SVI mgt address)  then even if you have dhcp enabled on that switch any host attached to it will not receive a reply to their dhcp requests.



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

View solution in original post

Content for Community-Ad