cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
379
Views
0
Helpful
7
Replies

switch from Stack 2x C9200 removed

Hi,

we have a switch sw1 in Stack 2x C9200L - went out the itself Stack.
we tried to change Stack cable and reload but no go.
no Configuration change and was ok for more than a year.

sw1#sh sw

Switch/Stack Mac Address : cc7f.761a.aaaa - Foreign Mac Address

Mac persistency wait time: Indefinite

H/W Current

Switch# Role Mac Address Priority Version State

-------------------------------------------------------------------------------------

1 Member 0000.0000.0000 0 V01 Removed

*2 Active cc7f.763e.aaaa 1 V01 Ready

 

what else we can try ?

 

Regards

Boris

2 ACCEPTED SOLUTIONS

Accepted Solutions
balaji.bandi
VIP Master

The switch not joining stack boot ? when you console and check ? - if that is booting ?

 

have you setup switch numbers and priorty of the switch to be master ?

 

what is the versios of CODE

 

Turn off both the switches, check the cables again. and Turn on Switch 1 first and then Switch 2 ? console to Switch 1 post complete logs.

 

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

View solution in original post


@BorislavPenchev0962 wrote:

16.09.05


I know what this is:  CSCvr32460

9200/9200L firmware has several "stack merge" bugs and this is one of those bugs.

The only way to fix this is to reboot the switch that is currently not joining.  If the switch is in ROMMON, it would be good to have a console into the switch before rebooting.  Post the entire boot-up process so we can have a look.

View solution in original post

7 REPLIES 7
balaji.bandi
VIP Master

The switch not joining stack boot ? when you console and check ? - if that is booting ?

 

have you setup switch numbers and priorty of the switch to be master ?

 

what is the versios of CODE

 

Turn off both the switches, check the cables again. and Turn on Switch 1 first and then Switch 2 ? console to Switch 1 post complete logs.

 

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

View solution in original post

sorry clicked accept solution by mistake, issue still persist

 

IOS 16.09.05

we can not reboot the master as its production environment, the member in question has been rebooted many times;

- "The switch not joining stack boot ? when you console and check ?" - how to check that ?

 

Switch/Stack Mac Address : cc7f.761a.aaaa- Foreign Mac Address

Mac persistency wait time: Indefinite

                                             H/W   Current

Switch#   Role    Mac Address     Priority Version  State

-------------------------------------------------------------------------------------

1       Member   0000.0000.0000     0      V01     Removed

*2       Active   cc7f.763e.aaaa     1      V01     Ready

 

 

 

         Stack Port Status             Neighbors

Switch#  Port 1     Port 2           Port 1   Port 2

--------------------------------------------------------

  2       DOWN       DOWN             None     None

 

 

Sw#/Port#  Port Status  Neighbor  Cable Length   Link OK   Link Active   Sync OK   #Changes to LinkOK  In Loopback

-------------------------------------------------------------------------------------------------------------------

2/1        DOWN         NONE      50cm           Yes       No            Yes       6                   No

2/2        DOWN         NONE      50cm           Yes       No            Yes       1                   No

 

Redundant System Information :

------------------------------

       Available system uptime = 1 year, 8 weeks, 1 day, 14 minutes

Switchovers system experienced = 1

              Standby failures = 1

        Last switchover reason = active unit removed

 

                 Hardware Mode = Simplex

    Configured Redundancy Mode = sso

     Operating Redundancy Mode = Non-redundant

              Maintenance Mode = Disabled

                Communications = Down      Reason: Failure

 

Current Processor Information :

-------------------------------

               Active Location = slot 2

        Current Software state = ACTIVE

       Uptime in current state = 44 weeks, 6 days, 22 hours, 32 minutes

                 Image Version = Cisco IOS Software [Fuji], Catalyst L3 Switch Software (CAT9K_LITE_IOSXE), Version 16.9.5, RELEASE 

                          BOOT = flash:packages.conf;

        Configuration register = 0x102

 

Regards

Boris

pman
Participant

Maybe it's a BUG


https://quickview.cloudapps.cisco.com/quickview/bug/CSCvn30950

 

Workaround:

The only way to recover is to reboot the Active switch. Proactively perform a "redundancy force-switchover" about once a week.

Leo Laohoo
VIP Community Legend


@BorislavPenchev0962 wrote:

was ok for more than a year.


What is the exact IOS-XE version of the stack? 

16.09.05


@BorislavPenchev0962 wrote:

16.09.05


I know what this is:  CSCvr32460

9200/9200L firmware has several "stack merge" bugs and this is one of those bugs.

The only way to fix this is to reboot the switch that is currently not joining.  If the switch is in ROMMON, it would be good to have a console into the switch before rebooting.  Post the entire boot-up process so we can have a look.

View solution in original post

reboot of both switches one by one worked.

 

thanks !