cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
204395
Views
55
Helpful
17
Replies

SWITCH PORT MODES

WHAT IS ACCESS, TRUNK, DYNAMIC, DESIRABLE AND AUTO MODES

PLEASE HELP ME ASAP.

17 REPLIES 17

http://bradhedlund.com/2007

http://bradhedlund.com/2007/11/27/switchport-configurations-explained/

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
Participant

This discussion has been

This discussion has been reposted from Additional Communities to the Getting Started with LANs community.

Beginner

Re: http://bradhedlund.com/2007

very unsefull indeed much more clear and complete than what's in CCIE Routing and Switching v5.0 Official Certification guide.

congratulations

Beginner

There are two types of

There are two types of switchports: trunk or access.

 

A access port is typically for a switch to host connection and this port is assigned to only one VLAN.  This can be done with the following commands:

# interface fastethernet [interface number]

# switchport mode access

# switchport access vlan [vlan number]

 

A trunk is typically a link between two switches or a switch and a router.  This allows multiple VLANs to traverse the interface/link. This can be configured in a few different ways but will achieve the same result.

# interface fasterthernet [interface number]

# switchport mode [select mode]

 

The mode you select could be any of the below:

... dynamic auto

... dynamic desirable 

.... trunk 

 

The 'dynamic auto' will configure the port to accept incoming negotiation and will accept becoming either a trunk or an access port.

The 'dynamic desirable' will configure the port to try and become a trunk link by sending a request to the other end of the wire requesting to become a trunk port.

The 'trunk' command will force the port to become a trunk.

 

 

 

Beginner

DTP stands for Dynamic

DTP stands for Dynamic Trunking Protocol and is crucial to the commands below. It is also Cisco proprietary.

switchport mode access - Always forces that port to be an access port with no VLAN tagging allowed EXCEPT for the voice vlan. DTP is not used and a trunk will never be formed.

switchport nonegotiate - turns off DTP and forces the interface into a trunk.

switchport mode dynamic desirable - pro-active DTP negotiation will begin and if the other-side is set to trunk, desirable, or auto. The interface will become a trunk. Otherwise the port will become an access port.

switchport mode dynamic auto - allows the port to negotiate DTP if the other side is set to trunk or desirable. Otherwise it will become an access port.

switchport mode trunk - This interface will always be a trunk no matter what happens on the other side. It will also use DTP to negotiate a neighbouring interface that is set to dynamic desirable or dynamic auto into a trunk.

In the real world - I have never seen *dynamic auto*or dynamic desirable as generally network engineers try and make layer 2 related items (such as switchport settings) stable and static. There are also security risks associated with this.

An access role port is usually used for an single host or device. You must also specify which VLAN you would like it to be associated with, otherwise it will default to VLAN 1 in the Cisco world. eg)

interface gig0/1
switchport mode access
switchport access vlan 10

Also, if you have a VLAN for voip traffic. You can also set the voice vlan as required by adding

switchport voice vlan 20

A trunk port is generally only used when you want to interconnect two switches together in order to pass multiple VLANs between the two switches. In this example, the switches will use Dot1Q tagging and allow vlans 10, 20 & 30 to be passed between the two switches. Vlan 10 however, will be passed without tagging since it is set as the native vlan. eg)

Switch1# interface gig0/1
switchport encapsulation dot1q
switchport mode trunk
switchport trunk native vlan 10
switchport trunk allowed vlan 10,20,30

Switch2# interface gig0/1
switchport encapsulation dot1q
switchport mode trunk
switchport trunk native vlan 10
switchport trunk allowed vlan 10,20,30

HTH,

Paul

Beginner

Re: Switchport trunk mode

Apologies firstly for not creating a new thread, please also forgive me if I am wrong but I think my question may be somehow related.

 

I've got two switches trunked on port f0/1. Switch 1 should be trunking on desirable mode and Switch 2 on auto mode. The running configs looks like:

 

S1

interface FastEthernet0/1

switchport access vlan 99

switchport trunk native vlan 99

switchport mode dynamic desirable

 

S2

interface FastEthernet0/1

switchport access vlan 99

switchport trunk native vlan 99

 

Are there any lines that should not be there? Should there only be one trunk port?

 

Beginner

Re: DTP stands for Dynamic

Paul  - 

 

Switchport mode access command - I never used it but is that used to create a new vlan on a live switch?

Please let me know...thanks!

Beginner

First off, I apologize if I

First off, I apologize if I should make a new thread for this question, but I figured you guys wanted to keep the board as clean as possible.

Anyway, I'm about to take my CCENT. I'm going through some Boson exams to make sure I'm 100% (My schools makes me have a 90% on Boson before I can schedule the actual exam). This question came up on trunking -- I'm not a complete noob with cisco, I have a few years of experience, but I believe this question to be wrong and I'm hoping that I'm wrong and just not understanding it.

Anyway, the question is --

You are trying to determine why a trunk link is not forming between two Cisco Catalyst 2960 series switches. You have issues the show interfaces fastethernet 0/5 trunk command on SwitchA and received the following output:

Port - Fa0/5

Mode - Auto

Encapsulation - 802.1q

Status - not-trunking

Native vlan - 1

Which of the following switchport modes are you likely to find listed in the command output when you issue the same command for the neighboring interface on SwitchB? (select 2)

A - off

B - desirable

C - auto

D - trunk

E - access

F - on

 

I'll take you through my thought process as this question seems easy enough. A / F are not switchport mode commands so those were ruled out. B wouldn't make sense, because from my understanding Desirable tries and force the port to trunk and if the other side is set to auto then it will negotiate as a trunk. D wouldn't make sense since auto negotiate to a trunk port if the other end is a trunk port.

That left me with C / E - Auto and Access. I answered that and I was wrong. Am I completely missing a vital concept here or is this question messed up?

 

 

Beginner

It can't be C / E as you are

It can't be C / E as you are trying to form a trunking here. The best answer would be D / F.

Beginner

The question isn't worded

The question isn't worded like that. I don't know if you read part 2 of it, but it says:

Which of the following switchport modes are you likely to find listed in the command output when you issue the same command for the neighboring interface on SwitchB?

The trunk hasn't been formed yet and you're troubleshooting why, if it was set to Trunk on the other end then it would have negotiated properly, correct?

Beginner

I concur with you Chairs9816.

I concur with you Chairs9816.  I've read the question and agree with your diagnosis that the answer should be C & E but am puzzled why Boson marks it wrong. Did you ever get any further with this out of interest? It could just be an error with their test I suppose.

Beginner

On this answer it should be A

On this answer it should be A and C as the correct answer. If you were to issue the same command which is show int f0/5 trunk (abbreviate) and it was an access port nothing would be displayed on the output because it is setup as an access port. Since the trunk is not forming and we can see the one side is auto then the other side must either be off or auto as well for that command to spit out anything on the other switch. Those are just my thoughts on it. Really confusing question but when reading questions you have to think what are they trying to get you to learn. Since the question is about trunking I would assume that the other side is not access. 

This is a misleading question though because off really makes it an access port and it will never trunk so really the question is testing if you know the trunk modes. 

Maybe I am wrong though

http://www.ciscopress.com/articles/article.asp?p=29803&seqNum=3

Beginner

The answer is C.

The answer is C.

If both switches are on auto, they cannot agree on both trunking, or access.

Beginner

Re: SWITCH PORT MODES

There are two types of

There are two types of switchports: trunk or access.

 

A access port is typically for a switch to host connection and this port is assigned to only one VLAN.  This can be done with the following commands:

# interface fastethernet [interface number] eg:#interface fastethernet 0/0-24

# switchport mode access eg:#switchport mode access 

# switchport access vlan [vlan number] eg:switchport access vlan 10

 

A trunk is typically a link between two switches or a switch and a router.  This allows multiple VLANs to traverse the interface/link. This can be configured in a few different ways but will achieve the same result.

# interface fasterthernet [interface number] eg:interface fastethernet 0/1

# switchport mode [select mode]eg:#switchport mode trunk

 

The mode you select could be any of the below:

... dynamic auto

... dynamic desirable 

.... trunk 

 

The 'dynamic auto' will configure the port to accept incoming negotiation and will accept becoming either a trunk or an access port.

The 'dynamic desirable' will configure the port to try and become a trunk link by sending a request to the other end of the wire requesting to become a trunk port.

The 'trunk' command will force the port to become a trunk.

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards