cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1250
Views
0
Helpful
11
Replies
Highlighted

Switch Port not working Cisco 2960x series

Hello All

I am facing one issue today,

I have 4 switch stack(2960x).

4 ports of switch have some issue( Gi 4/0/19 to 4/0/22)

Issue is like below.

When login, and check the status of these ports . it shows UP.

But physical LED of that port is down and not working.

I check same cable to connect with other port of same switch (Gi4/0/45)

then it works fine.no err-disable or any looping issue.!!

Speed and duplex are default from both side(user and port).

 

Can any one have any idea what may be the issue. ??

 

 

11 REPLIES 11
Highlighted
VIP Mentor

Re: Switch Port not working Cisco 2960x series

Hello,

 

could be a bug...which IOS version are running ? Are the PoE ports ?

Highlighted

Re: Switch Port not working Cisco 2960x series

Version- 15.2(2)E7 ,

yes Its PoE enabled switch

Highlighted
Hall of Fame Community Legend

Re: Switch Port not working Cisco 2960x series

Post the complete output to the command "sh interface Gi4/0/19 controll".
Highlighted

Re: Switch Port not working Cisco 2960x series

Check below..

 

GigabitEthernet4/0/19 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is b4a8.b95e.da93 (bia b4a8.b95e.da93)
  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 00:00:03, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 1387
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 1000 bits/sec, 1 packets/sec
     32089158 packets input, 7456502675 bytes, 0 no buffer
     Received 155477 broadcasts (133064 multicasts)
     0 runts, 0 giants, 0 throttles
     3 input errors, 3 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 133064 multicast, 1 pause input
     0 input packets with dribble condition detected
     73110049 packets output, 71069918554 bytes, 0 underruns
     0 output errors, 0 collisions, 3 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 pause output
     0 output buffer failures, 0 output buffers swapped out

     Transmit GigabitEthernet4/0/19           Receive
   2350443739 Bytes                       3161535379 Bytes
     63550406 Unicast frames                31933681 Unicast frames
      6135611 Multicast frames                133064 Multicast frames
      3424053 Broadcast frames                 22413 Broadcast frames
            0 Too old frames              3148732424 Unicast bytes
            0 Deferred frames                9103342 Multicast bytes
            0 MTU exceeded frames            3698523 Broadcast bytes
            0 1 collision frames                   0 Alignment errors
            0 2 collision frames                   3 FCS errors
            0 3 collision frames                   0 Oversize frames
            0 4 collision frames                   0 Undersize frames
            0 5 collision frames                   0 Collision fragments
            0 6 collision frames
            0 7 collision frames            20737102 Minimum size frames
            0 8 collision frames             2438702 65 to 127 byte frames
            0 9 collision frames             3184737 128 to 255 byte frames
            0 10 collision frames            2009873 256 to 511 byte frames
            0 11 collision frames            1098307 512 to 1023 byte frames
            0 12 collision frames            2620441 1024 to 1518 byte frames
            0 13 collision frames                  0 Overrun frames
            0 14 collision frames                  1 Pause frames
            0 15 collision frames
            0 Excessive collisions                 0 Symbol error frames
            0 Late collisions                      0 Invalid frames, too large
            0 VLAN discard frames                  0 Valid frames, too large
            0 Excess defer frames                  0 Invalid frames, too small
      5932857 64 byte frames                       0 Valid frames, too small
     11941403 127 byte frames
      8113299 255 byte frames                      0 Too old frames
      1624702 511 byte frames                      0 Valid oversize frames
      1163557 1023 byte frames                     0 System FCS error frames
     44334252 1518 byte frames                     0 RxPortFifoFull drop frame
            0 Too large frames
            0 Good (1 coll) frames
            0 Good (>1 coll) frames

Highlighted
Hall of Fame Community Legend

Re: Switch Port not working Cisco 2960x series

What happens if you move the cable to a different port?
Highlighted

Re: Switch Port not working Cisco 2960x series

then it works, only mentioned ports (Gi 4/0/19 to 22) have this issue, even these ports were also working fine earlier .

Highlighted
VIP Mentor

Re: Switch Port not working Cisco 2960x series

Hello,

 

what is the uptime of the switch (show version) ?

Highlighted

Re: Switch Port not working Cisco 2960x series

uptime = 18 weeks,

Highlighted
Hall of Fame Community Legend

Re: Switch Port not working Cisco 2960x series

Post the complete output to the command "sh post".
Highlighted
VIP Mentor

Re: Switch Port not working Cisco 2960x series

Hello

Unfortunately ports do break, more so if they are POE -  You cold try defaulting the interfaces check some statistics but it sounds like the ports are possible broken.

 

default int ran gig1/0/19 -22
sh interface gig1/0/xx status
test interfaces gig1/0/x
sh interface gig1/0 controller
show power inline gig1/0/x 
(if applicable)

r
es

Paul



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted

Re: Switch Port not working Cisco 2960x series

Right now , now physical connection to this port (Gi 4/0/19) but it is still showing UP in status, but LED is down. other asked details are as below. after defaulting the port.

 

CINSUR01MKTSTK01#sho interfaces gigabitEthernet 4/0/19 status

Port      Name               Status       Vlan       Duplex  Speed Type
Gi4/0/19                     connected    1          a-full a-1000 10/100/1000BaseTX

CINSUR01MKTSTK01#test interfaces gigabitEthernet 4/0/19
No IP address for GigabitEthernet4/0/19.
Skipping...
1 interfaces: 0 passed, 0 failed, 0 skipped, 1 untestable


CINSUR01MKTSTK01#show power inline gigabitEthernet 4/0/19
Interface Admin  Oper       Power   Device              Class Max
                            (Watts)
--------- ------ ---------- ------- ------------------- ----- ----
Gi4/0/19  auto   off        0.0     n/a                 n/a   30.0

Interface  AdminPowerMax   AdminConsumption
             (Watts)           (Watts)
---------- --------------- --------------------

Gi4/0/19              30.0                 15.4

CreatePlease to create content
Content for Community-Ad