cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
551
Views
3
Helpful
3
Replies
Muhammad Thanveer
Contributor

switch port trunked towards Cisco phone and PC

Dear All,

I have a set-up wherein my cisco switch port has trunked which is towards Cisco Phone and in turn a PC is connected.

On switch my vlan for voice traffic is 20 and data is 10

on trunk port native vlan is 20

Cisco Switch------(Trunk)------Phone-----PC.

Question No 1) will this set up work?

Question No 2) Will we get native vlan mismatch on switch.

Question no 3)what are the disadvantages or advantages of doing so.

Note: I am unable to do this in Lab because of limitation of the devices available. I am aware that we basically do Access port on switch with voice and data vlan Allowed.

Thanks in advance.

All the useful comments will be rated. :) 

BR

Mohammad Thanveer

3 REPLIES 3
duckandchips
Beginner

Hello Mate

This will work!!!

1) create the vlan 's
vlan 10
name DATA
!
vlan 20
name VOICE

2) create a SVI ( if using layer 3 , inter-vlan routing)

interface vlan 10
ip address 10.46.1.1 255.255.255.0
description  Data
!ip helper-address x.x.x.x
!
interface vlan 20
ip address 10.46.2.1 255.255.255.0
description Voice

3) config the switchport

!
interface range gigabitEthernet  1/0/1 - 48 
description standard Voice and Data port
switchport mode access
Switchport access vlan 10
switchport voice vlan 20
spanning-tree portfast
spanning-tree bpduguard enable
macro apply cisco-phone
no shut

from the interface config , soon as you apply the "switchport voice Vlan " command it allows the voice and data vlan to coexist together on an access port.

hope this helps

Jason

Hello Friend,

Thanks for your reply. 

I understand that it will work, My question is If the switch port is a trunk port with native vlan 20 in my case, what will happen?

Will we get native vlan mismatch on switch.

It's will not work as a trunk port, 

its needs to be an access port , 

Just to add , port on a switch can be in a couple of states.

1) Routed port

2) access port  an part of a single vlan

3) Trunk port , many vlans allowed

or

4) Voice port ( something special happens as the access port is allows one more VLAN in this mode ) in addition to the native vlan