cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
92
Views
0
Helpful
2
Replies

Switch Rate-Lmit per port

Dears,

I need to implement a scenario to one of my customers, he needs:

  • Limit the Interfaces to a specific bandwidth ( 4 Mbps , 10 Mbps , 20 Mbps )
  • all the interfaces will have the same gate-way IP( Router IP)

customer has a Switch (3560-48PS) and a Router, and I suggested to :

  • assign all the interface to single VLAN and to enable all the interfaces to access.
  • Enable rate-Limit per port.

Now I am not able to apply the rate Limit in both directions as the srr-queue bandwidth limit is not working in the outgoing direction I don't Know Why and I am not able to trouble shoot in the switch to know if it is working or not. 

any suggestions 

used IOS: 

  • c3560-ipbase-mz.122-35.SE5

 

Everyone's tags (1)
2 REPLIES 2
Participant

you would need to use

you would need to use policers for inbound traffic and srr bandwidth limit for outbound traffic.  

I want to check if my below

I want to check if my below configuration is correct or no

I need to rate limit all the traffic entering the Fa0/45 to 20 Mbps, so I need to check if the below configuration matches this need

---------------------------------------------------------Configuration---------------

mls qos aggregate-policer 20Mbps-Limit-MLS 20000000 8000 exceed-action drop
mls qos

!

!

class-map match-all ipclass1
match access-group 1
class-map match-all 4Mbps-Policy-agg
!
!
policy-map 20Mbps-Policy-agg
class ipclass1
police aggregate 20Mbps-Limit-MLS
trust cos
!

access-list 1 permit any
!
interface FastEthernet0/1
description "20M-Rate-Limit-Port"
switchport access vlan 20
switchport mode access
service-policy input 20Mbps-Policy-agg
!

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards