cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3534
Views
5
Helpful
12
Replies

Switch replacement procedure 3560G to 3750X

adi822001
Level 1
Level 1

                   Hello  Cisco experts,

My company will replace two 3560G (HSRP active Standby) with 2 3750X ( will be stacked)  switches in the near future.

I need to make a switch replacement procedure ( starting from removing the 3560s  until the 3750x are put online, but i think i need your advice.

I have  google it, searched cisco website documents, various forums but i couldnt find something to suit my needs.

My approach will be to

1. backup the standby  3560 config (traffi will flow through the active 3560) .

2. remove the plug of 3560and put in one 3750x. Configure 3750x to accept traffic and to be the  stack master.

3. backup the config on the remaining 3560 and remove it.

4. Plug in the second 3750x

5. Configure it as stack member.

Can you please advise me , point me to any document that shows a step by step procedure when replacing a cisco ( moving fr one mode to another)

Thank you in advance for your help.

PS :Excuse my English. I am japanese. :d

エイドリアン
3 Accepted Solutions

Accepted Solutions

Leo Laohoo
Hall of Fame
Hall of Fame
3750X ( will be stacked)  switches in the near future.

Have you purchased the 3750X yet?  If not, go for the 3850.  The exact corresponding model of the 3850 is priced THE SAME but with greater performance.

1.  Because you can stack the 3750X/3850, there's no need to configure HSRP.

2.  You first configure the stack master with the config above.  But your interface naming convention will have to change.

3750/3850 follow the same interface naming syntax:  Gigabit //Port

So you re-compile your interface configuration for the first switch as GigabitEthernet 1/0/24.  The second switch would be GigabitEthernet 2/0/12.

View solution in original post

Here's a good proceedure to install a stack of 3750X:

1.  DO NOT APPLY POWER to all switches;

2.  Install the Master switch;

3.  Power up the Master switch;

4.  Configure master priority using the command "switch 1 priority 15";

5.  Configure the succeeding switch members using the command "switch X provisioning <3750 model number>";

6.  Configure the switch stack;

7.  Attach the rest of the switch members;

8.  DO NOT provide power to the stack members;

9.  Attach stacking cable;

10.  Power up the stack member ONE AT A TIME and ACCORDING to the order

11.  Put 15 seconds interval before powering up the next switch member.

View solution in original post

Before I install the 3750 stack, I would need to archive and backup the 3560Gs and then unplug them.

I don't think this is possible.  At the end of the day, you need to MOVE your links from the 3560G to the 3750 stack.  How you can achieve this without any "disruptions" is beyond me.

View solution in original post

12 Replies 12

JohnTylerPearce
Level 7
Level 7

Adrian,

First, I understand that these two switches (3560Gs) are running HSRP. How do these switches fit in your network?

Second, you can go ahead and power on and configure the 3750 stack, so there is very minimal downtime, when you get ready to do a switchover.

Thanks for replying John,

I am pasting the two 3560G sh run :

Location : Data center aggregation

Vlan 10 --- WAN, Vlan 20 FW; NET , Vlan 40 DMZ  , VLAN 50 Vmware,

Is there a written procedure when transition between switches ?

HSRP Active

version 12.2

!

interface GigabitEthernet0/1

switchport access vlan 10

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/2

switchport access vlan 10

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/3

switchport access vlan 20

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/4

switchport access vlan 20

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/5

switchport access vlan 30

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/6

switchport access vlan 30

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/7

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/8

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/9

switchport access vlan 50

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/10

switchport access vlan 50

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/11

switchport access vlan 60

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/12

switchport access vlan 60

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/13

switchport access vlan 70

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/14

switchport access vlan 70

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/15

switchport access vlan 80

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/16

switchport access vlan 80

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/17

switchport access vlan 90

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/18

switchport access vlan 90

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/19

switchport access vlan 100

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/20

switchport access vlan 100

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/21

speed 100

duplex full

!

interface GigabitEthernet0/22

switchport access vlan 50

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/23

switchport access vlan 50

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/24

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10,20,30,50,60,70,80,90,100

switchport mode trunk

!

interface GigabitEthernet0/25

!

interface GigabitEthernet0/26

!

interface GigabitEthernet0/27

!

interface GigabitEthernet0/28

!

interface Vlan1

ip address 192.168.1.201 255.255.255.0

no ip redirects

standby 0 ip 192.168.1.20

standby 0 priority 105

standby 0 preempt

!

interface Vlan10

ip address 172.20.10.2 255.255.255.0

no ip redirects

standby 1 ip 172.20.10.1

standby 1 priority 105

standby 1 preempt

!

interface Vlan20

ip address 172.20.20.2 255.255.255.0

no ip redirects

standby 2 ip 172.20.20.1

standby 2 priority 105

standby 2 preempt

!

interface Vlan30

ip address 172.20.30.2 255.255.255.0

no ip redirects

standby 3 ip 172.20.30.1

standby 3 priority 105

standby 3 preempt

!

interface Vlan40

ip address 172.20.40.2 255.255.255.0

no ip redirects

standby 4 ip 172.20.40.1

standby 4 priority 105

standby 4 preempt

!

interface Vlan50

ip address 172.20.50.2 255.255.255.0

no ip redirects

standby 5 ip 172.20.50.1

standby 5 priority 105

standby 5 preempt

!

interface Vlan60

ip address 172.20.60.2 255.255.255.0

no ip redirects

standby 6 ip 172.20.60.1

standby 6 priority 105

standby 6 preempt

!

interface Vlan70

ip address 172.20.70.2 255.255.255.0

no ip redirects

standby 7 ip 172.20.70.1

standby 7 priority 105

standby 7 preempt

!

interface Vlan80

ip address 172.20.80.2 255.255.255.0

no ip redirects

standby 8 ip 172.20.80.1

standby 8 priority 105

standby 8 preempt

!

interface Vlan90

ip address 172.20.90.2 255.255.255.0

no ip redirects

standby 9 ip 172.20.90.1

standby 9 priority 105

standby 9 preempt

!

interface Vlan100

ip address 172.20.100.2 255.255.255.0

no ip redirects

standby 10 ip 172.20.100.1

standby 10 priority 105

standby 10 preempt

Second

version 12.2

interface GigabitEthernet0/1

switchport access vlan 10

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/2

switchport access vlan 10

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/3

switchport access vlan 20

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/4

switchport access vlan 20

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/5

switchport access vlan 30

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/6

switchport access vlan 30

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/7

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/8

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/9

switchport access vlan 50

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/10

switchport access vlan 50

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/11

switchport access vlan 60

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/12

switchport access vlan 60

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/13

switchport access vlan 70

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/14

switchport access vlan 70

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/15

switchport access vlan 80

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/16

switchport access vlan 80

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/17

switchport access vlan 90

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/18

switchport access vlan 90

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/19

switchport access vlan 100

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/20

switchport access vlan 100

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/21

!

interface GigabitEthernet0/22

switchport access vlan 50

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/23

switchport access vlan 50

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet0/24

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10,20,30,50,60,70,80,90,100

switchport mode trunk

!

interface GigabitEthernet0/25

!

interface GigabitEthernet0/26

!

interface GigabitEthernet0/27

!

interface GigabitEthernet0/28

!

interface Vlan1

ip address 192.168.1.202 255.255.255.0

no ip redirects

standby ip 192.168.1.20

standby preempt

!

interface Vlan10

ip address 172.20.10.3 255.255.255.0

no ip redirects

standby 1 ip 172.20.10.1

standby 1 preempt

!

interface Vlan20

ip address 172.20.20.3 255.255.255.0

no ip redirects

standby 2 ip 172.20.20.1

standby 2 preempt

!

interface Vlan30

ip address 172.20.30.3 255.255.255.0

no ip redirects

standby 3 ip 172.20.30.1

standby 3 preempt

!

interface Vlan40

ip address 172.20.40.3 255.255.255.0

no ip redirects

standby 4 ip 172.20.40.1

standby 4 preempt

!

interface Vlan50

ip address 172.20.50.3 255.255.255.0

no ip redirects

standby 5 ip 172.20.50.1

standby 5 preempt

!

interface Vlan60

ip address 172.20.60.3 255.255.255.0

standby 6 ip 172.20.60.1

standby 6 preempt

!

interface Vlan70

ip address 172.20.70.3 255.255.255.0

no ip redirects

standby 7 ip 172.20.70.1

standby 7 preempt

!

interface Vlan80

ip address 172.20.80.3 255.255.255.0

no ip redirects

standby 8 ip 172.20.80.1

standby 8 preempt

!

interface Vlan90

ip address 172.20.90.3 255.255.255.0

no ip redirects

standby 9 ip 172.20.90.1

standby 9 preempt

!

interface Vlan100

ip address 172.20.100.3 255.255.255.0

no ip redirects

standby 10 ip 172.20.100.1

standby 10 preempt

Thsnks

エイドリアン

Leo Laohoo
Hall of Fame
Hall of Fame
3750X ( will be stacked)  switches in the near future.

Have you purchased the 3750X yet?  If not, go for the 3850.  The exact corresponding model of the 3850 is priced THE SAME but with greater performance.

1.  Because you can stack the 3750X/3850, there's no need to configure HSRP.

2.  You first configure the stack master with the config above.  But your interface naming convention will have to change.

3750/3850 follow the same interface naming syntax:  Gigabit //Port

So you re-compile your interface configuration for the first switch as GigabitEthernet 1/0/24.  The second switch would be GigabitEthernet 2/0/12.

Thanks for your reply Leo,

The company has purchased the 3750x switches.

Can you guide me with  step-by-step instructions ?

My opinion

1. Remove 3560G switch

a) Archive backup before remove the 3560 switch we need to save its configuration; b) Mark the labels on the connect switch cables and record each corresponding switch port;

c) Shutdown, power off and unplug all the connecting cables;

d) Remove the switch out of Cabinet

2 Install 3750x Switch

a) Configure  Switch;

b) Put  switch in cabinet;

c) In accordance with the original line corresponds to the original plan plugged;

d) Test connection 1

Thanks

エイドリアン

Here's a good proceedure to install a stack of 3750X:

1.  DO NOT APPLY POWER to all switches;

2.  Install the Master switch;

3.  Power up the Master switch;

4.  Configure master priority using the command "switch 1 priority 15";

5.  Configure the succeeding switch members using the command "switch X provisioning <3750 model number>";

6.  Configure the switch stack;

7.  Attach the rest of the switch members;

8.  DO NOT provide power to the stack members;

9.  Attach stacking cable;

10.  Power up the stack member ONE AT A TIME and ACCORDING to the order

11.  Put 15 seconds interval before powering up the next switch member.

Hi Leo,

Thanks for your detailed procedure.

It is very helpful.

One more query.

Before I install the 3750 stack, I would need to archive and backup the 3560Gs and then unplug them.

Can I do the switchover live without disrupting the traffic? Or a maintenance window is mandatory?

Now the 2 3560G are in production.

Thank you

エイドリアン

Before I install the 3750 stack, I would need to archive and backup the 3560Gs and then unplug them.

I don't think this is possible.  At the end of the day, you need to MOVE your links from the 3560G to the 3750 stack.  How you can achieve this without any "disruptions" is beyond me.

Thank you Leo,

I got the point now.

Thank you for your great support.

エイドリアン

Adrian,

As suggested you get MW schedule to perform this action as this would cause the distruption on your network. Reason behine that you are going to replace th switches and makeing the new as stack.

Hope all your query's are answered by leo may I request you to kindly rate his posts and mark this thread as answered so that other be benefited with this thread in future.

Thanks for your understanding.

REgards

Inayath

*Plz rate all usefull posts and mark the thread as answered if solution been provided to you.

Thanks for the ratings, Adrian. 

Another thing, Adrian.

If you are in good terms with your Cisco account team, you could (potentially) get them to replace your 3750X with 3850 at no cost.

Thanks Leo,

I will try communicate this to my bosses but japanese companies are very strict when changing something.

Thank you again for your great support.

エイドリアン

エイドリアン
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card